Kdenlive Fedora 10 RPM's for testing

Hello,

 

I made test Fedora 10 repository for Kdenlive (32 and 64-bits packets + sources):

So, be free to try&test them.

Instructions for setting up repository :

First of all users must have installed RPM Fusion repository:

su -c 'rpm -Uvh http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpmhttp://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm'

then type this:

su -c 'rpm -ivh http://wiki.open.hr/~zpintar/fedora10/zpintar-repo-1.0-1.fc10.noarch.rpm'


su -c 'yum update'
su -c 'yum install kdenlive'

It contains the latest subversions of Kdenlive and MLT programs.

 

 

Hi,

I would like to test packages but I'm currently using x86_64 env.

As I'm able to build kdenlive with KBW under x86_64 Fedora 10, can you address me on how to package x86_64 rpms for Fedora10 from KBW build?

thanks

luca



Hello...

Ad first, you can not build RPMs by the KBW. You must use configure/make/ make install routine under the RPM's .spec file.

So, I suggest to you that be patient for a while because, maybe I'll try to distribute real RPM's (no prereleases) to Fedora community.

Now I just studying Fedora's Packages Guidelines and when finish I will make RPM's for 32 and 64-bit environment.

 

I updated my first post and put repository information.

Repo now contain 32 and 64 bits versions of Kdenlive.

Fee free to test them.

 

I changed baseurl of my repository, so accept that please...

Hi Grof,

I've done a test on my Dell M90 laptop (i386, nvidia).. all installed and up and running quickly.
Rendered a quick test video using h264, no problems at all.

The only issue I've seen is where kdenlive crashes if you move from clip/project monitor back to any clip in the project tree.
This is a known issue on Fedora that has been around for some time now.

Cheers,
Andrew

Hmm, I'll proceed this bug to developers...or can you fill the Mantis?

 

Edit:

Keep my repo open... I periodically update kdenlive's subersions packages...

I've opened issue 688 quite some time ago.

It looks like the same issue as 684.

Home
- Fedora 10 x86_64
- 8GB Ram
- ATI 4870x2 2Gb Video (fglrx 9.2-2.fc10)

Work: 
- Fedora 10 i386
- 4GB Ram
- nVidia Quadro FX 2500M (akmod-nvidia 180.29-1.fc10)

I have the same issue on both systems.

My workaround for the issue is to add clips first, then edit. If I need to add any other clips I have to restart kdenlive (or let it crash).
I save frequently as I work

Andrew

 OK, this is workaround, but its frustrating and must be resolved....

Thank you very much for setting up the fedora-zpintar repo. However there is no repodata/repomd.xml for i386 so I can't take advantage of the repo or any of the rpms. Can you set up the repodata/repomd.xml for i386?

Thank you!

 

Resolved!

My fault, sorry...

Repo news! - IMPORTANT!

 

I applied GPG signing of RPM packages for security reasons, so please, delete your current repo config data with:

su -c ' rm /etc/yum.repos.d/fedora-zpintar.repo'

and look at the first post in this thread!

 

Thanks.

If you have any repo configuration problems, please post here.

See also bug #410:

 

http://www.kdenlive.org/mantis/view.php?id=410

 

..... same issue.

I'm now getting used to it; other than this Kdenlive is coming more and more stable.

Ciao

Luca