Kdenlive installation

Help, Please Help.

I was so excited yesterday to find a Video package that I could run on my Ubuntu system. I am a brand new Linux user (2 weeks) and having trouble coming to terms with the 'jargin' used in all the forums. Install from CODE, from SOURCE, compile, binary package etc etc ..............WHAT??????? This request for help may even be in the wrong forum.

I thought I was doing quite well until I tried to download and install 'Kdenlive'. Is there a step-by-step anywhere on the net?

I would appreciate any advice.

thanks

Russ

You dont need to worry about that!

Just look for your packet manager in the menu and type in a search for kdenlive and install from there.

or

You could open the terminal and type 'sudo apt-get update'and then 'sudo apt-get install kdenlive' without the quotes!

good luck!

Thanks, I just attempted the Synaptic Packet Manager but keep getting "... unresolved dependencies."

When I try the 'Terminal' I also get 'unmet dependencies' as follows:
The following packages have unmet dependencies:
kdenlive: Depends: kdebase-runtime (>= 4:4.2.1) but it is not going to be installed
Depends: kdelibs5 (>= 4:4.2.1) but it is not going to be installed
Depends: libmlt++2 (>= 0.4.4) but it is not going to be installed
Depends: libmlt1 (>= 0.4.4) but it is not going to be installed
Depends: libqt4-dbus (>= 4.5.0~+rc1) but it is not going to be installed
Depends: libqt4-network (>= 4.5.0~+rc1) but it is not going to be installed
Depends: libqt4-svg (>= 4.5.0~+rc1) but it is not going to be installed
Depends: libqt4-xml (>= 4.5.0~+rc1) but it is not going to be installed
Depends: libqtcore4 (>= 4.5.0~+rc1) but it is not going to be installed
Depends: libqtgui4 (>= 4.5.0~+rc1) but it is not going to be installed
Depends: melt (>= 0.4.4) but it is not going to be installed
Depends: ffmpeg but it is not going to be installed
Depends: libavdevice-unstripped-52 but it is not going to be installed
Depends: libavfilter-unstripped-0 but it is not going to be installed
Depends: frei0r-plugins but it is not installable
E: Broken packages

How do I go about resolving these?

Thanks

Russ

To launch Synaptic, choose System > Administration > Synaptic Package Manager. You can call up the software preferences panel from within Synaptic by selecting Repositories from the Settings menu.
I'm not familiar with Ubuntu but from above you should see some lines similar to below;

deb http://ppa.launchpad.net/sunab/ppa/ubuntu jaunty main

You need to add this to the list. So copy and paste these into your repositories list. Select apply. You should get a screen telling you to update your list - click ok.

Open your terminal (like a dos screen). type in 'sudo apt-key update' (without the quotes)

Now go back to synaptic and download Kdenlive.

Stick with it, it's worth it!

No luck

I am unable to add http://ppa.launchpad.net/baudm/ubuntu as it tels me that the ATP line is incomplete.
'http://ppa.launchpad.net/sunab/ppa/ubuntu jauntey main' is already installed.

but still no luck

Russ

Sorry Russ, my mistake,

go here and copy in the whole line inc. the unbookmarked bits.

http://www.kdenlive.org/user-manual/downloading-and-installing-kdenlive/...

I've corrected the above also for future reference!

Hi Muttley

Sorry to keep burdening you like this but I am still not out of the woods.

I ran the items on the link page but am still picking up the following errors, is there another program framework that I should be installing first, eg. FFmpeg?

The errors
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
kdenlive: Depends: kdebase-runtime (>= 4:4.2.1) but it is not going to be installed
Depends: kdelibs5 (>= 4:4.2.1) but it is not going to be installed
Depends: libmlt++2 (>= 0.4.4) but it is not going to be installed
Depends: libmlt1 (>= 0.4.4) but it is not going to be installed
Depends: libqt4-dbus (>= 4.5.0~+rc1) but it is not going to be installed
Depends: libqt4-network (>= 4.5.0~+rc1) but it is not going to be installed
Depends: libqt4-svg (>= 4.5.0~+rc1) but it is not going to be installed
Depends: libqt4-xml (>= 4.5.0~+rc1) but it is not going to be installed
Depends: libqtcore4 (>= 4.5.0~+rc1) but it is not going to be installed
Depends: libqtgui4 (>= 4.5.0~+rc1) but it is not going to be installed
Depends: melt (>= 0.4.4) but it is not going to be installed
Depends: ffmpeg but it is not going to be installed
Depends: libavdevice-unstripped-52 but it is not going to be installed
Depends: libavfilter-unstripped-0 but it is not going to be installed
Depends: frei0r-plugins but it is not installable
E: Broken packages

Thanks
Russ

What version of Ubuntu are you running?
can you copy and paste the lines from your repositories here!
which ones have a tick next to them?
You could try installing these individually i.e. sudo apt-get kdelibs5 - but you shouldn't have to.
my guess is you haven't got your third party repositories enabled (ticked)

your not troubling me at all, so don't worry!

I am running Ubuntu 8.04.1 LTS Desktop Edition
My Repositories are:

not ticked http://[Ubuntu 8.04.1_Hardy Heron_-Release.......
ticked http://archive.canoncal.com/ubuntu hardy partner
ticked http://archive.canoncal.com/ubuntu hardy partner (Source code)
ticked http://ppa.launchpad.net/lure/video/ubunto jaunty main
ticked http://ppa.launchpad.net/sunab/ppa/ubunto jaunty main

I am currently trying to install FFmpeg

Thanks
Russ

Hi Russ

You should re-install Ubuntu9.04(Jaunty) in order to install kdenlive0.75 without complicated problems. You can use the repositry of "deb http://ppa.launchpad.net/sunab/ppa/ubuntu jaunty main" for the installation of kdenlive0.75 after installing ubuntu jaunty. Enjoy!

You can upgrade Ubuntu by 'sudo apt-get install dist-upgrade'

Thanks muttley but I get an error "...

russ@russ-desktop:~$ sudo apt-get install dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package dist-upgrade
russ@russ-desktop:~$

tried it twice

Russ

try sudo apt-get dist-upgrade

I'm having a bad day ;-)

If all else fails, download a copy of Ubuntu here = http://www.ubuntu.com/getubuntu/download

Burn it to a disk and install as normal.

sudo apt-get update
to update package list

Then:
sudo apt-get dist-upgrade

to upgrade system.

Still not getting very far with the upgrade to 9.4
Upgrade manager dose not show that there is an upgrade available. Maby because I am using 8.04.1
When I try update-notifier-kde -u from the Run Application window, I get an error.. Could not open location 'file:///home/russ/update-notifier-kde%20-u'
When I run sudo apt-get dist-upgrade all I get in return is

Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Where do I find information on the version that is actually running on my PC? !!! Sorry, found it in System Monitor. I am running 8.04

Russ

Hardy was not a good distribution! I've just read around and other people have had similar problems. There are ways around this. But, you will be better doing a fresh install from the link above I gave you. Just burn it to disk and run as normal. You may need to enter your bios (press delete on startup) to change your boot order to cdrom first. Jaunty is much better than Hardy Unless you have a very old PC.

If you need to burn the disc image in Hardy use k3b (available from your synaptic package manager OR sudo apt-get install k3b)

Thanks I will try that

Hi guys,

I'm new at this, may be someone can help me. I'm trying to render in Kdenlive and therefore I installes the following:

sudo apt-get install libavcodec-unstripped-52 libavdevice-unstripped-52 libavfilter-unstripped-0 libavformat-unstripped-52 libavutil-unstripped-49 libpostproc-unstripped-51 libswscale-unstripped-0

but I got this message: Unable to locate package libavfilter-unstripped-0

Does anyone have an idea as of what I can do?

Thanks!
Armando

You do not need libavfilter-unstripped; we do not yet use libavfilter.