kdenlive support for libmlt4?

I was having issues with VLC not playing any hd(The new version works great, even with .mts files!!!) content so I installed the newest version 1.1.8. In order to install it, it had to remove kdenlive. I was hoping after it installed, I would be able to install kdenlive again but no luck. It is saying:

"The following packages have unmet dependencies:
kdenlive: Depends: libmlt3 but it is not going to be installed
E: Broken packages"

The new version of VLC uses libmlt4. Is it possible to install kdenlive using libmlt4 and if so how do I make that happen?

Thanks for your time

Bryan

VLC uses libmlt?! That seems strange. I would be very surprised. Maybe you did some general package upgrade to get that but your Kdenlive package still needs libmlt3. The next version of Kdenlive will use libmlt4.

Thank you for the reply. It must have been a update like you said. Disabled all the repos except for the one specified here and re-downloaded it without a problem.

Thanks again!

After re-installing I tried adding video files and it crashes with these details:

Application: Kdenlive (kdenlive), signal: Segmentation fault
[Current thread is 1 (Thread 0xb786c710 (LWP 2318))]

Thread 3 (Thread 0xb43f6b70 (LWP 2325)):
#0 0x0069a422 in __kernel_vsyscall ()
#1 0x0059a342 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2 0x00f0e139 in mlt_consumer_get_frame () from /usr/lib/libmlt.so.4
#3 0xb43f61dc in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 2 (Thread 0xb4bf7b70 (LWP 2326)):
#0 0x0069a422 in __kernel_vsyscall ()
#1 0x0059a015 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2 0x090a44d9 in ?? () from /usr/lib/mlt/libmltsdl.so
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 1 (Thread 0xb786c710 (LWP 2318)):
[KCrash Handler]
#6 0x09433819 in sws_scale () from /usr/lib/i686/cmov/libswscale.so.0
#7 0x00000828 in ?? ()
#8 0x01932af3 in ?? () from /lib/tls/i686/cmov/libc.so.6
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

I had to restore to before I installed VLC in order to get kdenlive working. VLC's bleeding-edge repository updates several of the files that Kdenlive uses. At least I know its possible to watch HD on a older linux machine.