kdenlive: undefined symbol: _ZN3Mlt7Profile12set_explicitEi

I've been compiling kdenlive for a while now with great success. My last successful compile/run was version 0.8.1 rev.5721
Since then, the compile looks normal, but when I run kdenlive from the command line I get the following error:

kdenlive: symbol lookup error: kdenlive: undefined symbol: _ZN3Mlt7Profile12set_explicitEi

I can reinstall rev 5721 and it runs.
I have tried MLT from both the Packman repository (0.7.2) and compiling from source (0.7.3). Same issue.

Google didn't find any hits.
Any hints as to what happened and how to fix?

Running on:
OpenSuse 11.4 64-bit
KDE 4.6.4

Thanks

If you want to compile Kdenlive from svn (version 0.8.1), you need MLT from git (0.7.3). The error when launching Kdenlive means that you didn't uninstall a previous version of MLT (probably 0.7.2), and Kdenlive is linked against it.

Make sure to remove all MLT stuff in /usr/lib and /usr/local/lib

Then reinstall MLT from git and recompile Kdenlive.

It should work after that.

j-b-m

You're a genius.
I removed all traces of mlt, libmlt, pkgconfig (related to mlt)
Installed mlt from source. OK
Installed kdenlive from source. FAILED

The kdenlive install is looking for a pkgconfig reference for mlt. I see 2 files /usr/lib/pkgconfig/mlt*. Hmmm... I copied to /usr/local/lib/pkgconfig.

Installed kdenlive from source. OK

kdenlive 0.8.1 (5729) now runs.

Thanks for the help