Kdenlive wont start after compiled...?

Thanks to help from the kdenlive builder wizard and the guy who made it, I've successfully compiled kdenlive 0.7... I think. There's one small problem: every time I start kdenlive up I get this error:

$ kdenlive
kdenlive: symbol lookup error: /usr/lib/libavcodec.so.52: undefined symbol: av_lfg_init

I installed it in /usr so it should work right... Am I missing something? Does this have anything to do with the builder wizard wanting me to install avformat, which I already have installed? Thanks in advance!

Was ffmpeg installed previously on your machine? It kind of looks like kdenlive is trying to reference a shared object from old ffmpeg installation.

Try removing any previous packages of ffmpeg from your machine and recompile kdenlive.

- Si

Sloshy wrote:
Thanks to help from the kdenlive builder wizard and the guy who made it, I've successfully compiled kdenlive 0.7... I think. There's one small problem: every time I start kdenlive up I get this error:

$ kdenlive
kdenlive: symbol lookup error: /usr/lib/libavcodec.so.52: undefined symbol: av_lfg_init

I installed it in /usr so it should work right... Am I missing something? Does this have anything to do with the builder wizard wanting me to install avformat, which I already have installed? Thanks in advance!

Two things: there is a bug in the wizard (quite embarrassing, really), where it sometimes thinks you have missed avformat, when it is not the case. If you got a success from the wizard, and it says something about you missing avformat, its complete rubbish, and your build went fine.

Secondly: If you used the wizard, please consider using kdenlive_start to start kdenlive. I do not know if it will help with your specific error - try sweller's advice too.

Regards

Mads

sweller wrote:
Was ffmpeg installed previously on your machine? It kind of looks like kdenlive is trying to reference a shared object from old ffmpeg installation.

Try removing any previous packages of ffmpeg from your machine and recompile kdenlive.

- Si

yes, it was previously installed but i only removed the package... *tries completely remove then compile*

nope doesn't help... I think it has something to do with avutil or avformat or something like that... but when I remove them all of my applications that used them have to be removed... and thats a LOT. I really don't know what to do here...

If it helps i'm running k/ubuntu (kde and gnome installed) 8.10 with backports enabled.

Do you have libavutil.so installed?

You're probably getting this error because you need another library that defines the av_lfg_init symbol.

Run objdump -p libavcodec.so.52 | grep NEEDED

It will output all the share libs you need to be linked to. eg:

NEEDED libavutil.so.49
NEEDED libz.so.1
NEEDED libm.so.6
NEEDED libfaac.so.0
NEEDED libfaad.so.0
NEEDED libmp3lame.so.0
NEEDED libvorbisenc.so.2
NEEDED libvorbis.so.0
NEEDED libpthread.so.0
NEEDED libc.so.6

Now make sure all those so's are in /usr/lib or /usr/lib64