millions of errors on start up of kdenlive compiled from svn

When starting up kdenlive compiled from svn just now I get a continuous stream of error messages (causing nearly 100% of CPU usage):

QImage::setPixel: coordinate (0,0) out of range
QImage::pixel: coordinate (0,0) out of range

Despite that, Kdenlive seems to eventually start up, and I can load a clip or go through the configuration options. This is on debian SID, qt version 4.6.3-1.

kdenlive rev 4628 (mlt and ffmpeg are also current svn versions, but perhaps that doesn't matter)

Any ideas? Other info needed?

I also have this issue.
Looks like this is related to the new color correction monitors.

I'll look into this later.

What would help is, open the kdenlive project with qtcreator (Just open the CMakeLists.txt) and run it in debug mode, as soon as it starts reporting the errors press pause (or Shift-F5) in qtcreator.

Please let me know whether you still get this error in r4631.

It still happens for me.
I'll try the qtcreator thing you proposed before.

In qtcreator, first time I tried, it segfaulted with the following stack trace:

0 *__GI_getenv getenv.c 84 0xb631ba14
1 qgetenv(char const*) /usr/lib/libQtCore.so.4 0 0xb70ce745
2 qt_message_output(QtMsgType, char const*) /usr/lib/libQtCore.so.4 0 0xb70cefbd
3 ?? /usr/lib/libQtCore.so.4 0 0xb70cf15a
4 qWarning(char const*, ...) /usr/lib/libQtCore.so.4 0 0xb70cf339
5 QImage::setPixel(int, int, unsigned int) /usr/lib/libQtGui.so.4 0 0xb67a157d
6 QImage::setPixel qimage.h 343 0x083066ce
7 VectorscopeGenerator::calculateVectorscope vectorscopegenerator.cpp 184 0x083066ce
8 Vectorscope::renderScope vectorscope.cpp 209 0x082f9910
9 QtConcurrent::StoredMemberFunctionPointerCall1::runFunctor qtconcurrentstoredfunctioncall.h 410 0x082f606f
10 QtConcurrent::RunFunctionTask::run qtconcurrentrunbase.h 103 0x082f65d6
11 ?? /usr/lib/libQtCore.so.4 0 0xb70ccec9
12 ?? /usr/lib/libQtCore.so.4 0 0xb70d7fae
13 start_thread pthread_create.c 300 0xb62d9955
14 clone clone.S 130 0xb63b910e

The second time (without changing anything else) it started. If I interrupt it, ther e's a separate thread with ID 2 that contains the following stack trace:

0 __kernel_vsyscall 0 0xb7fe2424
1 write syscall-template.S 82 0xb63aa25b
2 _IO_new_file_write fileops.c 1276 0xb6353f54
3 new_do_write fileops.c 530 0xb6353bdf
4 _IO_new_file_xsputn fileops.c 1370 0xb6353ea6
5 buffered_vfprintf vfprintf.c 2275 0xb632f058
6 _IO_vfprintf_internal vfprintf.c 1306 0xb6329f13
7 __fprintf fprintf.c 33 0xb633421f
8 qt_message_output(QtMsgType, char const*) /usr/lib/libQtCore.so.4 0 0xb70cef8e
9 ?? /usr/lib/libQtCore.so.4 0 0xb70cf15a
10 qWarning(char const*, ...) /usr/lib/libQtCore.so.4 0 0xb70cf339
11 QImage::pixel(int, int) const /usr/lib/libQtGui.so.4 0 0xb6796270
12 QImage::pixel qimage.h 342 0x083065d2
13 VectorscopeGenerator::calculateVectorscope vectorscopegenerator.cpp 182 0x083065d2
14 Vectorscope::renderScope vectorscope.cpp 209 0x082f9910
15 QtConcurrent::StoredMemberFunctionPointerCall1::runFunctor qtconcurrentstoredfunctioncall.h 410 0x082f606f
16 QtConcurrent::RunFunctionTask::run qtconcurrentrunbase.h 103 0x082f65d6
17 ?? /usr/lib/libQtCore.so.4 0 0xb70ccec9
18 ?? /usr/lib/libQtCore.so.4 0 0xb70d7fae
19 start_thread pthread_create.c 300 0xb62d9955
20 clone clone.S 130 0xb63b910e
...

Both things seem to point towards some VectorScope thing?

I've fixed an error in the current SVN now. (Have been checking with the wrong boundaries.)
Could you please re-check?

In the debugger I see that in QImage VectorscopeGenerator::calculateVectorscope
(inside inside case PaintMode_Green2)

avgPxPerPx == inf

because vectorScopeSize.width() and vectorScopeSize.height() both return 0.

Not sure if that info can help you any further.

Hello,

The problem seems to be solved by initializing Vectorscope::cw with 0 in the Vectorscope::Vectorscope constructor.

Best regards,
Stefaan.

This should in fact be fixed as well.
Or could you still reproduce the error messages in current SVN? (r4631)

Thanks for reporting and debugging btw.
Simon

I still have the problem with latest svn 4636.
And intializating cw to 0 in Vectorscope::Vectorscope still solves the problem ;)

(apparently it contains some garbage value causing wrong paths to be taken)

Best regards,
Stefaan.

It should not be required to initialize cw. If it is, then something in the design of the abstract widget is not working the way I thought it to.

Could you please run the debugger again? It must be hanging at a different position now.

thanks,
Simon

Hello, I'm sorry it was solved indeed.
I normally use prefix=/usr, but the build by qtcreator uses prefix=/usr/local causing me to start the wrong build when I checked the problem.

Thanks, and best regards,
Stefaan.