Missing avformat module

I realize this type of thing has been covered in other threads, however obviously my problem is different - and it is stubborn enough to where I just cannot figure out what is wrong.

I'm trying to run with the latest packages Debian Multimedia/testing. I can never get "melt -query producers" to show avformat, even though /usr/lib/mlt/libmltavformat.so exists and there are no broken links (ldd) with any executable or shared library that I can find.

ffmpeg, melt, kdenlive, etc. - all coming from the same repository (again, Debian Multimedia / testing).

I've tried removing melt, ffmpeg, kdenlive, libavformat52, etc. - then looking for leftover shared libraries, could find none, reinstalled, etc.

I'll get the basics out of the way first. Any hints or suggestions would be most appreciated!

FFmpeg version SVN-r25838, Copyright (c) 2000-2010 the FFmpeg developers
built on Jan 21 2011 08:21:58 with gcc 4.4.5
configuration: --enable-libdc1394 --prefix=/usr --extra-cflags='-Wall -g ' --cc='ccache cc' --enable-shared --enable-libmp3lame --enable-gpl --enable-libvorbis --enable-pthreads --enable-libfaac --enable-libxvid --enable-postproc --enable-x11grab --enable-libgsm --enable-libtheora --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libx264 --enable-libspeex --enable-nonfree --disable-stripping --enable-avfilter --enable-libdirac --disable-decoder=libdirac --enable-libschroedinger --disable-encoder=libschroedinger --enable-version3 --enable-libopenjpeg --enable-libvpx --enable-librtmp --extra-libs=-lgcrypt --disable-altivec --disable-armv5te --disable-armv6 --disable-vis
libavutil 50.33. 0 / 50.33. 0
libavcore 0.14. 0 / 0.14. 0
libavcodec 52.97. 2 / 52.97. 2
libavformat 52.87. 1 / 52.87. 1
libavdevice 52. 2. 2 / 52. 2. 2
libavfilter 1.65. 0 / 1.65. 0
libswscale 0.12. 0 / 0.12. 0
libpostproc 51. 2. 0 / 51. 2. 0

$ kdenlive --version
Qt: 4.6.3
KDE Development Platform: 4.4.5 (KDE 4.4.5)
Kdenlive: 0.7.8

MLT melt 0.6.2

# ldd /usr/lib/mlt/libmltavformat.so
linux-vdso.so.1 => (0x00007fff347ff000)
libmlt.so.3 => /usr/lib/libmlt.so.3 (0x00007feddce80000)
libpthread.so.0 => /lib/libpthread.so.0 (0x00007feddcc64000)
libavformat.so.52 => /usr/lib/libavformat.so.52 (0x00007feddc988000)
libavcodec.so.52 => /usr/lib/libavcodec.so.52 (0x00007feddbcac000)
libavutil.so.50 => /usr/lib/libavutil.so.50 (0x00007feddba94000)
libswscale.so.0 => /usr/lib/libswscale.so.0 (0x00007feddb85b000)
libavdevice.so.52 => /usr/lib/libavdevice.so.52 (0x00007feddb64e000)
libc.so.6 => /lib/libc.so.6 (0x00007feddb2ed000)
libdl.so.2 => /lib/libdl.so.2 (0x00007feddb0e8000)
/lib64/ld-linux-x86-64.so.2 (0x00007feddd2da000)
libavcore.so.0 => /usr/lib/libavcore.so.0 (0x00007feddaee2000)
libm.so.6 => /lib/libm.so.6 (0x00007feddac60000)
librtmp.so.0 => /usr/lib/librtmp.so.0 (0x00007feddaa47000)
libz.so.1 => /usr/lib/libz.so.1 (0x00007fedda830000)
libbz2.so.1.0 => /lib/libbz2.so.1.0 (0x00007fedda620000)
libxvidcore.so.4 => /usr/lib/libxvidcore.so.4 (0x00007fedda312000)
libx264.so.112 => /usr/lib/libx264.so.112 (0x00007fedda06b000)
libvpx.so.0 => /usr/lib/libvpx.so.0 (0x00007fedd9c4b000)
libvorbisenc.so.2 => /usr/lib/libvorbisenc.so.2 (0x00007fedd977c000)
libvorbis.so.0 => /usr/lib/libvorbis.so.0 (0x00007fedd9550000)
libtheoraenc.so.1 => /usr/lib/libtheoraenc.so.1 (0x00007fedd9311000)
libtheoradec.so.1 => /usr/lib/libtheoradec.so.1 (0x00007fedd90f7000)
libspeex.so.1 => /usr/lib/libspeex.so.1 (0x00007fedd8ede000)
libschroedinger-1.0.so.0 => /usr/lib/libschroedinger-1.0.so.0 (0x00007fedd8c34000)
libopenjpeg.so.2 => /usr/lib/libopenjpeg.so.2 (0x00007fedd8a13000)
libopencore-amrwb.so.0 => /usr/lib/libopencore-amrwb.so.0 (0x00007fedd87f8000)
libopencore-amrnb.so.0 => /usr/lib/libopencore-amrnb.so.0 (0x00007fedd85bd000)
libmp3lame.so.0 => /usr/local/lib/libmp3lame.so.0 (0x00007fedd8327000)
libgsm.so.1 => /usr/lib/libgsm.so.1 (0x00007fedd811a000)
libfaac.so.0 => /usr/lib/libfaac.so.0 (0x00007fedd7f08000)
libdirac_encoder.so.0 => /usr/lib/libdirac_encoder.so.0 (0x00007fedd7c6f000)
libva.so.1 => /usr/lib/libva.so.1 (0x00007fedd7a10000)
libX11.so.6 => /usr/lib/libX11.so.6 (0x00007fedd76d4000)
libXext.so.6 => /usr/lib/libXext.so.6 (0x00007fedd74c2000)
libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0x00007fedd72bd000)
libjack.so.0 => /usr/lib/libjack.so.0 (0x00007fedd7079000)
libasound.so.2 => /usr/lib/libasound.so.2 (0x00007fedd6d94000)
libdc1394.so.22 => /usr/lib/libdc1394.so.22 (0x00007fedd6b1f000)
libgnutls.so.26 => /usr/lib/libgnutls.so.26 (0x00007fedd687b000)
libgcrypt.so.11 => /usr/lib/libgcrypt.so.11 (0x00007fedd6603000)
libogg.so.0 => /usr/lib/libogg.so.0 (0x00007fedd63fc000)
liborc-0.4.so.0 => /usr/lib/liborc-0.4.so.0 (0x00007fedd61a2000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007fedd5e8e000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00007fedd5c77000)
libxcb.so.1 => /usr/lib/libxcb.so.1 (0x00007fedd5a5b000)
librt.so.1 => /lib/librt.so.1 (0x00007fedd5852000)
libraw1394.so.11 => /usr/lib/libraw1394.so.11 (0x00007fedd5644000)
libusb-1.0.so.0 => /lib/libusb-1.0.so.0 (0x00007fedd5437000)
libtasn1.so.3 => /usr/lib/libtasn1.so.3 (0x00007fedd5226000)
libgpg-error.so.0 => /usr/lib/libgpg-error.so.0 (0x00007fedd5023000)
libXau.so.6 => /usr/lib/libXau.so.6 (0x00007fedd4e20000)
libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x00007fedd4c1a000)

Any clues? I'm pulling my hair out! Thanks in advance.

To be honest I would just build the current trunk version of kdenlive along with melt and ffmpeg etc. and ignore whatever versions your system has installed.

If you use the build script in the link below, kdenlive is built in ~/kdenlive/todaysdate/bin along with melt, ffpmpeg etc all pulled from git/svn. It also checks dependencies.
Kdenlive is then run by a start script in the same bin dir which sets up the environment. You don't need to uninstall any existing version on your system.

This links to the script I am using - and it worked today.
http://kdenlive.org/forum/kdenlive-0771-and-078-simultaneously#comment-1...

You will need to re-name ~/.kde4/share/config/kdenliverc if it exists, before running the new version.

Thank you, barjac - for having the patience to deal with an out-of-line anomaly. I appreciate the time you took to respond.

There was a problem getting the kdenlive source from git, but simply running that script again started the process and it is compiling now.

I will certainly report back.

libavcodec/libmp3lame.c: In function 'MP3lame_encode_init':
libavcodec/libmp3lame.c:63: error: implicit declaration of function 'lame_set_VBR_quality'
CC libavcodec/libx264.o
make: *** [libavcodec/libmp3lame.o] Error 1
make: *** Waiting for unfinished jobs....
KBWERROR: Unable to build ffmpeg
KBWTRACE: Entering feedback_result @ = FAILURE Some kind of error occured: Unable to build ffmpeg
KBWLOG: Process has finished. Reason: FAILURE Some kind of error occured: Unable to build ffmpeg

Argh.

For now edit line 66 to read:-

FFMPEG_SUPPORT_MP3=0

...and try again - you probably have a devel file missing.

do you have liblame-devel ?

Hello - and thank you. Commenting out MP3 support did the trick (after also installed libsox-dev).

I gotta say, that's quite a script. Good work!

Kdenlive is up and running again - something I haven't seen in months. With some new features!

I don't know what my problem was with the "official" Debian stuff; I know it can't be a repository problem, because they'd get a ton of flack. Something is obviously broken on my system, and while I couldn't figure out why, I guess it just doesn't matter anymore.

Thank you again for getting me up and running, barjac.

Hey - that script is nothing to do with me! I wish :-)

I was simply passing on the info I have gleaned over the last few months of using Kdenlive.

I read about that script in the thread that I pointed you to - I simply changed the ffmpeg repository info a few weeks ago when ffmpeg moved from svn to git.

Yes the new features are appearing on a regular basis, and it's getting more stable - I have noticed a big change in a short time.

When you re-build a new revision (I do it about once a week) just rename kdenliverc before you run the new version or it will get confused.
I just add the corresponding date string to the end of each one in case I need to revert to an earlier one.

Glad it's working for you - have fun!

Ah, OK - I'm not sure why I assumed that was your script.

But again - thanks for spending the time.

Looking forward to tinkering with Kdenlive again. :-)