Missing Xvid4 codec for rendering

Hi all,

once again I compiled kdelive (Version 0.7.7 (rev. 4182)) fresh from svn. Everything works fine, except one issue, I am not able to render Xvid4 file although, the Xvid codecs (libxvidcore4, libxvidcore4-dev) are installed.
I made no changes in the ffmpeg configuration. Just using the wizard, loading everything down and compiling.

Can anybody show me the pitfall I am trapping in?

Thanx
Tom

The builder wizard does not configure ffmpeg with --enable-libxvid. Is not FFmpeg's MPEG-4 good enough?

Hi Dan,

FFmpeg's MPEG-4 is of course good enough, no doubt about that. I was just wondering if I had made a miss configuration. And I was too lazy to checkout the wizard configuration for FFmpeg, shame on me.

Thanx for your answer!
Tom

BTW: Kdenlive is getting better and better!! Great tool.

I have enabled xvid in the script by adding :-

FFMPEG_SUPPORT_XVID=1

if test 1 = "$FFMPEG_SUPPORT_XVID" ; then
CONFIG[0]="${CONFIG[0]} --enable-libxvid"
fi

ffmpeg shows libxvid enabled :-

FFmpeg version git-47d62c9, Copyright (c) 2000-2011 the FFmpeg developers
built on Feb 12 2011 19:11:05 with gcc 4.4.3
configuration: --prefix=/home/baz/kdenlive/20110212 --disable-doc --disable-network --disable-ffserver --enable-gpl --enable-version3 --enable-shared --enable-debug --enable-pthreads --enable-libmp3lame --enable-libxvid --enable-libx264
libavutil 50. 37. 0 / 50. 37. 0
libavcore 0. 16. 1 / 0. 16. 1
libavcodec 52.112. 1 / 52.112. 1
libavformat 52. 99. 0 / 52. 99. 0
libavdevice 52. 2. 3 / 52. 2. 3
libavfilter 1. 75. 0 / 1. 75. 0
libswscale 0. 12. 0 / 0. 12. 0

However all the xvid4 options are still unavailable.
Any help would be appreciated.

Note:-
I could not build ffmpeg with --enable-libxvid unless I disabled libvpx with :-
FFMPEG_SUPPORT_LIBVPX=0
I have no idea why that was needed but with libvpx enabled there was an ffmpeg configure error:- libvpx decoder version must be >=0.9.1.