MLT 0.7.6 installed from source, but not found by Kdenlive (Solved)

well I finally found an open source video editor that does the trick. I installed kdenlive from the debian squeeze repos and was pretty satisfied with it. now I just want the latest version.

I installed the latest QJson and MLT from git without any problems. the only thing missing from my MLT compile was swfdec, but I compiled with --enable-gpl, ran make clean and make -j3 and installed successfully.

the only problem is, kdenlive doesn't seem to recognize that I have MLT 0.7.6. I get the following when I run cmake .. -DCMAKE_INSTALL_PREFIX=/usr :

Current Kdenlive Git revision is v0.8.2-270-g1988023
-- Found Qt-Version 4.6.3 (using /usr/bin/qmake)
-- Found X11: /usr/lib/libX11.so
CMake Warning (dev) at /usr/share/cmake-2.8/Modules/CheckCXXCompilerFlag.cmake:23 (INCLUDE):
File /usr/share/cmake-2.8/Modules/CheckCXXCompilerFlag.cmake includes
/usr/share/kde4/apps/cmake/modules/CheckCXXSourceCompiles.cmake (found via
CMAKE_MODULE_PATH) which shadows
/usr/share/cmake-2.8/Modules/CheckCXXSourceCompiles.cmake. This may cause
errors later on .

Policy CMP0017 is not set: Prefer files from the CMake module directory
when including from there. Run "cmake --help-policy CMP0017" for policy
details. Use the cmake_policy command to set the policy and suppress this
warning.
Call Stack (most recent call first):
/usr/share/kde4/apps/cmake/modules/FindKDE4Internal.cmake:406 (include)
/usr/share/cmake-2.8/Modules/FindKDE4.cmake:95 (FIND_PACKAGE)
CMakeLists.txt:51 (find_package)
This warning is for project developers. Use -Wno-dev to suppress it.

-- Phonon Version: 4.4.2
-- Found KDE 4.4 include dir: /usr/include
-- Found KDE 4.4 library dir: /usr/lib
-- Found the KDE4 kconfig_compiler preprocessor: /usr/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4
-- Found Qt-Version 4.6.3 (using /usr/bin/qmake)
-- Found X11: /usr/lib/libX11.so
-- Found MLT++: /usr/lib/libmlt++.so

-----------------------------------------------------------------------------
-- The following external packages were located on your system.
-- This installation will have the extra features provided by these packages.
-----------------------------------------------------------------------------
* KDELibs - KDE core libraries
* Soprano - Semantic Desktop Storing
* Shared desktop ontologies - Desktop ontologies
* QtOpenGL - Qt bindings for the OpenGL library
* QtScript - Qt module providing core scripting facilities
* Nepomuk - Support for the Nepomuk semantic desktop system
* QJson - Qt-based library that maps JSON data to QVariant objects

-----------------------------------------------------------------------------
-- The following REQUIRED packages could NOT be located on your system.
-- You must install these packages before continuing.
-----------------------------------------------------------------------------
* MLT (0.7.6 or higher)
Multimedia framework and video playout server for TV broadcasting

-----------------------------------------------------------------------------

CMake Error at /usr/share/kde4/apps/cmake/modules/MacroLogFeature.cmake:141 (MESSAGE):
Exiting: Missing Requirements
Call Stack (most recent call first):
CMakeLists.txt:92 (macro_display_feature_log)

-- Configuring incomplete, errors occurred!
-----------------------------

I'm compiling from the main git branch. is there something I missed?

I just went ahead and checked out the v0.8.2 branch. compiled fine. can't wait to get started.

For those who want to compile the recent git version and get this error: MLT installs it's pkgconfig files into {prefix}/lib/pkgconfig. But on a 64bit machine Kdenlive does only look into /usr(/local)/lib64 for the pkgconfig files, so it does not find MLT. Symlinking the mlt .pc files in /lib/pkgconfig to /lib/pkgconfig (or use ./configure option to install the files in /lib64/pkgconfig, but I do not know if other applications using MLT can handle this. Will try it out) should help.

Edit:
Hmm, Symlinking will make Kdenlive to compile but not to start because some MLT .so file can't be found and compiling MLT with --libdir=/usr/lib64 makes kdenlive crash with a segmentation fault on startup. At least on my Fedora system.

On a 64-bit system, use the following to configure MLT with the correct paths:

./configure --prefix=/usr --libdir=/usr/lib64 --enable-gpl