MLT module SDL not found error after upgrade to MLT 0.5 and KDEnlive 0.7.7

I found a packages for MLT 0.5 and KDEnlive 0.7.7 for Mandriva 2010 and installed them OK over my existing installs.Now when I try to start KDEnlive I get the error MLT module SDL cannot be found. I assume its looking for the lib moddule ending in SDL which is in /usr/lib/mlt and has been updated by the new 0.5 install. Can anyone suggest why I get this and how I might resolve it?

Stuart

A few ideas:

1) Make sure you don't have an older version of MLT / MLT++ installed
2) Try deleting the kdenlive config file: $HOME/.kde/share/config/kdenliverc

Well I'm fairly sure I dont have an old MLT and deleting the config file did not work. What I'll try if I can is to remove MLT and KDEnlive and install both new packages when I know I dont have any old ones. Hopefully MLT wont remove too much!

Stuart

Well I sorted it but the problem was that the package I used did not require updates to libmlt2 or libmlt++, once these updated packages were installed KDEnlive started fine. Oh well....

Stuart