No Audio Waveform In Timeline

This is my first post question. I am familiar with NLE (Adobe Premiere, Final Cut Pro, Sony Vegas). I want to work in Linux Ubuntu, use Kdenlive and promote it. I am making a HD video. Video+Audio (1) was recorded on a webcam and I recorded a separate sound track with Audacity. Video+Audio (1) on timeline, audio waveform doesn't show. I have tried the show audio thumbnails button, bottom right and top menu bar Timeline/Show audio thumbnails clicking on an off and it doesn't work.

I have tried menubar Settings/Configure Kdenlive/Display/Thumbnails/Audio [tick] on and off. still doesn't work.

I have searched Google to no avail. What do I do, to see the audio waveform so I can sync up the sound?

Which Kdenlive version are you using?

on ubuntu 10.04 (lucid lynx) that happened to me also using the default kdenlive 7.7.1 within lucid repos. If you use these versions and PPA's and repos you'll get a newer kdenlive where the audio wave thumbnails do show up. it's a slicker kdenlive also. I love it!! thanks to sanub's PPA (thanks sanub for all you help!!)
Very easy to setup also, just be sure to clean your system entirely prior to enabling new repos and PPAs, then do an update and you should be golden to install all software.

ffmpeg = medibuntu repo (SVN-r0.5.1-4:0.5.1-1ubuntu1)
libavcodec-extra-52 and all other ffmpeg libraries (4:0.5.1-1ubuntu1+medibuntu1)
mlt = sanub2 PPA (0.5.7+git20100907.c8b11129-0ubuntu0~sunab~lucid1)
kdenlive = sanub2 PPA (0.7.7.1+svn20100907.r4857-0ubuntu0~sunab~lucid1 )

if you have issue let me know I jsut went through this process of getting it working.

Hi I'm back again (it's been a while), with the same problem. I have Ubuntu 10.04 (lucid) and Kdenlive 7.7.1 and still now audio waveform.

a) could there be dependencies not installed that generate the waveform? I checked all the dependencies in the kdenlive wiki and all is ok http://en.wikibooks.org/wiki/Kdenlive/Getting_and_installing

b) I go to Settings --> Configure Kdenlive --> Display [video] is ticked [Audio] is ticked [Normalise audio for thumbnails] is ticked. The Show audio thumbnails icon (bottom right) is highlighted just like the video icon. Still no audio waveform.

Any suggestions?

I also had this problem and found out two things:

1) in my case the audio waveforms weren't being generated due to the clip being relatively long (~30mins encoded in huffyuv), however the audio waveform was being generated in the background and after a while it did appear;

2) upgrading to Kdenlive 0.8 and MLT 0.7.2 was the same, I just had to wait a bit for the waveforms to be generated, once they were they appear every time the project is opened.

Oh, and I just noticed that (at least on the new 0.8 kdenlive) it tells you in the status bar at the bottom that the thumbnails are being generated. Cool.