no sound / audio output (v0.9.2 on OpenSUSE 11.4/ALSA)

Hi,
I am new to kdenlive. Installed v 0.9.2 on an OpenSUSE 11.4 / ALSA yesterday, and did not manage to get any audio output so far.
I can produce sound from other apps (firefox, audacity, mpg123, ...) but succeeded neither from melt nor kdenlive.

In kdenlive I got some messages at first that no audio device could be opened but I managed to get rid of those. Now, I do see some display in the level meters and the spectral audio analyzer, but still do not hear anything. Interestingly, sometimes I see these messages several times when playing a clip with audio (reported by others to be seen related to crashes, but my kdenlive has not crashed so far):
ALSA lib pcm.c:7316:(snd_pcm_recover) underrun occurred

But: this seems not to occur every time I play clips with audio -- at least once these messages had not been thrown.

In case that clarifies something (not for me though): I do have a file /etc/alsa-pulse.conf containing

@hooks [
{
func load
files [
"/etc/asound.conf"
"/etc/asound-pulse.conf"
"~/.asoundrc"
]
errors false
}
]

There's no /etc/asound.conf and no .asoundrc in my home dir but I got /etc/asound-pulse.conf:
# PulseAudio plugin configuration

# Let's create a virtual device "pulse" for mixer and PCM

pcm.pulse {
type pulse
}

ctl.pulse {
type pulse
}

# Let's make it the default!

pcm.!default {
type plug
slave.pcm {
type pulse
}
}

ctl.!default {
type pulse
}

I am not very skilled on Linux sound, so I am not sure whether the above config is somehow invoking PulseAudio -- I do start just the alsasound init.d script so my guess is I am using ALSA ...
If someone has some advice or suggestions how to fix my issue I'd be grateful.

Thanks

moonfish

UPDATE: The message that no audio device is avail ("SDL failed to open audio: No available audio device") is seen always when i had kdenlive off, restart alsa (service alsasound restart), start kdenlive and play a video. If I confirm that error message, it does not return, even not after shutting down and restarting kdenlive. It requires in addition the alsa been restarted to recur.
moonfish

Consider trying 0.9.3 beta version available

https://launchpad.net/~sunab/+archive/kdenlive-svn

This is builds of the soon to be release 0.9.3 (or maybe it will be called 0.9.4) and there are lot of bug fixes in this up comming release.

In kdenlives config, playback devices menu for video and audio do you have them set to automatic or ALSA.

Audio on Linux has been a nightmare over the years, from memory I think Pulseaudio is supposed to handle all routing of devices through to whatever audio setup an app uses, he usual reason a device can't be opened is its been handled directly by another audio system in your case ALSA, perhaps do not start ALSA and let PulseAudio grab the device instead?

Sorry its sketchy long time since having these issues.

Audio was initially set to automatic, i checked out ALSA, then, with ALSA stopped and started, resp., PulseAudio. With ALSA explicitely set I checked out the two reasonable device choices offered: ALC883 Analog and ALC883 Digital.
None worked.
With ALSA shut down i just do not get the "Can't get hold of audio device"-like messages.

Will check out v093b now, and may be an OS upgrade is not a bad idea neither ...

Thanks so far

moonfish

With ALSA shutdown, have you configured or checked Pulseaudio settings for the available device? There's a few GUi type components for Pulseaudio config in the distro repository if not installed already.

Hi,

just to let you know: I had restarted the box y'day, and - when trying to look at a youtube clip - found that sound did not work at all. So I fixed it (some odd settings after my desperate attempts to make kdenlive sound :-). Curious, I first tried kdenlive thereafter, and, to my extraordinary surprise, I could hear the audio this time. So, I would no more assume a general kdenlive issue here. Need to concentrate on the setup of the machine I guess. Thanks for all the suggestions.
And for the question: No, I had not configured any PulseAudio stuff.

moonfish