No volume options

I just upgraded to kdenlive 0.8.1 rev 5808. Now, when I add the volume (keyframeable) effect, only the volume slider is visible and it doesn't work; it's frozen. No other options are displayed. The volume effect is listed in the effects stack but none of the options are visible, I can't really change the volume. Also, the clip in the timeline shows the "volume" label in the corner but no keyframable lines are visible. There is no way to change the volume on a clip. The little "Add keyframes" clock is missing. How do I fix this? My previous revision (rev. 5793) worked fine.

waynevid
mlt 0.7.5

The problem is that you probably also updated MLT.
Just update Kdenlive to the latest revision and try again.
See this commit: http://kdenlive.svn.sourceforge.net/viewvc/kdenlive?view=revision&revisi...

Thanks for the tip. I updated Kdenlive and now the volume options are back.

waynevid

I'm having this same problem. I'm using the build script from MLT - http://www.mltframework.org/twiki/bin/view/MLT/BuildScripts - to build the latest ffmpeg, mlt, and kdenlive. I did a build on 2012-01-14 and another on 2012-02-04. Both builds have the problem described above.

Is there an audio dev library or something that I could be missing? Or is this a known problem?

Thanks!

In case anyone else has a similar issue, I was able to solve the problem by removing the Ubuntu-packaged version of kdenlive, as well as associated packages:
frei0r-plugins{u} kdenlive kdenlive-data{u} libmlt++3{u} libmlt-data{u} libmlt4{u} melt{u} recordmydesktop{u}