Nvidea TwinView problem and others

Hi Folks,

I'm on Kubuntu, 4.something, 64 bit. I keep it up to date and apply all patches that come down.

1) -----

I'm having a problem with KDenlive in Twin View mode. The preview window doesn't show the video.

It will show stills at various points and the audio works without problems, but the video doesn't show in the preview on playback.

2) -----

Mpeg4, Xvid4 and Flash are unavailable in the rendering engine. Tried the various options and have added the repository for the other kdenlive updates but they are coming up as, "blocked," in software manager.

3) -----

First had three problems in the configuration...
MLT version: 0.4.7
QImage module
Title Module.

Found libmlt files dates 2009-10-25 in /usr/local/lib and deleted those. Now the configuration wizard is fine with Qimage and Title module but is still complaining about MLT version.
There were libmlt files in /usr/lib dated 2010-02-16 ... I destroyed those and then in the software management removed melt 0.5.2 (it removed kdenlive) and then re-installed it. Now, I can't install kdenlive because it has failed a package dependency.

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
kdenlive: Depends: kdebase-runtime (>= 4:4.4.2) but 4:4.3.5-0ubuntu1~karmic1 is to be installed
Depends: kdelibs5 (>= 4:4.4.2) but 4:4.3.5-0ubuntu1~karmic1 is to be installed
Depends: libqt4-dbus (>= 4:4.5.3) but 4.5.3really4.5.2-0ubuntu1 is to be installed
Depends: libqt4-network (>= 4:4.5.3) but 4.5.3really4.5.2-0ubuntu1 is to be installed
Depends: libqt4-svg (>= 4:4.5.3) but 4.5.3really4.5.2-0ubuntu1 is to be installed
Depends: libqt4-xml (>= 4:4.5.3) but 4.5.3really4.5.2-0ubuntu1 is to be installed
Depends: libqtcore4 (>= 4:4.6.2-0ubuntu3~karmic1~ppa1) but 4.5.3really4.5.2-0ubuntu1 is to be installed
Depends: libqtgui4 (>= 4:4.6.2-0ubuntu3~karmic1~ppa1) but 4.5.3really4.5.2-0ubuntu1 is to be installed
E: Broken packages

So now I don't even have kdenlive installed.

Help! Please!

Hi Folks,

Just to let you know, no hurry. I guess people are on holiday.

I've found Cinecutie and it has got me over the rough patch so I can use that until I get kdenlive working again.

Do you use the kdenlive packages distributed via sunab's repositories?

I use the one that is automatically in with the Ubuntu repositories normally,

Although as part of the testing I did follow various instructions here and added repositories in to get the latest version of the libs.

regarding:
2) you have to install an unstripped version of ffmpeg.
3) Did you try installing kdenlive from sunab2? because sunab2 is compiled against kde 4.4 which you appear not to use. Try following this guide: http://kdenlive.org/user-manual/downloading-and-installing-kdenlive/pre-...

Hi Ttill,

Thanks for the effort.

I've actually become used to Cinelerra and I think I'm going to stick with it for the time being.

The major advantage is that it works in Nvidea twin view and I don't have to reconfigure and restart X whenever I want to edit video ... and even if I did get KDEnlive sorted out, I'd still have to do that.

So, I'm going to rest with Cinelerra (actually the Cinecutie branch) for the time being and come back to KDEnlive at some point some months down the road.

Thanks for the help.

To get video to display on a secondary display, maybe you just need to set the video driver to X11 in Kdenlive settings. Otherwise, SDL will try to use XVideo extension, which might not be enabled on secondary display. Paused video with frame stepping will work with Automatic or XVideo enabled, because MLT uses a different SDL mode without the XVideo extension when not playing.