OpenSuse 11.4 - MLT from source - Kdenlive fails

1) I have installed a new pc with OpenSuse 11.4

2) I installed MLT from source using these commands:
git clone http://mltframework.org/mlt.git
cd mlt
./configure --prefix=/usr --enable-gpl
make clean
make
sudo make install

It appears fine and running melt -version from the command line worked.

3) I installed Kdenlive from source using these commands:
svn co https://kdenlive.svn.sourceforge.net/svnroot/kdenlive/trunk/kdenlive
mkdir kdenlive/build
cd kdenlive/build
cmake .. -DCMAKE_INSTALL_PREFIX=/usr
make
sudo make install

It choked on cmake. It couldn't find the install of MLT.
Comparing this box with an OpenSuse 11.3 box I found a difference.
Opensuse 11.3 put mlt stuff in /usr/local/lib
Opensuse 11.4 put mlt stuff in /usr/lib

*** SOLUTION ***
I copied the Opensuse 11.4 files from /usr/lib to /usr/local/lib and then I could build Kdenlive.
/mlt
/pkgconfig
/libmlt*

During my debugging efforts I did try the RPM package of MLT from packman, but that didn't work with building Kdenlive either. Same error. Couldn't find MLT.

I don't know that what I did was the right thing, but I wanted to report this here in case someone else gets stuck.

Thanks.

Forums:

You might find the build script handy as it does not require you to install things into /usr

http://www.mltframework.org/twiki/bin/view/MLT/BuildScripts#Kdenlive

I have the packman packaged kdenlive-0.8 working on both openSUSE-11.3 and openSUSE-11.4 PCs.

* Packman packaged kdenlive (for openSUSE) : http://packman.links2linux.de/package/kdenlive
* Packman packaged mlt (for openSUSE) : http://packman.links2linux.de/package/mlt