Pb d'installation kdenlive 0.7.8

Bonjour à tous

J'ai découvert kdenlive dans les dépôts d'Ubuntu, et j'en suis ravi, hormis l'instabilité, mais on s'y fait.

J'ai voulu installer la mise à jour pour passer en 0.7.8 mais rien n'y fait je ne peux l'installer.
Le message qui m'est indiqué est le suivant :
" Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
kdenlive: Dépend: libavfilter-extra-0 mais ne sera pas installé
E: Paquets défectueux "

Lorsque j'essaie d'installer à la main ce paquet, j'ai d'autres messages d'erreur :
" Les paquets suivants contiennent des dépendances non satisfaites :
libavfilter-extra-0: Dépend: libavcodec-extra-52 ( E: Paquets défectueux "

Quelqu'un a-t-il une idée de ce que je peux faire ?
Je suis sous Ubuntu 10.04

Par avance merci

Désolé, j'utilise Mandriva comme distribution. C'est impeccable pour Kdenlive, la dernière version est arrivée le lendemain de la sortie par les backports.

Bonjour jpascal,

ton problème est assez simple, tu a configuré sur ton système un dépôt ppa qui a mis a jour automatiquement la version d'FFmpeg de 0.5.1 vers 0.6. Il faut savoir que les paquets de n-muench comme ceux qui traînent sur d'autres dépôts personnels sont de simples "backports" depuis Maverick (la prochaine version d'Ubuntu), et donc le packaging n'est pas adapté et provoque des conflits dans Lucid.

Il faut faire très attention lorsque l'on utilise des dépôts alternatifs, en particulier il faut vérifier si lors de la mise a jour des paquets "originaux" ne sont pas brutalement désinstallés. FFmpeg est en plus très utilisé par de nombreux autres programmes, donc on a vite fait de "casser" la cohérence du système.

De plus il faut savoir que la version 0.6 n'est plus rétro-compatible avec la version 0.5.1 (FFmpeg évolue beaucoup et vite), en particulier dans deux bibliothèques libavutil et libavfilter. Donc pour conserver la cohérence du système il faut que libavutil49 et libavutil50 puis libavfilter0 et libavfilter0 puissent être installées en même temps, ce que ne permet pas le packaging backporté. En effet les développeurs Ubuntu n'ont pas prévu la coexistence de plusieurs versions d'FFmpeg.

Comme tu n'est pas le premier a soulever le problème, et que tu ne sera pas le dernier vu l'usage assez indiscriminé des dépôts ppa, je réfléchis à mettre à disposition une version d'FFmpeg 0.6 qui ne crée aucun conflit. Je ne promet rien ...

Sunab.

Merci pour l'info, je note ;)

Pas eu de soucis d'installation de la version 0.7.8 sur Ubuntu 10.04 Tango Studio : http://tangostudio.tuxfamily.org/