Please post a HOW-TO for Ubuntu Gutsy and kdenlive 0.6

Hi!

My name is Andrea Pizzini and Im a filmmaker from the italian company helios (

http://www.helios.bz

).
I wanna try the 0.6 Version of kdenlive but I wasnt able to install the programm. So Im asking some expert here (jbm?) if he can write us a HOW-TO for Ubuntu-Gutsy user!

Thank you a lot!
Andrea
helios.bz

This request means, of course, that you're no longer installing Binary Packages, as this forum suggests.

I would recommend using this script:

viewtopic.php?f=8&t=516#p1810

It is very easy to use and it worked for me wonderfully. You can read more about it in the Wiki:

http://en.wikibooks.org/wiki/Kdenlive/G ... e_easy_way

This will give you the most-recent version of KDEnlive that you can get, along with the most recent ffmpeg, mlt, and mlt++ (these are all needed for KDEnlive). This script will install everything only where you tell it to when (if) you edit the script before running it (just look for the part that reads:

Quote:
# Modify the destination directory if you want
# Or you can copy it afterwars to /opt/kdenlive- or wherever you want.
# Caution: if you pick /usr here, you system kdenlive, ffmpeg and mlt will be overwritten!
#export DEST_DIR=~/build/kdenlive.$(date +%F_%H_%M) # ..uncomment this if you prefer to have 'timestamp' in target directory name
export DEST_DIR=~/build/kdenlive_0_6svn

By default, it is all in your home (~) directory.

HowTo:

1. With Kbuntu (8.04, but this should also work for 7.xx I would think) I first added the multimedia repository (Medibuntu.org);
2. second I ran "sudo apt-get build-dep mlt mlt++ kdenlive ffmpeg" , which installed needed packages for building the (old-but-available) versions of these apps;
3. third I copied the new script from here: viewtopic.php?f=8&t=516#p1810 and I edited it (run: kate ~/Desktop/pathtoscript) to specify my directory (~/kdenlive/);
4. then I saved that script as kdenlive_builder.sh ,
5. I made it executable (in a console, run: chmod u+x kdenlive_builder.sh),
6. and I ran it from the command line:

    ~/Desktop/pathtoscript/# ./kdenlive-builder.sh

I chose the option to do it all; then I cd /pathtokdenlive/kdenlive/bin/ and then I ran ./kdenlive

:)

hi, i tried the script but after some time it ends on this error:

make[1]: Entering directory `/home/luci/mlt/src/modules'
list='avformat motion_est vmfx lumas effectv sdl plus feeds oldfilm frei0r valerie core westley kino normalize kdenlive fezzik qimage xine vorbis inigo gtk2 resample jackrack dv sox'; \
	for subdir in $list; do \
		if [ -f $subdir/Makefile -a ! -f disable-$subdir ] ; \
		then make -C $subdir all || exit 1; \
		fi \
	done
make[2]: Entering directory `/home/luci/mlt/src/modules/avformat'
cc -Wall -fPIC -DPIC   -O4 -pipe -fomit-frame-pointer -ffast-math -DUSE_MMX -g -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -pthread -I/include   -I../.. -DSWSCALE   -c -o factory.o factory.c
factory.c:34:22: error: avformat.h: No such file or directory
factory.c: In function ‘avformat_init’:
factory.c:90: warning: implicit declaration of function ‘av_register_all’
factory.c:92: warning: implicit declaration of function ‘av_log_set_level’
make[2]: *** [factory.o] Error 1
make[2]: Leaving directory `/home/luci/mlt/src/modules/avformat'
make[1]: *** [all] Error 1
make[1]: Leaving directory `/home/luci/mlt/src/modules'
make: *** [all] Error 1

any ideas please ?

similar error here..
ubuntu hardy, installed all dependecies, but while compiling:

make[1]: Leaving directory `/usr/src/mlt/src/albino'
In file included from factory.c:34:
/home/build/kdenlive/include/libavformat/avformat.h:40:32: error: libavcodec/avcodec.h: No such file or directory

the package libavcodec_dev is missing in your system. i recommend using synaptic to install.