Plugins missing

Hello,

I'm compiling ffmpeg, frei0r, mlt and kdenlive packages for Debian unstable locally from latest git trees. The packaging is copied with minor modifications from Debian and debian-multimedia.org packages. ffmpeg, melt and kdenlive work just fine but I seem to be missing a number of plugins, like RGB color adjustments in kdenlive GUI. How should I go and debug this? Has there been some major plugin or binary name or path changes in last few months, which my perhaps stale packaging files are missing?

I tried re-doing the packaging: cleaning frei0r, mlt, kdenlive git trees and copying latest dmo or debian unstable packaging on top. But still some plugins were not found, especially the RGB adjustment. So I installed frei0r, mlt and kdenlive with checkinstall instead, so now they work and plugins are there. I'll stick with this checkinstall approach then, which just shoves make install targets to .deb packages.

Did you perhaps have frei0r installed in both /usr/lib and /usr/local/lib? This is what happens to me sometimes. Removing the frei0r-1 directories there completely and re-installing then solves the problem.

No, I had only /usr/lib/frei0r-1 but there was something wrong/changed too much between the latest git and packaged versions. I didn't figure out what. kdenlive and mlt worked but plugins were missing.

Maybe this may help somebody:

If while running MLT's ./configure it tells you that Frei0r isn't found, try to reinstall Frei0r by running ./autogen.sh in the Frei0r directory and then typing ./configure --prefix=/usr; make; sudo make install.

After that MLT should find Frei0r.

hi mcfrisk, how do you do it the checkinstall way? i cant get my kdenlive from source compilation to detect the avformat module or the frei0r transparency effects.. which means i cant do anything in my project right now (no h264 support) though the binaries (from synaptic) do seem to detect everything fine..

@sunyboy Regarding the error you got (MLT did not find frei0r when self-compiled), this was because the frei0r.h file was not copied to /usr/include with CMake. I've fixed this error now.
automake works fine; CMake support has been added recently.