Problem compiling MLT

Hi,

is there anybody having problems while compiling MLT last svn version ? I'm having, but do not know if it's something I'm doing wrong or a problem with this version.

The problem seems to be related with avformat module being unable to find the headers file avformat.h. Since 3-4 days before, I do not have any problem, but last versions are not compiling well. I've tried to find what the root problem is, but not successful.

Any help will be appreciated.
Regards.
JM

Hi, had the same problem here.
I'm installing the kdenlive/ffmpeg/mlt/mlt++ packages via kdenlive-builderscript-3,
which i had to adapt to my slackware 11 distro. It worked, but since yesterday it stopped with an error:

Error "could not find avformat.h" was in:
./mlt/src/modules/avformat/factory.c

in this file the headers are searched in:
// ffmpeg Header files
#include

so i made a dir at "/usr/src/video/kdenlive/mlt/src/ffmpeg and symlinked the
header files from "/usr/src/video/kdenlive/ffmpeg/lib..." to this dir

then added the line "export CFLAGS="-I/usr/src/video/kdenlive/mlt/src/ffmpeg"
to the builder-script in the make mlt section.
( right under "export LDFLAGS="-L/usr/X11/lib" )

started the builder script and made a full installation without any error
(sure you have to set the pathes to yours)

my versions today:

Local Revision of FFMpeg is: "12339"
Local Revision of MLT is: "1099"
Local Revision of MLT++ is: "1099"
Local Revision of KDENLIVE is: "2000"

hope this helps, greetings aksels