Problem dragging clips to timeline with Qt 4.6?

I recently upgraded one of my test boxes to Kubuntu Lucid with Qt 4.6 I am using a Kdenlive package that I built myself against the latest version of MLT (and against Qt 4.6.) Whenever I try to drag a clip to the timeline, instead of popping into position on one of the tracks, you can instead place it anywhere. Playing the timeline does not work, and the improperly added clips cannot be removed. Am I doing something wrong here, or is this a Bug?

Forums:

Yes, with Qt 4.6, you need to use Kdenlive's development version from svn, where all Qt 4.6 related issues have been fixed.

Thanks! No problem, I will update my PPA package to SVN. Is this only for Kdenlive, or do I have to update MLT to the SVN version too?

Ok, I have now updated to SVN, but I am still seeing a problem. Whenever any of the video clips on the timeline have to be redrawn for any reason, it occurs very slowly. The two best ways to recreate this are dragging the timeline position indicator over a clip, or scrolling the timeline. On one of my projects, that uses multiple stacked video tracks with many transitions, it can take 2-3 seconds to redraw the timeline when scrolling.

Same problem here in opensuse 11.2 with QT 4.6.
Any idea when the fix will make into the stable kdenlive release?

Thanks in advance.

Woojin

hi. i can't use kdenlive anymore. It's the qt4 bug with clip in timeline
My system is opensuse 11.2, KDE version 4.3.95 RC2, kdenlive 0.7.6
Qt version is 4.6.1
I downgraded kde back to 4.3.4 and qt to 4.5.3 but the bug persisted
Is there any chance for kdenlive to work? If somebody DOES HAVE / POSESS an RPM of the svn 0.7.7 version of kdenlive, please let me know. I need the program to work for my wife's study work - a video.

Thank you in advance.

I plan to release Kdenlive 0.7.7 in about 10 days, that will solve this issue.
regards

When was this bug fixed? I still have this problem and I'm using svn4238 from ppa:sunab/sunab2 (Kubuntu 9.10, KDE 4.4 RC2)

I'd also like to know when this bug is fixed. I have same problems.

I have also tried to compile the latest SVN with the Builder, but it fails on ffmpeg and says:

ERROR: libx264 version must be >= 0.83

I can't find libx264 0.83 anywhere. So I would also like to know where I can get this too.

Right now you have to install x264 from git (or disable h264 in the wizard options I think) to use KBW. Look at videolan.org for more information. Do something like this;

git clone git://git.videolan.org/x264.git
cd x264
./configure
make
sudo make install

If you're on Ubuntu or similar you might like to use checkinstall, see this thread http://ubuntuforums.org/showthread.php?t=786095

O yeah, and if you like the Builder Wizard to stay alive and improve please sign this thread!
http://kdenlive.org/forum/poll-are-you-interested-kdenlive-builder-wizard

j-b-m wrote: I plan to release Kdenlive 0.7.7 in about 10 days, that will solve this issue.
regards

@j-b-m i am waiting unpatiently. ow working from scratch on openshot, but it doesn't suit my editing needs as kdenlive does.

Cheers!

I made an update to 0.7.7 and i have a problem with clips on timeline. I can drag them everythere i want. I cannot delete them.
Versions:
Qt: 4.6.1
KDE 4.4.0 (openSUSE 11.2)

Same for me on Ubuntu Karmic. This renders the 0.7.7 version completely unusable.

D.

same here. Kubuntu 9.10 with backports enabled...

Kubuntu guys, go to this forum thread. I already uploaded a 64 bit version, and am working on the 32 bit right now.

still problems with 0.7.7.1 version, look at screenshot
opensuse, kde4.4.1

same here on
kdenlive 0.7.7.1
mandriva 2010.0
QT 4.6.1
kde 4.4.0

Hi,

Known problem if kdenlive is compiled against KDE 4.3 and you are using KDE 4.4

Ask the maintainer to rebuild against KDE 4.4 if possible.

hi
for the mandriva users, installing the Cooker version of kdenlive solve the probleme

the problem was solved by openSUSE user RedDwarf and his repository. Good work, since I made the proper upgrades of corresponding KDE 4.4.x and kdenlive 0.7.7 it is working smoothly. Now KDE 4.5.0 and kdenlive 0.7.7.1.

Thank you for the awesome work.

hi everybody,

can anyone help me to create timeline for video plaback using qt