Problem extracting a clip using clip monitor

Hi everyone I have a little problem.
When I try to extract a part of a clip, using the monitor clip, the final result is, very often, different from selection. The final extracted clip starts and stops one (or one a half) second before my selection. If I check with ctrl+space the selection from clip monitor is perfect.
The timeline have no problems.
Some guess?
Thanks averyone in advance.

I've been using the clip monitor to extract a portion of a clip heavily for the last couple of weeks. My method: use project monitor to mark in/out the area where I wish to drop the clip extract and make note of the begin/end times (hh:mm:ss,ff). Also the area will be highlighted green above the timeline and so I know the exact length of the area for the clip. Next I Go to clip monitor and use mark in/out for the extract boundaries and make the time to match the area where it is to fit. Then drag/drop to the area. But I'm careful that the properties for the timeline match the properties for the clip. If they don't match (the fps for the timeline is 24 but for the clip is 30) there will be a mismatch and the clip will have to be converted to match the timeline and project profile.

If you are driven from the opposite goal -- that is, you BEGIN with the clip -- make sure you do the same thing by making note of the begin/end times (hh:mm:ss,ff) of the extraction zone, and then mark an area in the timeline on the project monitor beginning at your desired drop in point and the end point will be determined by the length of the extracted area. The extracted clip should fit exactly into the area you marked thusly marked.

Works for me. Using the set zone start [ and set zone end ] buttons on the clip monitor. Then drag the clip window to the time line. I get exact match. Is this how you are doing it Castore ?

Castore, what is the format and codec you are using? Does it happen with any video clips or just certain ones.

When I use kdenlive I convert every video in raw dv. ButI have the same problem with mpeg2 and mpeg4.
When I use clip monitor, using the ctrl+space, I see the right selection, the extraction does not match it.
I haven't clearly understood the method using the timeline.

What version of kdenlive and MLT are you using?

To try to understand, are you saying that you are dragging your clip to the Project Tree as a sub clip and that the selection in the clip monitor and timings of the sub clip slightly differ?

If so then are you sure that your Project Settings FPS and your source clips FPS match?

Perhaps what is happening is that you are using say 23.98 ie: 24/1001 in a strictly 24P ie: 24/1 project or 29.97 ie: 30/1001 in a strictly 30P ie: 30/1 project? And that playback of the original source in the clip monitor is say 23.98 but your subclip in the 24P Project Tree is playing back at 24P? Just a guess as I'm stuck for alternatives. :-)

Don't get too concerned by other methods using the timeline, it's as simple as ttguy explains, select the in / out points in the clip monitor, then either drag to the Project Tree to make a subclip or two or however many you want out of your parent clip or drag straight to the timeline.

I always convert every video with ffmpeg before importing in kdenlive. Every video have the same fps and, the project has the same fps (kdenlive always recognize from the first video).
They all are raw dv video.
No, I don't drag anything, after the selection I use the tool extract selected area and, after it, I tell kdenlive to put the result clip in the project.
But the extracted clip doesn't match the selection.
I'm using the last versione of kdelive with Arch and Fedora.

Have you tried using native source files to test rather than transcodes to dv?

Yes, I've tried mpeg2, mpeg4, dv and some kind of avi's.
I've tried on Arch and Fedora (no other distro's on my hd) and, I've asked to a friend to do the same, and He had the same issues.
Do you have the same issues too? Have you ever tried to extract from clip monitor a very short clip?

Where is the option "extract selected area" because I don't use that. So you might have found a bug.

Have your tried the alternate method I described at the start of the thread?

Wait I found the option.

But I can not test it because it errors out on me.

"Can't initialize DV format!
Make sure that you supply exactly two streams:
video: 25fps or 29.97fps, audio: 2ch/48kHz/PCM
(50Mbps allows an optional second audio stream)
Output #0, dv, to '/home/ttguy/Videos/light_sabre002_1713.dv':
encoder : Lavf53.21.1
Stream #0.0: Video: dvvideo, yuv420p, 720x576 [PAR 64:45 DAR 16:9], q=2-31, 28800 kb/s, 90k tbn, 25 tbc
Stream #0.1: Audio: pcm_s16le, 32000 Hz, 2 channels, 1024 kb/s
Stream mapping:
Stream #0.0 -> #0.0
Stream #0.1 -> #0.1
Could not write header for output file #0 (incorrect codec parameters ?)

But I can see what this feature tries to do - it extracts a sub-clip our of the main clip and puts it in the project tree.

I cans see that there are many work arounds for this problem. Why do you need these subclips in the project tree anyway?
You can use the select and and outpoints as you have been doing and then drag the part of the clip you want directly onto the timeline rather than have it in the project tree and then the time line.

You could also file a bug report if you so inclined.

Wait. I got it to work with a .mp4 clip rather than a .dv clip. And I see the bug you are talking about. I selected 2 seconds of clip and got 7 seconds in the project tree.

So you could file a bug and in the meantime use a workaround.

If I remember correctly, the keyboard shortcut ^i should trigger this function too to extract a marked clip region as a sub clip. However, from time to time, this function just refuses to work, maybe the same bug?

As for ttguy's question about what this is good for: I'm regularly using it to first go through my raw material (rather lengthy underwater footage) to extract the scenes I'm interested in. After that is done I'm only starting placing sub clips on the time line.

"Why do you need these subclips in the project tree anyway? You can use the select and and outpoints as you have been doing and then drag the part of the clip you want directly onto the timeline rather than have it in the project tree and then the time line."

For me I use it all the time that way dragging sub clips to the Project Tree first. :-)

I'll quite often leave the camera running between framing shots serves to capture reference audio to match with external audio recorder too, rather than trying to realign loads of short takes and separate audio for each short take, long audio also serves for ambient.

So when editing and I'm scooting through those sort of clips I mark in/out for each part of a clip that is framed and good, drag it to the Project Tree, might end up with four or five subclips per parent clip. Might also want to use a clip more than once and not have to go hunting for it on a busy timeline.

It's also not like we're duplicating clips taking disk space it's just lightweight XML file.

On more involved jobs where I sub divide shots which might serve more than one purpose and therefore very possibly in separate sub folders within the Project Tree I can duplicate a sub clip into multiple folders, still references the one 'real' source file.

I want to touch a clip once to establish the contents not keep fiddling with in/out points on the timeline although for fine tweaks for timing that always happens but only by a few frames at a time.

Depends on the time available to edit and size of project whether to organize sub folders and clips or just float the good stuff up the layers of video tracks, psuedo rating it for good shots, mediocre etc.

Different strokes for different folks. :-)

I use the project tree becouse I mount the clip not in the exact order that I've recorded. Sometimes I use the same clip twice.

How can I fill a bugreport?