Problem: imported images are stretched

Imported images are stretched to fit. Is there an option to make it so it doesn't stretch the images?

If you are using the development version of Kdenlive, go to Settings->Configure Kdenlive->Misc and uncheck the
"Distort Images" option.

regards

I guess I'm not cause I don't see that option. I'm using version 0.4 (KDE 3.5.6). Where can I get the version you are talking about?

(Edit) found 0.5svn version:

http://3v1n0.tuxfamily.org/pool/feisty/ ... 2_i386.deb

And it fixed the stretched image problem!

However the images are kind of blurred. not horrible, but looks blurred like when you rendered at a lower quality.