"Problem" with MLT

Hi,

I'm using kdenlive build wizard in the last version on my OpenSuSE 11.0. The installation is very easy and working without any problems.
I'm installing kdenlive in my own folder. Under start wizard I get the message that the MLT version is too old (0.2.4), even if I have installed the last version downloaded from SVN. See also attached picture.
So, I have also checked the MLT library installed in the main folder (/usr/lib etc.) - it's also 0.3.6.
What could it be?

Regards,
Rafael

are you sure there's no other mlt installed? please, also check mlt pkg-config (it could be in /usr/libdata)... i'm sorry i can't be more useful, but i'm not on unix at the moment and i can't remember very well...

here you are some more precise information: http://kdenlive.org/user-manual/downloading-and-installing-kdenlive/installing-source/installing-mlt-rendering-engine

uninstall kdenlive and mlt[++], follow the section "Remove MLT previous installation" and have another try with the builder wizard!

I'm installing kdenlive in my own folder.

 

...if you used the Builder Wizard I guess this means /home/username/kdenlive ? Then most probably starting up kdenlive via /home/username/kdenlive/bin/kdenlive_start should work fine.

 

Messing with MLT on your system won't make much of a difference I think since the Builder Wizard installs it in a separate source folder (by default /home/username/src) just for use with Kdenlive version build by the wizard. If kdenlive_start doesn't work I suggest running the Builder Wizard again. Post back here (or here) if you had success or failure!

the kdenlive start wizard checks mlt version with `pkg-config --variable=version mlt-framework`, so there could be an old pkg-config file breaking this test...

155             QString exepath = KStandardDirs::findExe("pkg-config");
156             if (!exepath.isEmpty()) {
157                 checkProcess.start(exepath, QStringList() << "--variable=version" << "mlt-framework");

...unless there's some magic environment settings in kdenlive_start

Indeed there was older version of MLT-Framework in my stystem. I don't know why... ;-)
I have installed the actual SVN version in /usr/... and now it works ok. Version check displays also the correct version.

Thanks for your help.

 

Rafael

Ah, crap.

The code which you posted is from Kdenlive, I reckon.

It appears the test added by jbm to check the mlt installation, does not take into account that the mlt installation may not actually be loaded from one of the system directories.

If you do not have mlt installed globally (which I do not), then it wont get a version, and it will actually ask the actual mlt binary for the version.

Sigh, I should have noticed this. Just released a version of the wizard, that does not have a fix for this, I reckon I will wait a day or two more, then release a fixed wizard.

In the meantime: Could you try adding this to the start of kdenlive_start, e.g. after export PATH=...

export PKG_CONFIG_PATH=$INSTALL_DIR/lib/pkgconfig/

this should fix the problem, I would be very glad to know it it does.

Regards

Mads