Remember to remove pulseaudio if using kubuntu karmic

Hi.
I've been beating my head on the desk over some issues since upgrading to karmic and the kdenlive 0.7.6 a few weeks ago. I found that I was getting ffmpeg/melt/kdenlive crashes with pulsaudio installed. This was solved by removing pulseaudio and its config files.

I've now got a good working system and wanted to share a few notes with the hope that it helps someone.

Of course kdenlive recommends that pulseaudio be removed here: http://kdenlive.org/user-manual/troubleshooting-and-common-problems/soun...

In short I did this to remove pulseaudio. Follow Part A. Step 1 of this guide:
http://ubuntuforums.org/showthread.php?t=789578
(Be careful when making these changes and understand what you are doing)

You can then use synaptic to remove some of the extra pulseaudio packages such as pulseaudio, and paprefs. Leave the libpulse stuff or it will want to remove too many useful programs.

Then reboot.

I also had to go into the kdenlive settings and choose alsa as the audio device and the restart kdenlive.

This was hard to diagnose since most of the problems were observed in ffplay, which kdenlive uses. I had the most problems with files like .m2t that use a lot more processor and figured it was a problem with these files (so went down the path of upgrading ffmpeg). I did eventually settle on the latest x264 and ffmpeg svn, but the problem was only fixed by removing pulseaudio.
-In the past I also noticed jerky video and sound crackling in the preview window, which a lot of posts seem to mention also. Removing pulse also fixed that for me.

Hope this helps, Geoff

Forums:

Is there definitely no other workaround for using kdenlive in Ubuntu Karmic than disabling pulseaudio?
Pulseaudio seems to work pretty stable in Karmic so I would prefer to stay with it.

I have a fresh Karmic install on an AMD64 machine with kdenlive 0.7.6 -- but due to crackling sound when playing clips it is not usable so far.

Thanks for listening

Jonathan

Well, installing libsdl1.2debian-pulsaudio (and removing libsdl1.2debian-alsa) helps -- but now I have audio sync issues again ... :-(
I'm importing DNxHD clips (transcoded from AVCHD footage), which play fine (that is: audio in sync with video) in ffplay.

Jonathan

I can only tell you what worked for me (remove pulseaudio). I have read that others have kept pulse, but for me it was causing too many problems. I have no crackling/jerky video at all anymore. Kdenlive runs smooth and stable on a (32bit kubuntu, 3Ghz Pentium D), although it uses a lot of cpu on my .m2t files.

Note that I use the kubuntu/KDE4 desktop and the default is no pulse. The desktop and kde4 apps works great. You would have more problems if removing pulse on ubuntu/gnome since I think many more of those apps rely on pulse.

I would suggest removing pulse using synaptic and giving it a try for a few days. You can always re-install it if it doesn't help.

Wow, I was wondering why playback of clips was always a little slow and jerky, but I guess this makes sense. Does anyone know if this is a kdenlive problem or a pulse problem? Other apps seems to work fine in pulse, and I don't want to break compatibility with everything on my Gnome desktop just to use Kdenlive.

BY THE WAY, frei0r-plugins is making a /lot/ of my gnome applications crash while it's installed for apparently not being able to access some font-related file (configuration or something?). After I remove it, everything works. I never had this problem in Jaunty or Intrepid.

Hi Jonathan,

For me it worked to just do part A of the following (earlier mentioned) guide:
http://ubuntuforums.org/showthread.php?t=789578

Thereafter the sound in Kdenlive 0.7.6, using Pulsaudio, on Ubuntu Karmic (9.10) sounded (reasonably) good.
(Before it was unworkable.)

The only problem is a little tick which I hear often. I did not yet experiment / found out if it can be solved with the answer to the 'stuttering' question in the same guide.

I hear the tick in Kdenlive when I play the video.
After it is rendered, and I play in for example Totem Movie Player, the sound is perfect.

Greetings,
Michiel

geoffrey, michielwittkampf,

thanks for your advices!

I think, the important part in the mentioned "Part A" is just

$ sudo apt-get install libsdl1.2debian-pulseaudio

I'm wondering, if sunab could implement this as a dependency of kdenlive in his PPA - where we all got 0.7.6 from, I guess.

Finally I realised that my audio/video sync issues appears just in the preview window, which is a bit annoying, but I can live with that. Stopping playback and starting again seems to resync, so it's just a short "space" "space" and I'm happy again. :)

Thanks again!

can't get rid of the stutering even following the appendix part of the guide. I guess it depends of kdenlive as the sound plays properly on other apps.
Are you using ffmpeg from karmic repository or sunabs?

forget about my question, I just tried both sunabs and karmics repos and it's the same.

rico, what are your system specs and what kind of files are you trying to play?

Core2duo T7200
nvidia go gt 7900 512mb
sigmatel stac 9200 audio
Ubuntu 9.10_64
kdenlive 0.76

i'm trying to play a mp4, flv, avi same noise happening on all of them

I have tried doing the first part of the guide as mentioned above.

However, I get this:

quietbearr@quietbearr-desktop:~$ mkdir ~/pulse-backup && cp -r ~/.pulse ~/.asound* /etc/asound.conf /etc/pulse -t ~/pulse-backup/
mkdir: cannot create directory `/home/quietbearr/pulse-backup': File exists
quietbearr@quietbearr-desktop:~$ rm -r ~/.pulse ~/.asound*
rm: cannot remove `/home/quietbearr/.pulse': No such file or directory
rm: cannot remove `/home/quietbearr/.asound*': No such file or directory
quietbearr@quietbearr-desktop:~$ sudo rm /etc/asound.conf
[sudo] password for quietbearr:
rm: cannot remove `/etc/asound.conf': No such file or directory
quietbearr@quietbearr-desktop:~$

And yet I still cannot use kdenlive as the audio is all glitchy and jaggy and totally unusable.

Also since I upgraded, my system used to recognize 16:9 video as 16:9, now it forces it to 4:3, it used to just be kdenlive that forced it which I can fix in kdenlive using the forced pixel aspect ratio.

Why is it that everytime I upgrade to the newest edition of Ubuntu everything runs like crap and everything changes to a bad way? I think I am going to stop upgrading, as things like this happen every time.

This time, it deleted my bookmarks in Firefox, kdenlive doesnt work, which I use all the time, when I watch movies (no matter what type) I get slow frame rates all the time which is annoying (didnt happen before), I cant watch DVDs anymore....the list goes on, and I have only had it installed for a couple of days.

Anyways, how can I fix Kdenlive so at least I can edit my own videos?

So, apparently Kdenlive will work when I run those commands even though it says it didnt do anything, but then all other audio on my system is disabled except kdenlive, when I finish rendering, I cant watch the video.

So, if I restart I can, but then I have to re run those commands to edit in kdenlive again.

So is there:

1. a way to fix the audio on the rest of the system after running those commands

2. a way to make it so those changes actually stay when I restart?

Also, I noticed that now when I add things like video transitions, it used to have the little yellow box that I could click on, well, the transition is there, but I cant see the box anymore. Also when I do things like audio fades, it used to have the red triangle so I knew when the audio fade started and how long it was, not it is not there.

Is there a way to get that back other than just de-upgrading back to the old version?

Quietbearr,
Assuming you disabled and removed pulseaudio and are running Ubuntu/gnome desktop, go into the gnome desktop settings and change the audio settings to alsa instead of pulseaudio. You may be better off also turning off system sounds and you may be limited to running only one audio application at a time. This is what pulse does, allows you to run many audio using applications at the same time in gnome/ubuntu. If pulse is not installed you will probably have audio problems if using more than one audio using application at a time such as firefox and a movie player. If running kubuntu/kde you probably are not having this problem since it doesn't need pulseaudio.

I don't know why the changes would revert when you restart if you successfully disabled pulseaudio.

Also not sure why you are having problems with transitions.

Hope this helps.

I have installed linux-kernel-rt (real time) and the sound works finally good.

But it is true, that from time to time i need to log out and log in, because sound just doesn't work. But i thing this is related to kdenlive rather than to pulse audio, because my rhythmbox works fine.

I just wanted to mention that I too was able to fix the stuttering audio found on Kdenlive 0.7.6 under Karmic Koala by doing part A of mentioned guide:
http://ubuntuforums.org/showthread.php?t=789578

So thanks for the advice on how to fix it and keep pulse audio.

No thanks for the suggestion in the subject of this thread. :(

Hi all,

I would like to confirm, that removal of pulseaudio is not necessary. The installation of libsdl1.2debian-pulsaudio solved the audio problems and instability for me.

Best wishes,
Michael

..using:
kdenlive 0.75
Ubuntu karmic

Following these instructions (for Karmic with Kden 0.7.6) resulted in fixing my crashing problems, but taking away all audio and giving me this error: "SDL failed to open audio: No available audio device"

This was fixed by downloading this package: "sudo apt-get install libsdl1.2debian-all" (per this page: http://www.kdenlive.org/mantis/view.php?id=31) (which I found after reading this thread about no sound: http://www.kdenlive.org/forum/no-sound-after-installation-repositories)

Right now my audio drive selection is set to "automatic" and it seems to be working fine. Thanks everyone who posted here! :D

I also had crashes with Karmic and thought that it were mz videodriver.
Indeed Kdenlive works like a charm with Debian and its Pulsaudio driver.
I will give a try to desinstall Ubuntus PA and reinstall Debians one.

RIN67630