render to h264 and use 3000 bit rate?

I have presets between 2000 then jumps to 4000

What can I do to set bit rate to 3000?

Forums:

You could try a custom render profile and set bitrate -b 3000k.

When select h264, then click custom icon, this shows up
What would you put where?
What is this vb=%bitrate+'k'

do you just add -b 3000k, that does not follow the observed pattern.

f=mp4 hq=1 acodec=aac ab=%audiobitrate+'k' ar=48000 pix_fmt=yuv420p vcodec=libx264 minrate=0 vb=%bitrate+'k' g=250 bf=3 b_strategy=1 subcmp=2 cmp=2 coder=1 flags=+loop flags2=dct8x8 qmax=51 subq=7 qmin=10 qcomp=0.6 qdiff=4 trellis=1 aspect=%dar pass=%passes

I find that 2000k gives 1gb and 4000k gives 1.9gb, so 3000k would be in the middle, perhaps just right size wise.

I found some info on this here.
http://userbase.kde.org/Kdenlive/Manual/Project_Menu/Render/Render_Profi...

I can maybe understand it to set a fixed bit rate use
b=3000k?

But what about this variable bitrate line, vb=%bitrate+'k'
Take it out?
And how would you set to 3000 variable bit rate? One of the render drop down boxes lts you adjust it.

So would it be then say vb=3000k ?
Is the %bitrate just a variable the program reads from user selection out of the drop down box?

Ok, trying it and it seems to be rendering this custom profile of 3000k.

I wonder if there is a data file you can edit to just put in more bit rates for the drop down box.

I'm no coder but to me the vb=%bitrate+'k' is to take the value you enter in the bitrate drop down, but you want to overide it with 3000k, so -b 3000k should do it.

I know it seems like a good idea to encode straight to a compressed codec from kdenlive. But for projects with lots of effects, transitions, titles etc it all takes computation time baking it all in everytime.

I just encode to lossless ffv1 from kdenlive, do the baking once and then use ffmpeg or Handbrake type of tool to encode the various versions, fiddle with compression levels, rescale to smaller versions etc after the majority of the computation time has been done once.

If you want variable bit rate, then it must be
vb=3000k

here is what I have it set for now.
f=mp4 hq=1 acodec=aac ab=%audiobitrate+'k' ar=48000 pix_fmt=yuv420p vcodec=libx264 minrate=0 vb=3000k g=250 bf=3 b_strategy=1 subcmp=2 cmp=2 coder=1 flags=+loop flags2=dct8x8 qmax=51 subq=7 qmin=10 qcomp=0.6 qdiff=4 trellis=1 aspect=%dar pass=%passes

I think it is better to use vbr encoding today compared to 5 years ago when players had trouble with it. It gives a better result.
http://en.wikipedia.org/wiki/Variable_bitrate

The video I am working on is from kino captures out of digital8, so it is dv video.
I was happy to see kdenlive offer rendering to dv video, so I edit the video then was rendering back to dv video.

Is the lossless codec going to make a much bigger file? I once tried huffyuv and the output was 30gb for an hour of video.

My idea was to keep the dv video then do a render and upload to youtube, yet still keep the dv video file. If I rendered the original dv video to lossless, wont it use up so much more space?

Yes it takes up more space, it's a trade off and depends on the project, render/rerender including all effects and wait or do the majority of baking once and encode with more flexibility after.

I found that 13gb dv codec when rendered lossless turns into 30gb using huffyuv
the setting vb to 3000 made the render = 1.5gb which was about what I wished.

vb set to 2000k lost to much detail.
vb set to 4000k had good detail but file was 2gb

Lossless doesn't have to be huffyuv, there are lossless h264 render profiles in kdenlive that may fare better.

After reading this thread, I am now wondering if I have been doing it all wrong. You see, my camera bitrate is 17000 but the presets are 12000 or 18000. So, I just click in the video bitrate box and change the setting to 17000. I just assumed that as you could change this figure it was ok to do so.

normcross, that is what I do, too. And the resulting files do quite well match the typed in bitrate. The render preset might be useful, if someone does not want to type the bitrate each time when rendering.