render to a network windows7 samba share gives error on permission

I thought why not try rendering across the gigabyte lan?
Now this windows share IS public and I even turned off windows firewall.

Using Nautilus in Ubuntu, I can do whatever I wish file wise.
KEDnlive is complaining, so what else needs to be done?

also this directory already exists, so the error message is misleading.

screenshots

https://lh3.googleusercontent.com/-iqdMc2Ma-ZQ/UOlfxM11zBI/AAAAAAAAEU4/g...

https://lh5.googleusercontent.com/-rfkXskF7s1k/UOlfxFwb5WI/AAAAAAAAEU8/C...

https://lh4.googleusercontent.com/-4lqWUHVmdb4/UOlhKT1RiVI/AAAAAAAAEVk/b...

Forums:

Have you tried rendering to a samba shared folder that doesn't contain spaces, try underscores instead of %20 being added for spaces.

btw personally I don't think its very good practice to be encoding to a network share, just because we can (in theory) doesn't mean we should. :-) Just personal pov of coarse.

I am completely out of hard drive space, so I thought to try this.
I am getting a new 1TB sata3 to put in my PC, so then wont be an issue.

I am rendering a 26gb vid at the moment, when that is done in 4 hours, I will try your idea.

I put the movflags=quickstart arg in this one to see if youtube stops fussing.

Tried it, made underscores.
still get same error.

How are you accessing the samba/windows share? Did you mounted it somewhere into your local filesystem or do you try to specify a render file path that directly refers to a smb URL? The latter does not work, as far as my own experience goes, while the former works and is completely transparent to mlt (which does the rendering).

You may want to try smb4k as a UI for browsing and mounting samba and windows shares.

mounted in file system nautilus. It shows up under network or I can connect to windows share.
IN the kdenlive render gui,(hit render button) do you people use it, I am alone in this? It shows samba shares under network. I just keep browsing till I get to the right folder. I keep seeing 'mlt' what are you saying?

MLT is the underlying media handling system that kdenlive uses:

http://www.mltframework.org/

What Diveo is saying is you just need to get linux to "mount" your windows share so that it looks like a regular directory on you linux file system (which is different to browsing to it under network in nautilus). And then kdenlive render functionality (which is mlt) will not care that it is a windows share.

KDE and Gnome can directly talk with Windows and Samba shares without the help of the underlying operating system. This is really convenient, as you can browse a Windows share *without* mounting it. But the downside is that only KDE and Gnome applications support it.

Now with Kdenlive, only the Video editor uses KDE and thus works to some extend with Windows shares. For rendering a video, Kdenlive instead relies on mlt, it's multimedia rendering framework. And mlt does not use KDE. In turn, it doesn't know how to talk to Windows shares.

But if you now use the operating system to properly mount a Windows share somewhere into your local file system, then mlt can use it ... because the operating system helps it to do so. But you need to mount. And this is a separate and explicit operation, not to be confused with browsing a Windows share.

As I said previously, Smb4k is such a KDE application for searching for Windows shares and mounting them. There should be something similar for the Gnome desktop too.

Ok, is this acceptably mounted. I used the connect to server in Nautilus.

https://lh6.googleusercontent.com/-EDj5HcEj8sc/UOxs7qpTWoI/AAAAAAAAEXY/-...

I guess no, as it does not work. why should kdenlive even show network then samba shares in the dialog if that does not work?

I doubt you mounted it ... question: where did you mounted it *to*?

As for your question why kdenlive shows network shares ... I explained it above. An additional explanation may be that the developers overlooked to block such shares in the file dialog when calling to open it.