Render "selected zone" produce no video stream

Hi all,

I'm new to kdenlive which I appreciate much but I'm facing an issue that I do not manage to fix/understand at the moment.

Actually when rendering a project if I select a zone with the green bar in the timeline, and then render selecting "selected zone" instead of "full project", there is no video stream in the output file, only sound.

I was thinking that may I do not select the zone properly, but as the sound is correct it does much more look like a bug.

Is anybody else facing the same issue ?

Nono

Forums:

What rendering profile are you using? There is an issue with flash rendering. Currently, you need to set the "Scanninf" option to "Force progressive" to get a working flash video.

Yes I've seen this post about the flash issue, but mine does not seems related to a specific profile.
I tried AVI DV, MPEG4 & XVID at the moment.

I have the same problem - no video stream, only audio stream is present for most output profiles.

The only profiles that emit a video stream are the ones that are the same as the original source clips - raw DV and avi DV.

Changing the "Scanning" setting to either values doesn't help.

I'm using KDEnlive build from today's SVN and MLT from today's GIT.

This might be significant - I work under the x86_64 architecture and binaries are compiled in 64 bit mode.

What's interesting, Theora export works fine, as well as FLV export if I select "Force progressive" scanning.

Could it be related to MLT build process? Maybe it doesn't correctly detect available libraries (although I have the headers for libxvid and libx264 installed and "ffmpeg -formats" shows a list which includes mpeg4, mpeg2 and h264 among availabel encoders).

Found the solution for my case!

https://bugs.launchpad.net/ubuntu/+source/mlt++/+bug/363805

It seems that under Ubuntu the unstripped versions of ffmpeg libraries are mandatory so one needs to explicitly install them:

sudo apt-get install libavcodec-unstripped-52 libavformat-unstripped-52 libavutil-unstripped-49 libswscale-unstripped-0