Rendered DVD video - picture "jerks" in TV DVD player

IS THERE ANYONE WHO SUCCESSFULLY RENDERED A DVD on TV PLAYABLE PAL VIDEO?
Please, let me know.

After manny attempts I still experience the same kind of jerkiness in my video when played in standalone DVD player on TV (in Kaffeine, Xine or Mplayer it is OK). Generally, when I cut any clip using Avidemux, it's played well in TV, all smooth and in supposed quality. When I edit this clip in Kdenlive, adding some basic subtlitles for example, render it to DVD mpeg or vob, burn it (DVDAuthor or ManDVD and K3B) and play it in DVD player on TV screen it "jerks". Even when the video is paused! It is well visible on edges of objects. Also interlacing is too visible, the comb efect on object edges.
All this makes my video hardly viewable :(

HarryVanDerWolf suggested a possible audio bitrate/codec problem so I tried these export profile options among many others as suggested:

0:Custom:target_dvd_acodec_mp2_abitrate_128_vbitrate_1000::::avformat::mpeg:format=dvd vcodec=mpeg2video acodec=mp2 size=720x576 video_bit_rate=3000000 video_rc_max_rate=5000000 video_rc_min_rate=300000 video_rc_buffer_size=1835008 mux_packet_size=2048 mux_rate=5000000 audio_bit_rate=128000 audio_sample_rate=48000 frame_size=720x576 frame_rate=25 gop_size=15

0:Custom:DVD VOB ac3 192 video 6500_8000::::avformat:PAL:vob:format=dvd aspect=4:3 vcodec=mpeg2video acodec=ac3 video_bit_rate=6500000 video_rc_max_rate=8000000 video_rc_min_rate=0 video_rc_buffer_size=1835008 mux_packet_size=2048 mux_rate=10080000 audio_bit_rate=192000 audio_sample_rate=48000 frame_size=720x576 frame_rate=25 gop_size=15 me_range=63

0:Custom:DVD VOB mp3 192 video 6500_8000::::avformat:PAL:vob:format=dvd aspect=4:3 vcodec=mpeg2video acodec=mp3 video_bit_rate=6500000 video_rc_max_rate=8000000 video_rc_min_rate=0 video_rc_buffer_size=1835008 mux_packet_size=2048 mux_rate=10080000 audio_bit_rate=192000 audio_sample_rate=48000 frame_size=720x576 frame_rate=25 gop_size=15 me_range=63

0:Custom:DVD VOB ac3 448 video 6500_8000::::avformat:PAL:vob:format=dvd aspect=4:3 vcodec=mpeg2video acodec=ac3 video_bit_rate=6500000 video_rc_max_rate=8000000 video_rc_min_rate=0 video_rc_buffer_size=1835008 mux_packet_size=2048 mux_rate=10080000 audio_bit_rate=448000 audio_sample_rate=48000 frame_size=720x576 frame_rate=25 gop_size=15 me_range=63

0:Custom:DVD VOB mp2 192 video 6500_8000::::avformat:PAL:vob:format=dvd aspect=4:3 vcodec=mpeg2video acodec=mp2 video_bit_rate=6500000 video_rc_max_rate=8000000 video_rc_min_rate=0 video_rc_buffer_size=1835008 mux_packet_size=2048 mux_rate=10080000 audio_bit_rate=192000 audio_sample_rate=48000 frame_size=720x576 frame_rate=25 gop_size=15 me_range=63

..it is sooo frustrating :(
I tried several both video and audio bitrate options, several audio codecs, checked it back in mplayer, but all the same. No change even in intensity or type of jerkiness. I tried low values, I tried high values, I tried suggested values by Wikipedia (DVD_video article). No change.
This leads me to assumption that this problem is NOT related to video or audio bitrate.

So what is left?

gop_size=15 ??
me_range=63 ?? (google hints that many use 0 as a value here)
video_rc_buffer_size=1835008 mux_packet_size=2048 mux_rate=10080000 ..don't have a clue what is this about

I still use 0.4 version with upgraded mtl 0.2.3 lib, all from SUSE Pacman repo.

Thanks for any idea or help.

Forums:

Stil lno success, but this findings may be relevant.

Avidemux exported sequence, non-jerking video:

Frames sequnce
I(06) B(08) B(08) P(06) B(08) B(08) P(06) B(08) B(07) P(06) B(08) B(07) I(06)

I frame i every 12 frame, so GOP = 12 ?
B frames present, interesting.

Image size 720x 576
Frame Rate 25.000 fps
# of frames 332 frames
Codec 4CC MPEG
Video duration 00:00:13.280
Aspect Ratio Pal 4:3 (16:15)

Extra properties:
Packed Bitstream No
Quartel Pixel No
GMC No

Audio:
Codec AC3
Channels STEREO
Bitrate 32000 Bps / 256 kbps
Frequency 48000 Hz
Audio duration 00:00:13.472
VBR No

Kdenlive rendered, jerking video, the same clip:
I(31) P(18) P(12) P(08) P(06) P(06) P(06) P(06) P(06) P(06) P(04) P(04) P(06) P(06) P(06) I (06)
I frame i every 15 frame, so GOP = 15 (as was set in render profile)
There are no B frames at all!

Image size 720x 576
Frame Rate 25.000 fps
# of frames 320 frames (12 frames missing, interesting!)
Codec 4CC MPEG
Video duration 00:00:12.800
Aspect Ratio Pal 4:3 (16:15)

Extra properties:
Packed Bitstream No
Quartel Pixel No
GMC No

Audio:
Codec AC3 (MP2 also tested)
Channels STEREO
Bitrate 56000 Bps / 448 kbps (128, 192, 256 kbps also tested)
Frequency 48000 Hz
Audio duration 00:00:12.768
VBR No

forum.doom9.org: GOP's: I, P, and B frames explained...
http://forum.doom9.org/archive/index.php/t-19436.html

This information is interesting:

Quote:
I noticed some confusion about B frames, so I thought I would write down a quick explaination of an MPEG "GOP", or, "Group Of Pictures", as explained to me by a professor
...
Oh, BTW, in MPEG2 at least, a GOP order is always IPBBPBBPBBIPBBPBB etc etc. (pending on your GOP size), but it is always 1 I, 1 P, and 2 B's, then you can stack more groups of "PBB"'s in that one GOP if needed (usually up to 15 total frames.
...

This information indicates that Avidemux processed clip (cut and copy operation from original stream) is very close to this IBBPBBPBBPBBI.. order. And this works!

Contrary, Kdenlive exported video is IPPPPPPPPIPPPP.. only stuff. No B frames at all. May this be related? Is this MTL or Kdenlive specific? What avlib parameters I can use to achive desired IBP frames combination?

I have to report partial success.
When I reencode video clip rendered in Kdenlive in Avidemux then jittering gone away when playing in standalone DVD player on TV.
Essential is to reencode video (DVD default options) AND SOUND !! (libavcodec, ac3, 384 kbps)
Not an ideal solution but at least some progress :)

So after all harryvanderwolf may be right about the sound cause.
The question is what so bad is done to sound in Kdenlive renderer.

I have just rendered a 30 sec sequence (2 clips with a dissolve) to a vob file and it plays back on my pc very smoothly. I'm using kdenlive 0.4 on Ubuntu 7.04

Nic

I've just burned a slightly longer seq of 4 clips to a disk and it played ok on my tv from a sony desktop player. There is a bit of pixelation on one transition but no jerkiness. I'm a real Linux beginner so I dont know much about the technicalities. I used Brasero to burn the disk.

Nic

Thank you for reply.
Did you burned a Video DVD, not a data DVD? Suppose DVD Video but just to be sure.
Is your DVD player a simple one (DVD viode only) or DivX or AVI and other formats enabled? I tried only the simple ones.
PC playback of my videos was always OK, no jerking or jittering. The issues described were visible only on standalone DVD - TV player.
Anyway nice to hear that someone did it successfully.

hi espinosa,

i'm experiencing the same problem.
i have footage from a minidv camcorder which i converted to dvd (on my hardware dvd+tv plays ok).
then i made a kdenlive project with these clips (added titles, etc) and when i exported the project to dvd i got the "jerky" effect
on the hw dvd+tv.
then, i read your posts at sourceforge

http://sourceforge.net/mailarchive/foru ... live-devel

i tried the method you describe, but with partial success (some parts of the clip are still "jerky", but 70% are ok).
the profile i used is:

format=dvd vcodec=mpeg2video acodec=ac3 size=720x576 video_bit_rate=6000000 video_rc_max_rate=8000000 video_rc_min_rate=0
video_rc_buffer_size=1835008 mux_packet_size=2048 mux_rate=10080000 audio_bit_rate=448000 audio_sample_rate=48000 frame_size=720x576
frame_rate=25 gop_size=12 me_range=63 b_frames=2 real_time=0 progressive=1

and in avidemux
for video: i used "DVD" profile (_not_ "DVD lavc") with single-pass quantizer (the bitrate option causes the app to crash if you try to export),
progressive, default matrix, gop 12, and max bitrate 9000
for audio: i used "Copy" (no transcoding needed for audio)
for format: mpeg ps a+v

so, i am wondering if you made any progress, or if ffmpeg or mlt fixed this bug.
this is very important for me because it's the only reason i don't use/recomend kdenlive at work (at work i don't do video editing/mastering, but when i needed
to do a similar simple task, i gave it to someone else ;) kdenlive is not ready for production use).

have you tried v0.5 of kdenlive? if yes, did you see any improvement on this subject?

i am on debian etch with kdenlive 0.4, mlt 0.2.3, avidemux 2.3.0

thanx in advance,
poutsoklis

hi guys,

i think i solved the problem.
i followed espinosa's advice along with some other posts in mlt-devel and kdenlive-devel mailing lists.
first of all you must have libmlt-dev/dev++ (as i said before i use debian) installed, in order to have inigo installed (inigo is in libmlt-dev package).
your kdenlive project includes some clips (from your camcorder maybe - as in my case). as espinosa said, kdenlive has a problem with rendering
interlaced clips (no b-frames, with avidemux you can verify that).
these clips are the "actual problem".
suppose one of these _original_ clips (in your .kdenlive project) is called shoot_0001.vob (from the camcorder (after i shoot stuff, i make a dvd with them and then use kdenlive to add titles, music, etc; but before editing with kdenlive, i have .vob clips which i copy to my hard drive as shoot_blah_blah.vob)).
open a console and issue:

$inigo shoot_0001.vob -consumer westley:shoot_0001.westley

this will create a .westley file for the above clip.
fire up avidemux. open shoot_0001.vob and see the correct number of frames (ffmpeg can't figure out the right number). suppose it's 2631.
back to your console:

$vi shoot_0001.westley

correct the "length" tag with the right number (the one you saw in avidemux). also, there are 3 "out" entries in the clip tag.
replace them with correct_length-1 (e.g. if your clip has 2631 frames, enter 2630).
ALSO, (the _most_ important change):
change "av_bypass" tag to 1 (don't know what this tag is for, but for me this one made the difference).
save and exit.

$inigo shoot_0001.westley

this will playback your .westley playlist clip. (just for viewing)

fire up kdenlive.
open your kdenlive project which include shoot_0001.vob and replace shoot_0001.vob with shoot_0001.westley in the project clips area.
DO NOT RENDER! (kdenlive rendering will "ignore" the above changes in the .westley files)
save your project (e.g. proj.kdenlive) and exit kdenlive.
back to your console (this one is lengthy!).

$inigo proj.kdenlive -consumer avformat:proj-dvd.vob real_time=0 format=dvd vcodec=mpeg2video acodec=ac3 size=720x576 video_bit_rate=6000000 video_rc_max_rate=9000000 video_rc_min_rate=0 video_rc_buffer_size=1835008 mux_packet_size=2048 mux_rate=10080000 audio_bit_rate=448000 audio_sample_rate=48000 frame_size=720x576 frame_rate=25 gop_size=12 me_range=63 b_frames=2 progressive=1

this is for rendering proj.kdenlive to proj-dvd.vob

$mplayer proj-dvd.vob

to see if everything is ok.
after that, i use dvdauthor (or one of its front-ends, like dvdstyler or mandvd) for authoring and burning.

hope someone will test it and let me know if it was successful. for me it worked.
as i wrote before, i use debian etch with kdenlive 0.4, mlt 0.2.3, avidemux 2.3.0 installed.

good luck,
poutsoklis

This thread saved me a whole lot of editing work. I edited a family movie with effects and sounds and stuff and everything looked perfect as long as I viewed in Kdenlive. But when I rendered it to a DVD I got the same jerkiness. This is using Kdenlive 0.5 on Mandriva 2008. Before seeing this post I found out that the interlacing is indeed the problem. The standard profile for rendering to MPEG1 gave a result without jerkiness. When I create a custom profile based on that where I change progressive=1 into progressive=0 gives the same kind of jerkiness as when I create the DVD. I don't have to burn it and see it on the TV set, it is already very visible in Kaffeine on my PC.
Anyway, using the profile mentioned above

format=dvd vcodec=mpeg2video acodec=ac3 size=720x576 video_bit_rate=6000000 video_rc_max_rate=8000000 video_rc_min_rate=0
video_rc_buffer_size=1835008 mux_packet_size=2048 mux_rate=10080000 audio_bit_rate=448000 audio_sample_rate=48000 frame_size=720x576
frame_rate=25 gop_size=12 me_range=63 b_frames=2 real_time=0 progressive=1

, the video rendered completely OK without the jerkiness.
I found out that there is a setting in my camcorder that is called progressive. The manual says that enabling the progressive mode leads to better quality of photos. Doesn't say anything else about it. Since I only very rarely take photos with my camcorder, I disabled the progressive mode. Hope that I got rid of that problem know.

Ciao,

Sitor

Someone who was new to Linux and Kdenlive asked me via private message how to perform what I mentioned in the message above. Since others might be interested in the same thing, here is the answer I wrote down:

Quote:
It is pretty easy really. In Kdenlive you do [File] / [Export Timeline]. In the [Render Timeline] Window that opens, select the [Custom] tab. Click the [New] button to create a new render profile. A [Custom Encoding Options] window opens. Give your profile a name in the [Name] field (e.g. DVDwithoutJerking). I have no idea what the [Extension] field is for, so I don't enter anything in there. In the [Parameters (libavformat)] field, you need to specify the command that needs to be run. That is the complete command that was mentioned in the thread:
format=dvd vcodec=mpeg2video acodec=ac3 size=720x576 video_bit_rate=6000000 video_rc_max_rate=8000000 video_rc_min_rate=0 video_rc_buffer_size=1835008 mux_packet_size=2048 mux_rate=10080000 audio_bit_rate=448000 audio_sample_rate=48000 frame_size=720x576 frame_rate=25 gop_size=12 me_range=63 b_frames=2 real_time=0 progressive=1 Just copy it from this message (as you indicated that you are new to linux, here is another tip: if you just select that whole command in this page of your browser, and in the field in Kdenlive you click with your middle mouse button (your wheel if you have a wheel mouse), then the text will be entered without any copy / paste commands required). Click [OK]. Select the rendering profile you just created and click the [Export] button.

Good luck! Let me know whether the result is OK or not.

Ciao,

Sitor

I hope that it might serve others.

to sitor:

I have no luck with recommended settings - still getting jerking vob or mpg file.
My DVD-player does not see any timecode on this file - time counting always hangs at 0:01
If I create a DVD then videos I rendered with Kino or Mainactor play perfectly but Kdenlive rendered videos start jerking after 10-15 sec.
Any suggestions from developers?

Using Ubuntu 7.10