Rendering audio speed issue

I have two versions Ubuntu 7.04 (x386 & amd64). Both versions of kdenlive render the audio sound tracks just a little to fast, it sounds like a record album playing at a wrong speed.

Has anyone else encountered this issue?

thx for any help!

Forums:

Hi

Same config (ubuntu 7.04 & x386) and same trouble with the sound speed !
If anyone could help ... thx by advance ;)

I could report this issue also on my pc (Kubuntu 7.04).

After export as raw dv the audio is a couple of seconds ahead of video.

The problem doesn't occurs on export as *.avi format.

my video is playing fast, and my audio is playing even faster. It plays fine through the timeline, this only happens when I render.
I'm on Ubuntu 7.04 Feisty.

So, is this just a Ubuntu issue? I tried Gusty today and have the same issue.

Hi,

which version of kdenlive are you using ? I'm running svn version 1716, with MLT 0.2.4 and last ffmpeg svn version in Ubuntu Gutsy and have no problem with audio desync. I've tried rendering to dvd and mpeg4 and both are OK.

So maybe problem is more related with kdenlive or ffmpeg versions than with Ubuntu !

Regards.
JM

I'm not running the SVN verison. I did apt-get install and installed kdenlive .5.

So your saying that is your add a sound track(mp3 file) to a slideshow or movie, the sound plays at a normal speed?

Hi,

yes, working with the versions I mentioned, with a kdenlive captured video directly from a mini-DV camera (captured as Raw DV), processed and rendered in mp2 and mp4. I had no problem with audio desync.

If you can update to latest kdenlive version, please let us know if this solve the problem.

Regards.
JM

I tried to install the CVS version + ffmpeg, but had some errors and then ran out of time.

If you have some free time, could you verify/test this setup:

Import some pictures as a slideshow.
Add your FAVORITE mp3 file for background music.
Export to Mpeg2 (DVD).

After exporting, watch the movie. Listen closely, does the sound track play at a normal speed, or a little fast.

Ive had to create several custom slide shows lately and ended up using Cinelerra instead of Kdenlive because of this issue.

thx

Hi dad311,

I've tested what you suggest and I can confirm there's no audio delay in the final video.

I've made a slideshow with 69 images and let kdenlive default the settings (2 seconds per slide, 0,1 second transition). I used default crossfade transition between slides. I've added an MP3 audio file and resize it to fit the video (2 minuts 17 seconds in total). I've exported the result as DVD with standard kdenlive settings and using TOTEM to play, the video and audio are totally sincronized.

To be honest, I've to say that it has been impossible to play the video inside kdenlive. The audio and video collapsed everytime a transition is found (2 seconds ok, then noise, 2 seconds more ok, more noise, ...). But I think this is another issue (I'll try to reproduce and report a bug) and, as said, when rendered everything works fine.

Hope this helps.
Best regards.
JM

Thanks. When I get some time, Ill try to install the svn version.

Thanks again!
:D

Are you working in NTSC (29.97 fps)?

http://www.kdenlive.org/mantis/view.php?id=23

It seems there is an issue with NTSC and it is being worked on, but until then NTSC rendering seems to have issues:

Quote:
Hey, as a result of this bug:

http://www.kdenlive.org/mantis/view.php?id=23

I have determined that MLT and therefore kdenlive is currently broken for any
profile not using 25 fps. By broken, I mean various things related to
editing, particularly in and out points are not working as expected. This
occurred with the introduction of mlt_profile. I have in my MLT working copy
a bugfix that I am testing.
--Dan Dennedy, MLT

yes thats me NTSC (29.97 fps).

Thanks for the reply.