rendering completes, but file says ¨invalid ¨

Hi, I just tried to render a 20 min video as theora, it all seemed fine, but the when I play the resulting clip it just shows the word ¨INVALID¨ in white on a black background.

Does anyone one know why

1) Kdenlive is having an issue rendering in a free video format (I have has issues with this before, it seems to find mpeg´s etc easier)

and

2) why kdenlive does not seem to notice/does not tell you that it is rendering an invalid file?

This seems to me like a bug, but I wanted to see what people made of it first, has anyone else had this problem?

best

Anna

Forums:

ps: when from command line

melt clip_1.ogv
Failed to load "clip_1.ogv"
Failed to load "clip_1.ogv"
Usage: melt [options] [producer [name=value]* ]+

but melt plays other videos downloaded from net...

i installed the ffmpeg-theora thing in synaptic/muon and have now been able to render to theora. I don´t really understand what/how i have fixed, can anyone enlighten me as to if i have fixed or simply sidestepped this issue?

Hi! Looks to me as if you have been missing a theora decoder/encoder for melt to use for playback. But after adding "ffmpeg2theora" your melt can handle this.

ffmpeg2theora: "This package provides a command-line tool to encode/recode various video formats (basically everything that ffmpeg can read) into Theora, the free video codec."

So I'd say your issue is solved.

hum, sounds good, but itsn´t it now using like an extra step? If kdenlive renders to theora, can´t it usually read it too? Perhaps I don´t understand what you mean by decoder/encoder, but it strikes me as odd that I could encode as theora but not read it? Is there a more exacting solution out there?

It is not an extra step, it's just a step.

How can you be sure that kdenlive has rendered to theora before? First you have had "INVALID" as a text, other files from the internet played well (so I guess you did not render to theora). After installing the ffmpeg2theora package rendering worked. That does not look like you've had a playback issue.

Just a word on the encoding/decoding stuff:
decoding/encoding = (en)COding/DECoding = CO/DEC = codec

Imagine a codec as a manual of how to treat some data. It is a description of how the bytes have to be arranged (coding) or interpreted (decoding) to make sense.

Why can a computer encode but not decode? Analogy to real life: If we learn a human language, we are able to use it in two directions (understand and speak). Having the computer as a (dumb) machine, it can "speak" perfectly, if it has an encoder for the "language" (theora in your case). But unless it has also a decoder, it will perfectly fail to "understand" the same "language" (again theora). In your case it was just the other way round.

It might be also annoying, that, even if ffmpeg2theora a pure decoder, it could make sense, as the data is sent from one software to the other and just another while rendering (at least involved: kdenlive, m(e)lt, ffmpeg). kdenlive is just a graphical frontend for all the software involved and does not even know how to encode or decode any byte from your camera without all the other software around. So adding an encoder or decoder to ffmpeg or melt or mlt or simply at the right place, enables kdenlive to use it.

"How can you be sure that kdenlive has rendered to theora before? First you have had "INVALID" as a text, other files from the internet played well (so I guess you did not render to theora). After installing the ffmpeg2theora package rendering worked. That does not look like you've had a playback issue"

Ok, i understand more - but this said, I would expect kdenlive to be able to tell me at some point during the 20 mins it took to render, that its not in fact able to render to that format because the codec is missing. I have had it tell me (on previous installs) that it doesn't have the correct codec to render to a specific file type - any idea why it didn't do this for theora?

KXstudio have put the ffmpeg2theora in to their bundle for the next version :)

"I would expect kdenlive to be able to tell me"..."any idea why it didn't do this for theora?"

Your expection is comprehensible, but there are at least two reasons, why you did not get notified in this case:

1. kdenlive knows that the result is unusable, but does not tell you (if intended: nasty developer (very unlikely), if not intended: bug)
2. kdenlive does not know that the result is nonsense, because it streams the data to another software, which does not tell kdenlive, that it produces nonsense (maybe because itself does not know this for some reason).

Do not forget that kdenlive is still moving. :) Finally you have got it running... :)

yeah, i am doing so well with it now, making a super cool vid which i will post soon! whoot!!

as for two reasons, the options seem logical, but either way, i think this is a bug. At the end of the day, not everyone will bother to take the time to find out why something is not working... I would hate for Kdenlive to lose users over little things like this: ( I will try and make a repost today :)

I haven't tested to encode to theora myself with kdenlive. I suppose the encoding worked for you, but the decoding didn't work (when you got the INVALID message). The OGG files you've downloaded from internet that you could play may have contained other video formats than theora since OGG (OGV) is just a container format.

kdenlive could check that the encoding process worked (I'm not sure if it do check before encoding though), but the decoding is more difficult to check because the use can use a lot of different programs to decode the video stream. Did you try to play the OGV file you made using theora codec in VLC? VLC can handle/play/decode a lot of formats. What I'm trying to say is that maybe the encoding worked, but not the playback (decoding) using melt? As I mentioned above, I haven't tried this myself so I'm just throwing out some theories here.

Read more: http://en.wikipedia.org/wiki/Theora

..oh, and yes gingerling, it would be nice if kdenlive could assist the user in getting the right packages for playback of the produced movies. But I'm not sure if I would call this "a bug" in kdenlive ;)

Hi, yeah, I use vlc for most playback anyway, its such a failsafe :) I think kdenlive does try and help you right? I mean it checks at the start to tell you that you have everything you need, it said I had everything that I needed. Not sure if you can re-run that initial config without reinstalling, as I could check the codecs bit on there and see of kdenlive thinks it has the codec or not. With regards to if its a bug or not, I don't suppose it matters what we call this kind of problem, but I really don't think any piece of serious free software can afford to lose users/potential future help over something which looks like a critical error, but is in fact, just one missing codec :)

Maybe it's easy to add another package dependency into the kdenlive installation, I'm not the right guy to tell. But I suppose someone has to test first if the extra package is needed to encode/decode theora video, and if adding the extra package can have other impacts on the system. Then someone could add the package to the kdenlive installation files.

>Not sure if you can re-run that initial config without reinstalling

You can, use menu "Settings / Run config wizard"