Rendering completes successfully although video is incomplete

I've recently run into a frustrating problem that my short movie (only around 7 minutes in length total) will complete rendering successfully. Unfortunately when I attempt to watch the the video in VLC, movie player or other players the video appears to either crash or end around the 6 minute mark. I've tried different profiles such as HD PAL 720, NTSC, Web formats, etc. I've had the best luck with the HD PAL profile, and was actually able to render successfully once.

I'm currently using Ubuntu 12.04, pulling the latest Kdenlive and MLT from the PPA. I'm running on an Intel Sandy Bridge Core i7 CPU, with 4GB's of RAM. More than 100GB free of storage on my user partition.

Help!

Forums:

So, what are your clips? MTS? or what? 25 fps, 30? Oh, and what project profile are you using?

So, so sorry, so many questions :-))

Ask as many questions as you need. :)

Most of my clips are JPEGs, I also have three different MP3's used for background audio. I'm not sure what MTS is, so you may have to fill me in on that.

I'm using "File Rendering" under the HDV profile, using PAL 720 25p (which I'm guessing is 25fps)

I just rebooted the machine and ran the render again, this time with complete success. I'm still not able to do this consistently though.

Hummm... Some more questions to analyse what is happening...

1. Check if the players crash or the movie is just over:
Do the players output any error message when stopping or crashing? Run the player from command line like vlc pathToMovie or mplayer pathToMovie

2. Check the movies rendered length:
What do the players tell you about the movie length when running on command line? Something in 7 or 6 minutes?

3. Check if there is a fixed point of stalling:
Comparing two render attempts: Is it always at the same time or at different times?
-> If crash or stop at the same time:
What happens in the movie at the point of stalling? Any transition, cut, or something?
->If crash or stop at different times:
Do you always render the whole movie or only a part (using i/o points in project view?)

Are the images massive size in resolution and file size? Like DSLR digital camera photos, if so you may find it an advantage to prep those by batch converting in a image editor, scaling and crop to the 1280x720 resolution before adding to the timeline to save some memory usage.

Check how many encoder threads you might be using in kdenlives config.

Thanks for the follow up. I'm away from my home computer right now, but I'll be able to answer in more detail when I get a chance to experiment further tonight.

1. Previously, the players appeared to be crashing/hanging at a certain spot in the video, but I didn't look at any debug output or logs to see any specific error message (good suggestion which I will try tonight).

2. I'll check the specifics on the rendered length tonight. I seem to remember that Movie player indicates the length of the video as intended, but VLC accurately reports the actual length that was rendered (up to the error). So it's probably a great indicator of the spot where the renderer may have experienced an issue.

3. I didn't confirm if it was the same place every time, but another great suggestion that I will try tonight. And all attempts to render have been with the entire movie, not just a selection.

Thanks again!

@yellow - Great suggestion. Many of my photos are very large (i.e. taken with DSLR) and are being imported directly as high quality as possible. However, I think reducing the resolution as you said would probably make only a negligible difference in the output quality so I will give that a shot. I should also revise my earlier system RAM number was not correct. I actually have 8GB of system RAM.

@nebhead, yes reducing the resolution before adding to the timeline and encoding to 720P will make no difference in quality, in fact doing it in a image editor gives more control theoretically as you can choose the scaling algo, not suggesting kdenlive's isn't good enough though.

re 8GB RAM and assume you're using a 64bit build of Ubuntu 12.04 to be able to access that.

Yes, I'm using 64-Bit Ubuntu 12.04.

And thanks for the tip on reducing the size. I'll give it a shot.

OK, was able to reproduce the issue last night using the NTSC 720 30p profile. The video stops at 6:37, during a fade to black and pan/zoom effect. The VLC player doesn't seem to crash - and the video actually appears to be just ending at that point. I didn't get much time to do more analysis last night, but I do want to try reducing the image sizes (especially on this clip) to see if that will help.

I'll also try rendering again today, to see if it stops at the same spot or if it's more intermittent.

Thanks!

Confirmed last night that it fails/stops rendering at the same exact place every time I render (6:37). This may help.

OK, even after re-sizing photos down to a more manageable size, I still get the render issue with NTSC 720 30p. Rendering appears to stop at 6:37.

I assume you render the complete project and not a selection that ends at 6:37?