Rendering crashes and Kdenlive 0.8.1 uses all memory

I upgraded from 0.8.0 to resolve an issue my project was having with rendering, whenever I tried to render my project to file it worked however it rendered using the proxy clips even with the box unchecked. I'd read someone else resolved the problem by upgrading to the SVN so I tried it and now there is an entirely different problem with rendering. Now when I try to render to file with any format I choose it'll go up to 6% and crash with the error "Rendering aborted resulting file will probably be corrupted", my system becomes very unresponsive when this happens and after checking the system monitor I found it's because it uses all 2 GB of my ram and another 2 GB of my swap.

I rendered to script and when I run

"/usr/bin/melt atsc_720p_2398 avformat - /home/adam/kdenlive/scripts/script005.sh.mlt file:///home/adam/Desktop/test2.mp4 f=mp4 hq=1 acodec=aac ab=384k ar=48000 pix_fmt=yuv420p vcodec=libx264 minrate=0 b=4000k g=250 bf=3 b_strategy=1 subcmp=2 cmp=2 coder=1 flags=+loop flags2=dct8x8 qmax=51 subq=7 qmin=10 qcomp=0.6 qdiff=4 trellis=1 aspect=@16/9 pass=2 threads=4 real_time=-1 -verbose"

from the terminal it launches a window that plays my project and my memory usage stays low. I noticed in the video playback a couple of the clips don't match what is in the project, they're scenes that happen a little before the clips the timeline uses.

The first errors it spits out are

Failed to load "atsc_720p_2398"
Failed to load "avformat"
[mp3 @ 0x8828cd0] max_analyze_duration reached
[mp3 @ 0x882fd40] max_analyze_duration reached

and later it says

Failed to load "file:///home/adam/Desktop/test2.mp4"

Can anyone help me debug this or does it looks like I'm going to have to do a re-install?

Forums: