Rendering a DVD output results in a huge VOB file

Hi,

I am new to kdenlive and to video editing in general. So far I am really enjoying working with kdenlive, it is quite easy to use and powerful. I am facing a small issue however, that I need some help with.

I have two VOB:s that I import into kdenlive and that I would like to combine (one of the imported VOB:s has a missing footage that the other VOB does have, so I want to use this to fill the gaps in the first VOB and to export everything as a new DVD/VOB). I also want to replace the audio from the first VOB with the audio from the second VOB.

The original imported VOB:s are around 3.5-4 GB each. However, after I render the DVD/VOB when I am done editing, the resulting VOB is 6.2 GB! I would have hoped that the size should have landed around 4-4.5 GB so that it fits on a single DVD, as the input DVD:s are not that large either.

What am I doing wrong? Are there any preferences I can change in the rendering that would help me achieve the smaller VOB size?

I will gladly provide more details if necessary.

Thank you in advance.

Kind Regards,
Veroslav

The file size of rendered output always depends on the bitrate. I guess the bitrate of your Kdenlive render profile is higher than the one from your input VOB. You may want to create a custom profile as a copy of the original VOB profile and lower the video bitrate values.

The video bitrate is displayed when playing the vob with mplayer, vlc or so from command line.

If you want to calculate the bitrate for a specific file size, take look here: http://www.kdenlive.org/forum/trying-render-mov-and-keep-it-under-750-mb...

Thank you for your fast reply, al25fps. I will have a look at the bitrate and try to change it in order to accomodate for a smaller output file size, as soon as I am back at home tonight. I managed to find exactly the same thread as you mentioned in your post just after I posted my question here, and thought that it might have something to do with the bitrate not being set correctly.

Kind Regards,
Veroslav

Hi veroslav, If this works for you please update it here, since i am having the same issue, i would try it if it works for you.
Thanks

------------
snel afvallendikke buiksnel afvallen in een week

Hi abhikala1,

I can confirm that adjusting the bitrate for the output file does indeed makes it much smaller. However, as expected, the video quality of the resulting file (4.3 GB) is much lower. So right now I am experimenting with some other stuff in order to keep the video quality high.

On a related note, I didn't find any easy options to set the output bitrate in the GUI (render window), so I created a new render profile based on PAL/DVD/4:3 and manually set the ffmpeg output parameters (believe it was -b, -minrate and -maxrate resp), that I set to the target bitrate. It works this way but perhaps there is a simpler approach though.

Regards,
Veroslav

dvd bitrate is always 8Mbps isn't it -or this is the maximum?

no you don't want lower than that, dvd Q is low anyway, its just you don't notice it when sitting away from the TV and when not looking for crispness.

have you checked the duration of project, you haven't combined too much data?

just curious!