Rendering is not producing anything

I created a project and when I try to render it I get an empty file. I have tried rendering to different formats, tried selective rendering, I am not sure what I am doing wrong. This is my first attempt at creating a video with this program, any advise would be helpful, Thanks.

Forums:

Hi, what version of kdenlive, linux distro version or mac? Source video file code?

Did you place clips in the timeline?

Haha yes I put the clips in the timeline :)

I have Umbuntu 12.10 and using kden 0.9.2, I tried to just test rendering on a few video files and it seemed like it was working, so I thought I might have done something to my project so I started over and rebuilt it. Still not rendering, when I choose the output file and push render, 7-30 seconds later it says finished and I have nothing but I file name with no content. I can send the project if someone wants to look for themselves.

Have you got ffmpeg from Ubuntu 12.10 repository or from somewhere else?

What codec & container are your source video files?

i got it from the unbuntu repository, and the source videos are .mov files. Not sure what codec. I used the same files for a test and it seemed to work but when I wanted to finish the whole project is where I am having trouble.

could this be the old "rendering stops at the first title" problem? http://www.kdenlive.org/forum/rendering-suddenly-goes-100-after-first-ti...

In a copy of your project can you try deleting any titles you have and try rendering.

If that works then you should maybe try installing the 0.9.3 beta version that is around

For Ubuntu you could use sunabs 'stable' PPA probably more upto date than Ubuntu's repo, otherwise the 'unstable' PPA near latest git

Hmmm, i have a title right in the beginning. I will try removing it and see if that works.

Okay, so after reading the thread ttguy put the link to, I ran Kden with sudo kdenlive in the terminal and....It worked. I would never have figured that out on my own, Thank you guys so much.

matt

Hopefully there's a bug report for this then, because running kdenlive as superuser is no solution. Its a work around to a bug that needs fixing and running as su should not be recommended.

And as a sunab PPA user on Ubuntu 12.10 and any others doing the same not have the same problem?

Could this be more to do with the access to hardware rights that can be set in the individual user setup at OS level causing problems with some effects plugin? Where as su or root would have access to all hardware.

If you go into user settings in Gnome for example and tick all the boxes for levels of access to sound, modems etc etc, I know I have them all ticked and then run kdenlive as normal does it render?

I'm not at my machine to test this theory though. :-)

that thread is old and suggests it is a mlt bug. and thus it might be fixed in more recent mlt builds