Rendering stuck at 0%

Since I've been able to build the 0.6SVN version after this latest round of improvements, I have created a very short test video. Unfortunately, my export is stuck at 0% across the bottom of KDEnlive; since I launched it from a terminal I have its current actions, which are this and only this since I clicked the [export] button:

kdenlive:  / / / /CHOSEN ENCODER CMD: :MED:Mpeg:720x480:High::avformat::mpeg:format=mpeg minrate=0 b=12000 ab=384000 ar=48000 s=720x480 progressive=1
kdenlive: +++++++++++  Generating scenelist start...  ++++++++++++++++++

Its been sitting there for ten minutes. Any ideas??

Forums:

A bug was opened about this issue. My guess is that you don't have the "inigo" binary in your path, so Kdenlive does not find it. I committed a fix to Kdenlive so that now it will check that and ask for a path if required. Please try updating (Mlt and Mlt++ need to be updated too) and let me know.

Related bug report:

http://www.kdenlive.org/mantis/view.php?id=85

Edit: it might also be that you have 2 versions of Mlt on your system, an stable version installed system wide and a development version installed locally. In that case, you need to tell Kdenlive to use the development version of inigo. To do this, go to Kdenlive Setting->Misc and give the correct path for inigo.

I recompiled and it still didn't work, even though the Inigo path was there; then I opened the Inigo path folder selection thing, and clicked on the Inigo binary itself; at that point it worked and my export is working!

AND, the audio and video are in sync, and cutpoints are accurate! (NTSC) That was a big issue for me before, so this seems to be working much more reliably! JB and Dan D, you two and your teams are amazing. Thank you both!

Well I have exatly the same problem.
My export is stuck at 0%.

To sum up my configuration, I installed kdenlive on my Suse 10.3 from the Packman repository.
It has auto installed both kdenlive 0.6.0-svn and MLT 0.2.4 and MLT++ 0.2.2.

I have read that kdenlive could possibly not find the inigo binary. So I had it to Setting->Misc. But it has no effect. It only says that I need to reconfigure it at startup. So I put /usr and it starts fine, but still does not export.
I also have heard that we should better install MLT 0.2.5 ? Is that right ? Does this means that PackMan dependencies are not well achieved ? How to do this in a clean manner on Suse ?

For information, my input files are H.264 encoded with MP3, but it is rendered correctly in the viewing window. So I think it is fine, but who knows ?

Please help me ! This soft is wonderful but I can't use it at its maximum. :cry:

Hi.

I just checked and the suse 10.3 package is quite old (47 days old). This version does not use inigo for rendering, but instead uses kdenlive_render. One thing you can try is to generate an export script (from the render dialog, click on the "create script" button, choose a location and press "save")

Then, open a terminal, go to the directory where you saved your script and run it. If the script is called "my_project.sh", type:

./my_project.sh

what does the output say ?

regards
jb

Well it seems that it begins normally. And in the end, the video clip is created successfully. WOW !
The only problem is the sound that is scratchy when I associate both a video and a separate sound track. Because on the other hand when I create a video with both video and a sound track the sound is very good.

Here is the result of the command line. It seems that the end is not handled properly since the script never gives back control to the prompt.

lxuser@linux:/windows/data/Agnes> sh ./test.sh
Starting rendering to untitled.m2t...
*** glibc detected *** kdenlive_renderer: free(): invalid pointer: 0x0808bc50 ***

Thanks a lot for your answer. Now I can at least render my video.
Maybe you plan to update the Suse 10.3 packages ?

Sorry in fact I realized that I did not answered your question exactly.

When I type ./my_project.sh, the prompt says:
bash: ./test.sh: /bin/sh: bad interpreter: Permission denied

So maybe it is also a problem ...