repeated play and pause crashing kdenlive

if I keep pressing play and pause in the project monitor and moving around in the
timeline kdenlive crashes,

I get this from the terminal

ALSA lib pcm.c:7316:(snd_pcm_recover) underrun occurred
ALSA lib pcm.c:7316:(snd_pcm_recover) underrun occurred
ALSA lib pcm.c:7316:(snd_pcm_recover) underrun occurred
ALSA lib pcm.c:7316:(snd_pcm_recover) underrun occurred
ALSA lib pcm.c:7316:(snd_pcm_recover) underrun occurred
ALSA lib pcm.c:7316:(snd_pcm_recover) underrun occurred
ALSA lib pcm.c:7316:(snd_pcm_recover) underrun occurred
ALSA lib pcm.c:7316:(snd_pcm_recover) underrun occurred
ALSA lib pcm.c:7316:(snd_pcm_recover) underrun occurred
ALSA lib pcm.c:7316:(snd_pcm_recover) underrun occurred
ALSA lib pcm.c:7316:(snd_pcm_recover) underrun occurred
ALSA lib pcm.c:7316:(snd_pcm_recover) underrun occurred
ALSA lib pcm.c:7316:(snd_pcm_recover) underrun occurred
ALSA lib pcm.c:7316:(snd_pcm_recover) underrun occurred
ALSA lib pcm.c:7316:(snd_pcm_recover) underrun occurred
ALSA lib pcm.c:7316:(snd_pcm_recover) underrun occurred
ALSA lib pcm.c:7316:(snd_pcm_recover) underrun occurred
ALSA lib pcm.c:7316:(snd_pcm_recover) underrun occurred
ALSA lib pcm.c:7316:(snd_pcm_recover) underrun occurred
KCrash: Application 'kdenlive' crashing...

I'm using svn and I had the audio tracks mute and I was playing music in amarok (might be relevant)

edit: my phonon backend is vlc

edit2: Tried a clean session with a video clip because previous session only used graphics and title clips, but the
crashing still persists. Sometimes it crashes when I press play and sometime when I press pause.

Forums:

Me too. I have a 1-hour clip that I'm trying to chop into small scenes, so I'm jumping around with the preview window, playing, pausing, setting in/out. I don't get very far before it freezes and I get something like this in the terminal:

...
[h264 @ 0xb279360]AVC: Consumed only 6209 bytes instead of 6212
[h264 @ 0xb279360]AVC: Consumed only 6201 bytes instead of 6204
[h264 @ 0xb279360]AVC: Consumed only 31297 bytes instead of 31300
[h264 @ 0xb279360]AVC: Consumed only 112263 bytes instead of 112266
[h264 @ 0xb279360]AVC: Consumed only 23773 bytes instead of 23776
[h264 @ 0xb279360]AVC: Consumed only 6489 bytes instead of 6492
ALSA lib pcm.c:7245:(snd_pcm_recover) underrun occured
ALSA lib pcm.c:7248:(snd_pcm_recover) cannot recovery from underrun, prepare failed: Input/output error
ALSA write failed (unrecoverable): Input/output error
[h264 @ 0xb279360]AVC: Consumed only 102019 bytes instead of 102022

BTW, I've got a freshly updated 0.8 with 0.72 of that M-thingy package.

I keep trying to come back to KDEnlive every few months, hoping that its stability problems will have been fixed. It's such a great-looking editor and it seems lots of people have success with it. Not me.

It may be related to my continuing audio problems (audio stops working regularly when I'm listening to music, watching movies and even in Firefox) but I it's been my understanding that that's just an Ubuntu problem that's pretty widespread since PulseAudio? I dunno, I'm no Linux guru.

EDIT: {SOLVED} I had been running Ubuntu Studio 10.04, but I never use 95% of the apps that are included, so I decided to do a fresh install of Ubuntu 11.04, then installed KDEnlive. So far, so good! I don't want to jinx it, but what a joy to use this editor... I'm very excited :)