Shearing distortion

Hello,

In another thread it was posted that the shearing distortion that some people had reported when using compositing and transparency effects and transitions had been fixed in kdenlive 0.7.9 SVN and with MLT > 0.5.10. Sadly, it still seems to be present. I am using MLT 0.6.2 and I downloaded and built kdenlive SVN (version 5520) and the problem still seems to occur.

The images below show the result of placing one image on top of another in two adjacent video tracks. To the top image, I have attached both the Transparency effect and the Composite transition (in order to get an alpha channel to make the Transparency effect work). The first image shows the preview window (showing the sheared top image), and the bottom image shows the timeline where this happens. (Note, the images are in the following post as the original form would not let me attach images.)

Here are versions of libraries I am using:
kdenlive : SVN (5520)
MLT: 0.6.2
FFmpeg (incl. libswscale): 0.6.201103092102git

Please let me know if there is any other information I can provide.

Dave

The original posting form didn't let me attach the images, so here they are:

Dave,
Since I'm the one that might have led you astray about the shearing problem being fixed, I thought I'd see if I could reproduce this problem. The first thing I noticed is that I can't even find a Transparency effect. Is that buried somewhere other than in the standard Effect List?

Nevertheless, I think I was able to achieve the effect you were looking for with just the Composite transition and adjusting its Opacity property. And there was no shearing when I did that. But I don't know what other properties your project and clips were using.

My versions are:
Kdenlive: SVN 5520
MLT: 0.6.3
ffmpeg: SVN 0.5.1

Jack

Hi Jack,

The Add Effect menu in SVN is now hierarchical, so the Transparency affect is available by selecting the clip and right-clicking the mouse and selecting "Add Effect -> Alpha Manipulation -> Transparency". Note, this may be a frei0r plug-in, so if you don't see it, you may need to install the frei0r plug-ins.

BTW, I didn't mention, but my project is HD 1080p 29.97Hz, and the images I placed on the timeline are still images of 1920x1080 resolution

I also noticed a few other things:

1. As you noticed, The problem only occurs if both the Transparency effect and Composite transition are both present. I agree, the same thing can be achieved using only the Composite transition, but I was experimenting with the transparency effect to see how it worked when I noticed this. If this is a frei0r plug-in, as I believe it is, it may be superfluous; however, the fact that the shearing occurs means that there are still some conditions that can cause it and it should probably be tracked down because one never knows when it might creep in.

2. I also noticed that for the shearing to occur, the transition must be set to Composite. Any other settings, e.g., soft light, lighten, addition, Dissolve, etc. don't cause the problem.

3. This way of duplicating the problem seems to be repeatable for me (two images on different tracks with the top image containing both the composite transition and Transparency effect).

I notice that you are using a slightly newer version of MLT. Your version of ffmpeg seems different. ffmpeg is now using Git, so I suspect yours may be older. Since the problem is intermittent and occurs after the input images are read, I suspect it's not a problem with ffmpeg.

Dave

OK, I think I solved this. I tried this on my laptop at work, and the problem did not appear, even though I was using kdenlive 0.7.8 (stable version). What I found was that on my home machine, where I saw the problem, I still had an old version of mlt (0.5.10) installed in parallel with the newer version (0.6.2), and when I removed the old mlt package, kdenlive SVN now does not show the problem.

Somehow, kdenlive must have been using mlt 0.5.10, even though the config wizard reported that it was using mlt 0.6.2. So I think that solves the problem.

I guess the real question is why kdenlive's config wizard thought kdenlive was using mlt 0.6.2 when in fact it was using mlt 0.5.10.

Dave

Dave, glad you solved the puzzle.

As for the Transparency effect, I don't have it listed under Alpha Manipulation. I do have frei0r-plugins 1.3 installed and have other -0r effects listed, but not that one. Maybe I'm still missing a related plugin. Oh well, I haven't needed it yet so I guess I won't risk messing things up by trying to install something else.

Thanks.

Yes, I guess I was a victim of shared library hell :)

Hmmm, I have compiled frei0r 1.3 but have not installed it yet, but I do see the transparency plug-in. Maybe in this version, it goes into a different place in the menu hierarchy.

In any case it most likely is not very useful. It doesn't have any effect unless you place a Composite transition on the clip, and once you do that, you can adjust the transparency with the Composite transition. There seem to be a number of frei0r functions that overlap with built-in kdenlive effects.

Dave

If you use the build script it creates a more isolated runtime environment:
http://www.kdenlive.org/forum/build-script-instructions-new

When you do, please check the path to melt in your Kdenlive settings to make sure the melt binary used for rendering is the correct version as well.

Also, FYI, transparency has been disabled since the last kdenlive release:

ddennedy@I7-desktop:~/src/kdenlive$ svn log -r 5106
------------------------------------------------------------------------
r5106 | ddennedy | 2010-11-19 23:36:36 -0800 (Fri, 19 Nov 2010) | 6 lines

Remove transparency effect.

It is not obvious that it requires composite, it is redundant with
composite's opacity, and it is demonstrated as unstable:
http://www.kdenlive.org/mantis/view.php?id=1464