Show Background Not Working?

Okay, so I go to the Title Clip Properties. I check the checkbox that says "Show Background", which shows a preview of the clip with the background showing (Instead of checkerboard gray and white). I click OK. I go back to title clip properties. It's UNCHECKED.
Am I missing something or being stupid?
I'm trying to get 3 different title clips to play on screen at the same time, one with text and the others each with one image. They're on 3 different tracks slated for the same time.
I've tried restarting and doing it in a new project with no success. Suggestions?

the "show background" feature is not saved. currently, when activated it shows the frame where the timeline cursor is.

do you think it would be preferable to remember the "show background" feature when opening a title clip?

I was expecting Kdenlive to be able to support layering. Without that, it seems like a fancy version of Windows Movie Maker rather than a free version of Sony Vegas (sorry if that seems a bit harsh).

Yes, I'd love it to save 'Show Background' for the timeline. Also, yes remembering 'show background' would be a plus. Whenever an OK box is pressed, all settings on dialog/screen should be saved as it is.

The show background option has nothing to do with layering.
It only applies in the titler. If you later use the title in the timeline a composite transition needs to be used, which should be added automatically.
In the composite transition you have to choose the correct track you want it to be applied on.
Here is a tutorial which also includes compositing: http://www.youtube.com/watch?v=c4vXxRgMiLA