Simple build script for kdenlive + ffmpeg + mlt - use it!

This is a script I use for downloading sources and building kdenlive + ffmpeg + mlt and there is no reason why not to share it with others.
I can only recommend to anyone to use this script. It's suggested to have self compiled latest ffmpeg and mlt when you are going to report a bug.
IMPORTANT: The script force kdenlive to look for its libraries primarily in local ../lib subdirectory. You don't need to set LD_LIBRARY_PATH anymore.
IMPORTANT: The script will not interfere with any installed ffmpeg or mlt or kdenlive from you distribution. everything is builded into separate directory.
I suggest kdenlive_builder.sh as a name for the script.
Put the script to your source root directory and run it!
You don't need to modify PATH. After successful compilation go into destination directory, ~/build/kdenlive, into bin directory, and run ./kdenlive.

#!/bin/bash
# Script for easy Kdenlive & ffmpeg & mlt & mlt++ build utilizing LD_RUN_PATH
# All subprojects are compiled and installed to specified directory.
# This sript ensures, that kdenlive will call 
# You can verify this it by calling
# cd ~/build/kdenlive/bin && ldd ./kdenlive
# - or -
# cd ~/build/kdenlive/bin && LD_DEBUG=libs ./kdenlive 
# You can safely have multiple kdenlive/ffmpeg versions.
# Set DEST_DIR in script, otherwise ~/build/kdenlive is used by default.
#
# Espinosa
# v1.0 - 16.6.2007
#
# Usage:
#      kdenlive_builder getsources - call svn to get sources for all subprojects
#      kdenlive_builder clean      - call make clean for all subprojects
#      kdenlive_builder build      - call configure and make and make install for all subprojects
#

# Modify the destination directory if you want 
# Or you can copy it afterwars to /opt/kdenlive- or wherever you want.
# Caution: if you pick /usr here, you system kdenlive, ffmpeg  and mlt will be overwritten!
export DEST_DIR=~/build/kdenlive

case "$1" in

"getsources")
cd ffmpeg
svn checkout svn://svn.mplayerhq.hu/ffmpeg/trunk ffmpeg
cd ../mlt
svn co https://mlt.svn.sourceforge.net/svnroot/mlt/trunk/mlt mlt
cd ../mlt++
svn co https://mlt.svn.sourceforge.net/svnroot/mlt/trunk/mlt++ mlt++
cd ../kdenlive
svn co https://svn.sourceforge.net/svnroot/kdenlive/trunk/kdenlive
;;

"clean")
cd ffmpeg
make clean
cd ../mlt
make clean
cd ../mlt++
make clean
cd ../kdenlive
make clean
;;

"build")
export PATH=$DEST_DIR/bin:$PATH
export LD_RUN_PATH=../lib

cd ffmpeg &&

# from kdenlive: wiki
#./configure --prefix=$DEST_DIR --enable-gpl --enable-shared --enable-libvorbis --enable-libogg --enable-pp --enable-swscaler &&

./configure --prefix=$DEST_DIR --enable-gpl --enable-shared --enable-swscaler \
--enable-libogg --enable-pp --enable-libtheora --enable-libmp3lame \
--enable-libfaac --enable-libfaad --enable-libvorbis  --enable-liba52 \
--enable-vhook --enable-x11grab --enable-libx264 &&
make &&
make install &&

cd ../mlt &&
./configure --prefix=$DEST_DIR --enable-gpl --avformat-swscale --enable-motion-est --disable-mmx &&
make &&
make install &&


cd ../mlt++ &&
./configure --prefix=$DEST_DIR &&
make &&
make install &&


cd ../kdenlive &&
sh bootstrap &&
./configure --prefix=$DEST_DIR &&
make &&
make install
;;

*)
# print some help
echo 'Kdenlive & ffmpeg & mlt & mlt++ build script utilizing LD_RUN_PATH'
echo 'Set DEST_DIR in script, otherwise ~/build/kdenlive is used by default'
echo 'Usage: '
echo '      kdenlive_builder getsources'
echo '      kdenlive_builder clean'
echo '      kdenlive_builder build'
;;

esac

The script is very simple, it tests nothing! You are expected to have all necessary external libs already installed prior to execution of this script.
Check kdenlive requirements at

http://en.wikibooks.org/wiki/Kdenlive/G ... g_from_SVN

.

Please report problems related to script here.
Feel free to comment, improve the script or discuss configuration parameters used here.
Advices from more experienced "bashists" are welcomed.

Hi,

Big thanks for your installation script... but .. yes a 'but' exists ,o)
I get an error every time I run it:

/usr/bin/ld: cannot find -lmad
collect2: ld returned 1 exit status
make[2]: *** [../libmltsox.so] Error 1
make[2]: Leaving directory `/home/leon/scripts/cvs_kdenlive/mlt/src/modules/sox'
make[1]: *** [all] Error 1
make[1]: Leaving directory `/home/leon/scripts/cvs_kdenlive/mlt/src/modules'
make: *** [all] Error 1

Of course, I installed the libs and other stuff.
My system is Kubuntu Feisty with some Gutsy libs.

If you have an idea ?!
Cheers.

Do you have mad (MPEG Audio Decoder) library and dev package installed? What version?

http://en.wikipedia.org/wiki/MPEG_Audio_Decoder

http://www.underbit.com/products/mad/

Can you post be back full path to your libmad?
Mine is /usr/lib/libmad.so.0.2.1 and this is fine.
And also check if you have:
/usr/include/mad.h

Hmm, may be MAD is just not mentioned in requirements in wiki.

P.S.
You can omit MAD library from ffmpeg ./configure params, it is easy to locate the line in script. But I would suggest to keep it if possible.

Hi,

thanks for your reply.

You are right, some bookshops missed!!
I fixed them and I get a new error..

...
make[1]: Leaving directory `/home/leon/scripts/cvs_kdenlive/mlt++/test'
Bootstrap is now trying to create a ./configure script suitable for Kdenlive
WARNING: running bootstrap is only usefull when checking out Kdenlive from CVS.

./admin/cvs.sh: 651: --version: not found
*** AUTOCONF NOT FOUND!.
*** KDE requires autoconf 2.53 or newer
make: *** [cvs] Error 1

The autoconf version on my system is 2.61!
(automake is installed too!)

Thx for your help.

OK, can you go to kdenlive src subdirectory and call one by one these commands?

sh bootstrap
./configure --prefix=$DEST_DIR
make
make install

It's also good to call clean (kdenlive_builder clean) for all directories prior to start building.

Hmm I don't know if you have to call bootstrap if we retrieving sources from SVN and not CVS. Isn't it just an outdated information in wiki?
Mine version of autoconf is 2.60.

Try to ommit the bootstrap script and then see what happens :)

Posting reply in this thread as you requested.

espinosa_cz wrote:

??
What is you directory structure of kdenlive and its subproject? They are in separate directories aren't they?
kdenlive_builder suppose this structure:

/kdenlive
/ffmpeg
/mlt
/mlt++

That's correct, but in the ckeckout phase it's not good to cd into them, as you'll get a structure of:

/kdenlive/kdenlive
/ffmpeg/ffmpeg
/mlt/mlt
/mlt++/mlt++

That's because of how you invoke svn checkout. Additionally, if the dirs don't exist, they will be created during checkout, anyway and cd to them will fail beforehand.

Anyway, with those cd's the script didn't work, after getting rid of them all went fine, including build process.

Hi,

I've tried directly the 1st command: sh bootstrap

result:

Bootstrap is now trying to create a ./configure script suitable for Kdenlive
WARNING: running bootstrap is only usefull when checking out Kdenlive from CVS.

./admin/cvs.sh: 651: --version: not found
*** AUTOCONF NOT FOUND!.
*** KDE requires autoconf 2.53 or newer
make: *** [cvs] Error 1

After that, I tried the second one but "configure" didn't exist in the folder!

What to do after?

Cheers

olo wrote:
That's correct, but in the ckeckout phase it's not good to cd into them, as you'll get a structure of:
/kdenlive/kdenlive
/ffmpeg/ffmpeg
/mlt/mlt
/mlt++/mlt++

OK. You are right.
I will fix it.
Thank you!

leoon wrote:
result:
Bootstrap is now trying to create a ./configure script suitable for Kdenlive
WARNING: running bootstrap is only usefull when checking out Kdenlive from CVS.

./admin/cvs.sh: 651: --version: not found
*** AUTOCONF NOT FOUND!.
*** KDE requires autoconf 2.53 or newer
make: *** [cvs] Error 1

This is really annoying me: I had exactly this error a couple of months ago, but am not sure what I had to do to fix it!

Try running this:
sudo aptitude install kdelibs4-dev libqt4-dev unsermake libsdl-image1.2 libsdl-image1.2-dev libsdl1.2-dev libsamplerate0 libsamplerate0-dev libogg0 libogg-dev libvorbis0a libvorbis-dev libdv4 libdv4-dev libjack0.100.0-0 libjack0.100.0-dev sox sox-dev libxml2 libxml2-dev ladspa-sdk-dev libquicktime0 libquicktime-dev libtheora0 libtheora-dev ladspa-sdk swh-plugins libavformat0d libavformat-dev kdesvn build-essential libgtk2-dev libmad0 libmad0-dev autoconf automake1.9 dvgrab cvs subversion k3b dvdauthor

Those are all the dependencies you might need, I think that error appears if you don't have the 'unsermake' package installed, not certain about that though. :)

Tried this script, without the cd's and using the commented out ./configure from the kdenlive wiki (for ffmpeg). When running the ffmpeg generated by this script all I get is:

liam@howardmoon:~$ ~/build/kdenlive/bin/ffmpeg
FFmpeg version SVN-r9415, Copyright (c) 2000-2007 Fabrice Bellard, et al.
  configuration: --prefix=/home/liam/build/kdenlive --enable-gpl --enable-shared --enable-libvorbis --enable-libogg --enable-swscaler --enable-libmp3lame --enable-libtheora
  libavutil version: 49.4.1
  libavcodec version: 51.40.4
  libavformat version: 51.12.1
  built on Jun 24 2007 17:44:21, gcc: 4.1.2 (Ubuntu 4.1.2-0ubuntu4)
usage: ffmpeg [[infile options] -i infile]... {[outfile options] outfile}...
Hyper fast Audio and Video encoder

Main options:
/home/liam/build/kdenlive/bin/ffmpeg: symbol lookup error: /home/liam/build/kdenlive/bin/ffmpeg: undefined symbol: av_strlcpy

Any ideas what this problem is? Thank you! :)

hi,
thx jeevesbond for your reply.

Unfortunately, all package are installed in the system even unsermake .

maybe it's a bug from (k)ubuntu feisty!?

Quote:
maybe it's a bug from (k)ubuntu feisty!?

Might be... The answer is out there somewhere, it's working on my Kubuntu Feisty installation. Am pretty sure it's related to some package that's not installed (although I might be wrong). Maybe some Gnome/GTK malarkey that doesn't get installed? Again, I could be wrong.

Sorry I can't be of more assistance, keep searching: if I managed to fix it, you can too! :)

I now get this error when trying to use the ffmpeg installed by this script:
/home/liam/build/kdenlive/bin/ffmpeg: error while loading shared libraries: libavformat.so.51: cannot open shared object file: No such file or directory
Have checked and libavformat.so.51 is installed in /home/liam/build/kdenlive/lib/ as it should be, yet ffmpeg doesn't seem to find it? Is anyone else seeing this problem, or is there a way to fix it?

Kubuntu issue:
I have just recalled there is a KUbuntu specific issue with some configure scripts, it has to do something with sh versus bash shell!
In Kubuntu sh is called for somewhat reason instead of bash, but some scripts genuinely require more powerful bash shell.
There is a way how to change Kubuntu behavior, force bash usage, check Kubuntu/Ubuntu forums, ffmpeg build is not the only one affected.

AD libavcodec not found
Use LD_DEBUG=libs ./kdenlive.
This is the ultimate way how to check why and when such or another library was picked.
Check relevant post in this forum for details and examples.

AD ffmpeg binary & jeevesbond
Jeevesbond I cannot see any problem in your output sample. FFmpeg binary is CLI tool expecting some command line parameters to operate.
What you intended to do? I have need to call kdenlive I guess.

I use relative paths in my scripts. There is a unfortunate possibility of mishandling them by some distributions.
To test this, use full paths /home/.../kdenlive. The downside is that kdenlive will not be transferable to another directory.

There is a new version of the script fixing some bus and more! Check this post.

viewtopic.php?f=8&t=100

Quote:
Jeevesbond I cannot see any problem in your output sample. FFmpeg binary is CLI tool expecting some command line parameters to operate.
What you intended to do? I have need to call kdenlive I guess.

That was the error it returned, my input was not included. Anyway, that's irrelevant, the script v2.0 has mysteriously started working. Hurray! The reason for using that version of ffmpeg is that it's a lot newer than the one provided by Ubuntu, mysteriously I can't seem to get an SVN version installed to /usr to work. As this didn't work thought I'd try your script's version instead.

Now Kdenlive refuses to render at all, that's not too much bother though: can just go back to the old 0.4 version when that's required. It's probably not because of your script either. :)

myself wrote:
Now Kdenlive refuses to render at all

Scratch that, SVN Kdenlive is now working (although it didn't a couple of hours ago for no apparent reason) for me! Seems to be thanks--somehow--to that script. So what are you reading this for? Go and download the version 2 script! :)

jeevesbond wrote:
Now Kdenlive refuses to render at all, that's not too much bother though: can just go back to the old 0.4 version when that's required. It's probably not because of your script either. :)

There is (was?) an issue with kdenlive_render binary (part of kdenlive but external executable binary) not being found (or wrong version being found) when kdenlive builded to nonstandard directory, ie other than /usr. I reported it as a bug, check "kdenlive_render binary search path" it possible than with latest SVN it was fixed. The workaround is (was?) to include current directory to PATH variable before launching kdenlive:

export PATH=.:$PATH
kdenlive

Ah thanks for that, it seems to be fixed now. :)

Think the problem might have been that I wasn't in the directory when firing up kdenlive (using the terminal, from ~/). Does that make sense, or could that not have been the problem?

Hi,

this is an answer to leoon, just in case he has still problems with the script:

be sure you have automake1.6 (or 7, ...) and autotools-dev installed (do it from synaptic, for example). I had the same problem working with ubuntu-feisty and pretty sure solved installing these packages. If not let me know and I'll check the rest of packages needed.

Regards.
JM

espinosa_cz wrote:
jeevesbond wrote:
Now Kdenlive refuses to render at all, that's not too much bother though: can just go back to the old 0.4 version when that's required. It's probably not because of your script either. :)

There is (was?) an issue with kdenlive_render binary (part of kdenlive but external executable binary) not being found (or wrong version being found) when kdenlive builded to nonstandard directory, ie other than /usr. I reported it as a bug, check "kdenlive_render binary search path" it possible than with latest SVN it was fixed. The workaround is (was?) to include current directory to PATH variable before launching kdenlive:

export PATH=.:$PATH
kdenlive

Hi,

I've just compiled kdenlive from source using your script (V2) and still experiencing the problem with the renderer. So fully support your idea on fixing the path variable in the calling program.

Regards.
JM

Hi!

I'm using the following script to launch KDEnlive built with espinosa_cz's script:

#!/bin/sh

build_dir=/home/olo/misc/soft/Graphics/KDEnlive/SVN/espinosa/build
export PATH="$build_dir/bin:$PATH"
export LD_LIBRARY_PATH=$build_dir/lib
export LD_DEBUG=libs
$build_dir/bin/kdenlive 2>&1 | tee -a $build_dir/$(date +%F_%H_%M_%S)_log.txt

Because in order for the ld to locate the libraries built by the script, LD_LIBRARY_PATH environment variable is needed.

Otherwise you'll end up using the system-wide libraries anyway (or get an error if there aren't any available).

BTW, Espinosa, is there a page where one can always get the latest version of your script?

Here's my modified version that I'm using currently:

#!/bin/bash
# Script for easy Kdenlive & ffmpeg & mlt & mlt++ build utilizing LD_RUN_PATH
# All subprojects are compiled and installed to specified directory.
# This sript ensures, that kdenlive will call
# You can verify this it by calling
# cd ~/build/kdenlive/bin && ldd ./kdenlive
# - or -
# cd ~/build/kdenlive/bin && LD_DEBUG=libs ./kdenlive
# You can safely have multiple kdenlive/ffmpeg versions.
# Set DEST_DIR in script, otherwise ~/build/kdenlive is used by default.
#
# Espinosa
# v1.2olo - 28.6.2007
#
# Usage:
#      kdenlive_builder getsources - call svn to get sources for all subprojects
#      kdenlive_builder clean      - call make clean for all subprojects
#      kdenlive_builder build      - call configure and make and make install for all subprojects
#

# Modify the destination directory if you want
# Or you can copy it afterwars to /opt/kdenlive- or wherever you want.
# Caution: if you pick /usr here, you system kdenlive, ffmpeg  and mlt will be overwritten!
export DEST_DIR=~/misc/soft/Graphics/KDEnlive/SVN/espinosa/build

case "$1" in

"getsources")
#cd ffmpeg
svn checkout svn://svn.mplayerhq.hu/ffmpeg/trunk ffmpeg
#cd ../mlt
svn co https://mlt.svn.sourceforge.net/svnroot/mlt/trunk/mlt mlt
#cd ../mlt++
svn co https://mlt.svn.sourceforge.net/svnroot/mlt/trunk/mlt++ mlt++
#cd ../kdenlive
svn co https://svn.sourceforge.net/svnroot/kdenlive/trunk/kdenlive
;;

"clean")
cd ffmpeg
make clean
cd ../mlt
make clean
cd ../mlt++
make clean
cd ../kdenlive
make clean
;;

"build")
export PATH=$DEST_DIR/bin:$PATH
export LD_RUN_PATH=../lib

cd ffmpeg &&

# from kdenlive: wiki
#./configure --prefix=$DEST_DIR --enable-gpl --enable-shared --enable-libvorbis --enable-libogg --enable-pp --enable-swscaler &&

./configure --prefix=$DEST_DIR --enable-gpl --enable-shared --enable-swscaler \
--enable-libogg --enable-pp --enable-libtheora --enable-libmp3lame \
--enable-libvorbis  --enable-liba52 \
--enable-vhook --enable-x11grab --enable-debug &&
perl -pe 's/\-O3/-O1/' -i config.mak &&
make &&
make install &&

cd ../mlt &&
./configure --prefix=$DEST_DIR --enable-gpl --avformat-swscale --enable-motion-est --disable-mmx --enable-debug &&
perl -pe 's/\-O4/-O0/' -i config.mak &&
make &&
make install &&


cd ../mlt++ &&
./configure --prefix=$DEST_DIR &&
make &&
make install &&


cd ../kdenlive &&
sh bootstrap &&
./configure --prefix=$DEST_DIR --enable-debug=full &&
unsermake &&
unsermake install
;;

*)
# print some help
echo 'Kdenlive & ffmpeg & mlt & mlt++ build script utilizing LD_RUN_PATH'
echo 'Set DEST_DIR in script, otherwise ~/build/kdenlive is used by default'
echo 'Usage: '
echo '      kdenlive_builder getsources'
echo '      kdenlive_builder clean'
echo '      kdenlive_builder build'
;;

esac

Espinosa, how about creating a project "KDEnlive devel utilities" on

http://code.google.com/hosting

?

We'd have our own SVN repository for all those scripts and avoid mess with getting the latest version and submitting improvements.

Hi all ..

thx herrej01,

I've installed automake1.7 (it wasn't before)!

but I get again an error .. with script V2

make[2]: Leaving directory `/home/leon/scripts/cvs_kdenlive/mlt/src/modules/core'
make[2]: Entering directory `/home/leon/scripts/cvs_kdenlive/mlt/src/modules/qimage'
cc -Wall -fPIC -DPIC   -O4 -pipe -fomit-frame-pointer -ffast-math -DUSE_MMX -g -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -pthread -I../../   -c -o factory.o factory.c
cc -Wall -fPIC -DPIC   -O4 -pipe -fomit-frame-pointer -ffast-math -DUSE_MMX -g -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -pthread -I../../   -c -o producer_qimage.o producer_qimage.c
g++ -Wall -fPIC -DPIC   -O4 -pipe -fomit-frame-pointer -ffast-math -DUSE_MMX -g -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -pthread -I../../ -I/usr/include/qt3 -I/usr/include/kde -Wno-deprecated   -c -o qimage_wrapper.o qimage_wrapper.cpp
qimage_wrapper.cpp:31:23: error: kinstance.h: No such file or directory
qimage_wrapper.cpp:32:22: error: kimageio.h: No such file or directory
qimage_wrapper.cpp:42: error: expected initializer before ‘*’ token
qimage_wrapper.cpp: In function ‘void qimage_delete(void*)’:
qimage_wrapper.cpp:50: error: ‘instance’ was not declared in this scope
qimage_wrapper.cpp:50: error: type ‘’ argument given to ‘delete’, expected pointer
qimage_wrapper.cpp:51: error: ‘instance’ was not declared in this scope
qimage_wrapper.cpp: In function ‘void init_qimage()’:
qimage_wrapper.cpp:80: error: ‘instance’ was not declared in this scope
qimage_wrapper.cpp:81: error: expected type-specifier before ‘KInstance’
qimage_wrapper.cpp:81: error: expected `;' before ‘KInstance’
qimage_wrapper.cpp:82: error: ‘KImageIO’ has not been declared
make[2]: *** [qimage_wrapper.o] Error 1

versions..

kdenlive_builder2.sh info
FFmpeg SVN version:
Revision: 9555
Last Changed Date: 2007-07-09 08:51:54 +0100 (Mon, 09 Jul 2007)
MLT SVN version:
Revision: 1006
Last Changed Date: 2007-07-07 08:26:43 +0100 (Sat, 07 Jul 2007)
MLT++ SVN version:
Revision: 1006
Last Changed Date: 2007-06-12 07:00:29 +0100 (Tue, 12 Jun 2007)
Kdenlive SVN version:
Revision: 1636
Last Changed Date: 2007-07-07 19:13:03 +0100 (Sat, 07 Jul 2007)

--
Cheers

Looks like you miss the kdelibs-dev package. Please try to install it and tell me if it works. If it is already installed, can you tell me which distro you are using ?

regards
jb

I've opened a project on Google Code project hosting for the tools by Espinosa and me:

http://code.google.com/p/kdenlive-dev-helpers/

I welcome suggestions and bug reports :)

Hello

On feisty, i have this error, with the last version of the script on google:

"cc -Wall -fPIC -DPIC -O4 -pipe -fomit-frame-pointer -ffast-math -DUSE_MMX -g -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -pthread `libst-config --cflags` -I../../ -c -o filter_sox.o filter_sox.c
cc -shared -o ../libmltsox.so factory.o filter_sox.o -lst `libst-config --libs` -L../../framework -lmlt
/usr/bin/ld: cannot find -lmad
collect2: ld a retourné 1 code d'état d'exécution
make[2]: *** [../libmltsox.so] Erreur 1
make[2]: quittant le répertoire « /home/cvts/Desktop/kdenlive/mlt/src/modules/sox »
make[1]: *** [all] Erreur 1
make[1]: quittant le répertoire « /home/cvts/Desktop/kdenlive/mlt/src/modules »
make: *** [all] Erreur 1"

i don't know what to do ?

nyme

I think -lmad is from libmad. Do you have libmad installed?

hello

i had libmad0 installed, but not libmad0-dev ...

It's resolved

Thank you

hello

i can now launch the application but ...

- i can't save any project ... i click on save, it's like it's ok, but i haven't the file saved ...
- when i try to drag and drop a video clip to the timeline kdenlive crash very often ...

On my laptop, i install the deb svn from Trevino repository (also on a stock and fresh feisty) and all work good apart some crashs ....

nyme

Hi all,

I've install kde-dev in my system (kubuntu Feisty) and download the last script.. (thx google)
but I got a new error

...
inter-sign -O3  -c -o dsputil.o dsputil.c
dsputil.c: In function ‘dct_sad8x8_c’:
dsputil.c:3398: warning: dereferencing type-punned pointer will break strict-aliasing rules
dsputil.c: In function ‘dct_max8x8_c’:
dsputil.c:3463: warning: dereferencing type-punned pointer will break strict-aliasing rules
dsputil.c: In function ‘quant_psnr8x8_c’:
dsputil.c:3480: warning: dereferencing type-punned pointer will break strict-aliasing rules
dsputil.c:3481: warning: dereferencing type-punned pointer will break strict-aliasing rules
dsputil.c: In function ‘rd8x8_c’:
dsputil.c:3506: warning: dereferencing type-punned pointer will break strict-aliasing rules
dsputil.c: In function ‘bit8x8_c’:
dsputil.c:3584: warning: dereferencing type-punned pointer will break strict-aliasing rules
/tmp/ccEcwrdN.s: Assembler messages:
/tmp/ccEcwrdN.s:241408: Error: unknown pseudo-op: `.uleb12�'
/tmp/ccEcwrdN.s:241469: Error: bad expression
/tmp/ccEcwrdN.s:241469: Error: junk at end of line, first unrecognized character is `x'
/tmp/ccEcwrdN.s:241513: Error: junk at end of line, first unrecognized character valued 0xe
make[1]: *** [dsputil.o] Error 1
make[1]: Leaving directory `/home/leon/scripts/cvs_kdenlive/ffmpeg/libavcodec'
make: *** [lib] Error 2

hard the life ,o)

nyme wrote:
hello

- i can't save any project ... i click on save, it's like it's ok, but i haven't the file saved ...

Read the "Important" section over here:

http://code.google.com/p/kdenlive-dev-h ... veLauncher

It might be a solution for you.

leoon wrote:
...
but I got a new error

...
/tmp/ccEcwrdN.s: Assembler messages:
/tmp/ccEcwrdN.s:241408: Error: unknown pseudo-op: `.uleb12�'
/tmp/ccEcwrdN.s:241469: Error: bad expression

It's an error in FFMPEG code. Probably very temporary - try updating FFMPEG sources from SVN the next day and compiling again.

Versions from SVN are cutting edge, but serious errors and even problems in building from the source are common.

nyme wrote:
- when i try to drag and drop a video clip to the timeline kdenlive crash very often ...

Nyme, you can try locating the cause of the crash using the GNU debugger.

Read the instructions here:

http://code.google.com/p/kdenlive-dev-h ... ngKDEnlive

Thanks, I've updated the sources...

olo wrote:

It's an error in FFMPEG code. Probably very temporary - try updating FFMPEG sources from SVN the next day and compiling again.

Versions from SVN are cutting edge, but serious errors and even problems in building from the source are common.

But again, I got a (new) error..

...
g++ -Wall -fPIC -DPIC   -O4 -pipe -fomit-frame-pointer -ffast-math -DUSE_MMX -g -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -pthread -I../../ `pkg-config --cflags libquicktime`  `pkg-config --cflags libdv` -Wno-deprecated `pkg-config --cflags libquicktime`    -c -o error.o error.cc
g++ -Wall -fPIC -DPIC   -O4 -pipe -fomit-frame-pointer -ffast-math -DUSE_MMX -g -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -pthread -I../../ `pkg-config --cflags libquicktime`  `pkg-config --cflags libdv` -Wno-deprecated `pkg-config --cflags libquicktime`    -c -o filehandler.o filehandler.cc
/usr/lib/gcc/i486-linux-gnu/4.1.2/../../../../include/c++/4.1.2/bits/vector.tcc: In member function ‘void std::vector<_tp _alloc="">::_M_insert_aux(__gnu_cxx::__normal_iterator::_Tp_alloc_type::pointer, std::vector<_tp _alloc=""> >, const _Tp&) [with _Tp = char*, _Alloc = std::allocator]’:
/usr/lib/gcc/i486-linux-gnu/4.1.2/../../../../include/c++/4.1.2/bits/vector.tcc:249: internal compiler error: in var_ann, at tree-flow-inline.h:127
Please submit a full bug report,
with preprocessed source if appropriate.
See  for instructions.
For Debian GNU/Linux specific bug reporting instructions,
see .
The bug is not reproducible, so it is likely a hardware or OS problem.
make[2]: *** [filehandler.o] Error 1
make[2]: Leaving directory `/home/leon/scripts/cvs_kdenlive/mlt/src/modules/kino'
make[1]: *** [all] Error 1
make[1]: Leaving directory `/home/leon/scripts/cvs_kdenlive/mlt/src/modules'
make: *** [all] Error 1

:o(

leoon wrote:
Thanks, I've updated the sources...

...
/usr/lib/gcc/i486-linux-gnu/4.1.2/../../../../include/c++/4.1.2/bits/vector.tcc:249: internal compiler error: in var_ann, at tree-flow-inline.h:127
Please submit a full bug report,
with preprocessed source if appropriate.
See  for instructions.
For Debian GNU/Linux specific bug reporting instructions,
see .
The bug is not reproducible, so it is likely a hardware or OS problem.

Whoah, the compiler itself bombed out. That's a rare problem.

I suspect that you may have a hardware problem (most probably faulty memory) - to verify it, try building identical sources two times consecutively and see if the build crashes at different points - if it does, then you have to test your computer's memory (e.g. using memtest) and hard disks (e.g. using smartmontools) because it isn't reliable.

Just make sure that you start compiling under exactly identical circumstances - afer the SVN checkout of sources make a copy of all of them (ffmpeg, mlt, mlt++, kdenlive), and when the compilation crashes, note the errors somewhere, delete the sources, restore their copy and start compiling again.

It may also be a bug in GCC compiler itself - what distribution are you using? It might be good to report this problem to the distributors if it's indeed a bug in your distribution's version of GCC. But first test if your hardware is OK.

Hello

i re install my feisty so i recompile svn version...

First i can save and open project and i have no crash with drag and drop of clib but:
when i compile i had this error:

"rm -f ./po/hu.gmo
: -o ./po/hu.gmo /home/cvts/Desktop/kdenlive/kdenlive/po/hu.po
rm -f ./po/pt_BR.gmo
: -o ./po/pt_BR.gmo /home/cvts/Desktop/kdenlive/kdenlive/po/pt_BR.po
rm -f ./po/es.gmo
: -o ./po/es.gmo /home/cvts/Desktop/kdenlive/kdenlive/po/es.po
rm -f ./po/it.gmo
: -o ./po/it.gmo /home/cvts/Desktop/kdenlive/kdenlive/po/it.po
rm -f ./po/fr.gmo
: -o ./po/fr.gmo /home/cvts/Desktop/kdenlive/kdenlive/po/fr.po
rm -f ./po/tr.gmo
: -o ./po/tr.gmo /home/cvts/Desktop/kdenlive/kdenlive/po/tr.po
checking /home/cvts/Desktop/kdenlive/kdenlive/kdenlive/kdenliveui.rc
/usr/bin/install -c -p -m 644 ./po/ca.gmo /home/cvts/Desktop/kdenlive/share/locale/ca/LC_MESSAGES/kdenlive.mo
/usr/bin/install: ne peut évaluer `./po/ca.gmo': Aucun fichier ou répertoire de ce type
Error creating /home/cvts/Desktop/kdenlive/share/locale/ca/LC_MESSAGES/kdenlive.mo. Exit status 1.
make: *** [install] Erreur 1
"

kdenlive seem to be working ... i don't know if this error is important ?

thank

nyme

nyme wrote:
checking /home/cvts/Desktop/kdenlive/kdenlive/kdenlive/kdenliveui.rc
/usr/bin/install -c -p -m 644 ./po/ca.gmo /home/cvts/Desktop/kdenlive/share/locale/ca/LC_MESSAGES/kdenlive.mo
/usr/bin/install: ne peut évaluer `./po/ca.gmo': Aucun fichier ou répertoire de ce type
Error creating /home/cvts/Desktop/kdenlive/share/locale/ca/LC_MESSAGES/kdenlive.mo. Exit status 1.
make: *** [install] Erreur 1

kdenlive seems to be working ... i don't know if this error is important ?

It seems like an error in installation of Catalan translation. Translations are usually installed at the end, so it seems that all critical files for KDEnlive operation have already been installed correctly.

KDEnlive will work fine, unless there was something important to be installed after the translations (because installation was interrupted by this error).

I don't speak French, what does the error message say?

hello
"`./po/ca.gmo': Aucun fichier ou répertoire de ce type" he say: no file or folder exist like ./po...

But KDEnlive work very good, on my laptop and Desktop ...

Thank

Nyme