Slackware package

A few days ago I created a 0.7.4 package for slackware, my first kdenlive package I made so far.
I also posted it for linuxpackages.net, but it still did not get reviewed and as such not available yet.

The question is two-fold:
1) Is there anyone around here that is able to host it with enough bandwidth, or knows a good place to host a package like this? (8.9M) Linuxpackages seems to only accept packages up to 5MB. In a few days I'll be on vacation for a week or two, and I'll turn off the computer at home, making the package not available.
2) Anyone around who is willing to test the package out and able to provide some (constructive) feedback. I'm willing to maintain this package, but I lack time to see if there are errors made in the build process or that the bugs I encounter are known bugs and as such should not be solved in the package itself ;-)

Today I created the MLT package as well as kdenlive 0.7.5 (I have been on vacation), the scripts are generic enough that I should be able to keep up with new versions.
If people are interested, let me know; I can provide packages for you, or you get the scripts which I attached here and make your package yourself ;-)

(best to strip the .sh part, some parts of the build script do not expect to have the .sh extension.)

Suggestions for improvement are welcome as well of course.

i got some spare bandwith on a sever thats no longer being developed... welcome to put it there, my username at gmail. email it to me and i can post it there...

Splendid! If things went OK they should be in your mail now. Thanks!

http://mobit.co.za/packages/

they sitting here at the moment - tried to set up a page but just haven't had time :)

I would be extremely happy if you would maintain a package for Slackware! Please do it!

I like Kdenlive as a video editor. I first used it on Kubuntu, which automatically deals with all the dependencies. I hate Kubuntu though. Easy Kdenlive installation was one of the only nice things about that Distro. I'm back on Slackware for everything. Slackware 12.2 is nearly perfect. My laptop just goes into suspend and never needs to be rebooted. I use if for work and it's the best it has ever been for things working... except there is no video editor, at least that I've found.

Feedback on your package:
Did the package installation for MLT and Kdenlive. Got this error after trying to run Kdenlive:
kdenlive: error while loading shared libraries: libnepomuk.so.4: cannot open shared object file: No such file or directory

Again, see if you can get it submitted at http://linuxpackages.net. If you pass, you know you've probably done something well because they are quite picky ;-)

Scott

drumar, would you like to also maintain a page here on kdenlive.org in the packages section?
just say yes, and we'll grant you documentation writer privileges

Maintainer: surely I am willing to maintain this package!

As for the error you got: I think there is a dependency with the nepomuk library, which already are in -current if I'm not mistaken. Given that I expect Slack 13 to be out really soon -I will upgrade my system to a "default" Slack 13- I think it is beyond the scope of the package to include / add a package for this library. Feel free to disagree, I may yet come around and make a package for this library as well. Obviously I was not aware of the dependency anyway.

Please keep the feedback coming, I will send it for approval to them once it is up as I do know they're picky (which is good) - only thing I somewhat disagree with them is the exact script needed to make the packages, as I prefer to have a slightly different approach, having functions in my script which do the process in several steps:
- download sources if not available
- configure
- compile
- make package
- clean up

Sometimes things go wrong, and this makes it easier for me to skip a certain step, so I don't loose too much time. But that's going into details ;-) If I manage, I will try to post a script here today that should create a package to install libnepomuk from source. The computer a script like it may reside on is turned off at the moment or I could see if I had it from where I am at the moment. Hang on please!

EDIT: - I just dived a bit deeper into libnepomuk and the library is indeed in slackware-current kdelibs package, as this query shows: http://packages.slackware.it/search.php?v=current&t=2&q=libnepomuk* I am not certain (yet) if the sources for this library can be separately downloaded and compiled, and defenitely in which hell of chained dependencies I will get if I tried that. ;-)

EDIT 2: - Dived even deeper, it seems KDE4 is a requirement for kdenlive. Since this is required, you should also get the nepomuk libraries, and thus making this separately is not logical. nr required. If -for some reason- you cannot or will not upgrade to slackware-current, then I suggest waiting till Slackware 13.0 is really out. You can expect a fresh package shortly after, as I will have to upgrade my system. Currently I am running a compile of the current git of kdenlive on a very old system (Pentium 2) that is a bare Slackware-current system; if it is succesfull, I will let you know.

aye sir! :-)

filled something with some info

thanks! i converted your comment in the page itself. in the future, please "edit" the page instead of adding comments ;)

Thanks! I tried, but it was locked by you ... at least, so it said...

oh, sorry... it happens sometimes, don't know why...

I have looked at the build requirements posted on the Kdenlive site and I figured your package was based on "current". There's just too many dependencies to resolve if you are not running KDE 4.

I have one experimental system that is running slackware64-current. I will try your package on that and get back to you. All of my other systems are too important to not be on the latest stable. They *must* remain flawless and up all the time. Which is why I use Slackware ;-)

I thought Slackware 13 was a long way off. I haven't looked at the change logs in a while though. I wish you good luck with all this because I think it is the last thing I really want working on my Slackware systems. Video editing is the last step to perfection on Slackware Linux ;-)

Thanks, keep an eye open here; I resolved a few dependencies not in the least ffmpeg, which in turn has its own dependencies. I am currently building some old versions of these dependencies to build an svn release of ffmpeg. For now also using old scripts, which I will update along with updates with newer versions of the dependency source tree.

Drumar,

Saw your post on LQ and now I can't get access to your download side. "ACCESS FORBIDDEN". Will check again later.

Bob

my bad, hadn't set read-bits; fixed now.

Make sure you get both the new MLT and Kdenlive package; especially MLT has a few different flags that made the fix in the build.

Just installed both the new packages, MLT first, then Kdenlive. Exactly the same result. Same errors as before. Will try to provide a screenshot. The first error occurs immediately on trying to open Kdenlive, the second when clisking OK. Guess installation of Slack just isn't going to play nice. As previously mentioned, I did get Cinelerra installed and it seems to be pretty stable.

Bob

Pretty strange; a few things worth trying:
- Try to re-install MLT and Kdenlive by uninstalling and reinstalling;
- Before that, go to http://connie.slackware.com/~alien/slackbuilds/ and get the following packages from him (these are the packages I used as well during the build)
-- yasm
-- faac
-- faad2
-- ffmpeg

Additionally, you could try to give the output of the commandline utility:

melt yourvideo.mpg

If melt (MLT's commandline videoplayer) runs the video things are wrong in a different way, but I guess there's something wrong with MLT due to the dependencies as stated above.
For ffmpeg I needed yasm; faac and faad2 actually are compiled when building ffmpeg from Alien Bob's package, but it won't hurt to have those along. I expect things to run fine after this.

If I may guess freely: I guess "yasm" is the killer here; I bet the part for ffmpeg in MLT cannot parse something and makes MLT crash eventually. So, you can try to take the shortcut and install yasm and see if that fixes it.

Hi Drumar,

MLT certainly seems to be the problem here. I tried to play an avi file with:

bob@bob-laptop:~$ melt WhoLetTheDOgsOut.avi

and got:

sage: melt [options] [producer [name=value]* ]+
Options:
-attach filter[:arg] [name=value]* Attach a filter to the output
-attach-cut filter[:arg] [name=value]* Attach a filter to a cut
-attach-track filter[:arg] [name=value]* Attach a filter to a track
-attach-clip filter[:arg] [name=value]* Attach a filter to a producer
-audio-track | -hide-video Add an audio-only track
-blank frames Add blank silence to a track
-consumer id[:arg] [name=value]* Set the consumer (sink)
-debug Set the logging level to debug
-filter filter[:arg] [name=value]* Add a filter to the current track
-group [name=value]* Apply properties repeatedly
-help Show this message
-join clips Join multiple clips into one cut
-mix length Add a mix between the last two cuts
-mixer transition Add a transition to the mix
-null-track | -hide-track Add a hidden track
-profile name Set the processing settings
-progress Display progress along with position
-remove Remove the most recent cut
-repeat times Repeat the last cut
-query List all of the registered services
-query "consumers" | "consumer"=id List consumers or show info about one
-query "filters" | "filter"=id List filters or show info about one
-query "producers" | "producer"=id List producers or show info about one
-query "transitions" | "transition"=id List transitions, show info about one
-serialise [filename] Write the commands to a text file
-silent Do not display position/transport
-split relative-frame Split the last cut into two cuts
-swap Rearrange the last two cuts
-track Add a track
-transition id[:arg] [name=value]* Add a transition
-verbose Set the logging level to verbose
-version Show the version and copyright
-video-track | -hide-audio Add a video-only track
For more help:

I already have all of those files your listed, including yasm (also from Alien Bob's repos), so that probably isn't the issue. I have uninstalled and reinstalled both apps at least five times each. Certainly has me stumped. The only other thing I could try is to compile MLT from source so that it will compile against the libraries I have installed. That is the only thing I can think of.

On the plus side, while I haven't tried to render yet, Cinelerra is performing adequately with just a couple little niggles. It is so much more complicated than Kdenlive, that I would rather use Kdenlive for my purposes, but it isn't going to work, I'll just have to use what I have. I can use Kdenlive in Ubuntu if I need to, it is just very unstable and crashes/freezes alot.

Bob

Sad to hear it isn't going to work; At the moment it beats me towards how this can be... seems we're both on the same libraries / other software... only thing I can think of is tracing what is being required. The packages mentioned, did you have them installed from Alien Bob or from slackbuilds.org or linuxpackages.net? If either of the latter, it might be that Alien Bob uses /usr/lib for libraries whereas slackbuilds and linuxpackages use /usr/local/lib. That would mean I could / should reinstall those packages with a /usr/local prefix instead of the /usr prefix.

Just wanted to note that I am encountering the same problems as Bobnutfield. I have pretty much the same packages installed except mine have all come from slackbuilds.
And the only things in /usr/local are from aaa_base-13.0-noarch-1, brscan-0.2.4-0.i386, and motion.

Am going to try building MLT from source like
he mentions to see what happens.
_
Built and installed MLT from source.
Problems still persist for me.

All of the mlt files are in /usr/share and not /usr/local. Interesting though that the result of:

ldd `which mlt`

is this:

which: no mlt in (/usr/local/bin:/usr/bin:/bin:/usr/games:/usr/lib/java/bin:/usr/lib/kde4/libexec:/usr/lib/qt/bin:/usr/share/texmf/bin:.)
ldd: missing file arguments

The result of:

whereis mlt

is:

mlt: /usr/lib/mlt /usr/include/mlt /usr/share/mlt

Strange results. Never have encountered this before.

Bob

I'm in...
I tried to make sure everything was getting installed
in the correct place...ie. /usr vs /usr/local and
/usr/lib vs /usr/local/lib...

My stuff was in /usr and /usr/lib...

So I:
ln -sf /usr/lib/mlt /usr/local/lib/mlt

And I'm In.
And i was able to capture video (with audio)
from my old philips webcam using the pwc driver...
only kdenlive gave an error about the clip
being invalid and it being removed from the project.

P.S. I could have sworn, I tried the symlink earlier
and it did not work at the time. Anyway, it worked
this time and I can get in and see how far I get.

Well, I physically checked each library in /usr /usr/local just to be sure. The, just in case, I also did the symlink. Same results, no change. Glad that got it going for you, though. Something about my installtion of Slack current is just not going to work with Kdenlive.

Bob

EDIT: I was mistaken. I also had them in /usr/share AND /usr/local/mlt/lib, probably just as you have done, but the symlink did not work for me. I get the same results.

A few things I also had to do when I compiled MLT:
I had to make sure I also built ffmpeg with the swscale option. And I used the following when configuring MLT:
./configure --avformat-swscale --enable-gpl --prefix=/usr --libdir=/usr/lib

I also installed frei0r.
HTH
Cheers

I used these options since everything else appeared to be going to /usr and /usr/lib...

And the only settings I did not have control over...
was where the kdenlive package was expecting the libs to be
(thus the symlink).

Thank you, that's kind of you to provide that info. But to tell you the truth, I have been wrestling with this for almost a week now, and I am to the point that I don't really want to bother trying to recompile mlt. I used Drumars Slack packages and I have not compiled either kdenlive or mlt, just installed the packages. But I do have Cinelerra working pretty well (even though it is WAY more complicated!) and I have learned enough about it to do as much as I can in Kdenlive (and a massive amount more..) I have not tried rendering yet, but the basic composition is fairly easy.

I DO have kdenlive working on Ubuntu, but it crashes and freezes a lot (though it does autosave the work). Just gets too frustrating. I also have the 0.7.3 version running on another desktop, and it is considerably more stable, but weak in features (almost NO transitions or effects to speak of.)

Any, once I have rested my brain a little, I might give this another shot.

Bob

iirc linuxpackages and probably others as well "demand" things to be built in /usr/local (which is logical, given the FHS) but probably since Alien Bob is part of the Slackware team things are built in /usr (?) just speculating; I tend to find his packages to be of a very good quality, which is why I always use those. My bet is that my next release will come along with other required packages, as soon as they have been identified properly.

Given the output of ldd the problem does not seem to be a shared lib issue, but rather something along the lines of a called binary, which is harder to identify... just hoping "melt -verbose" can shed some light... will dive deeper, slackers will get a proper package!

Thanks aomega for the input, really much appreciated. As it is late here now, I'm not sharp enough to see how to alter things to make things work out of the box (which is what I aim for) I'll re-read and have a thought about other flags to give the compile procedure to get things work out of the box.

The problem -afaics- is people using different packages for dependencies, resulting in upredictable results, unless I "include" those packages / use static linking, but that's pretty much against the whole idea of being able to use shared libs... As a workaround I can write an install script that would make the symlinks, but even that I consider a bit hacking-like.

Bob: as for stability: I doubt I can do much against that; kdenlive is still not at a 1.0 release, so instability is -much as it hurts me to say- a thing to take in stride at this point in time. However, I see this project as something very promising, so I will go on and keep on building and trying. But I kinda need input to see how to get a proper package that everybody will enjoy.

qimage-libdir is supposed to reside in /usr/lib
qimage-includedir in /usr/include/qt4
I did compile it with --avformat-swscale, the --avformat-shared=/usr

mlt is not the binary, so it should never be in your path ;-) melt is, so a which melt should give you more info; It should reside in /usr/bin; the libraries in /usr/lib and /usr/lib/mlt (due to a /usr prefix in the compile)

Some interesting output may come from stracing kdenlive like this:
on a shell prompt: strace -f -F -efile kdenlive >kdenlive.strace 2>&1

Then check the file for some "strange" ENOENT, you will probably get many, but this will give insight on what files kdenlive wants to open and -most important- fails to open and where they are expected. The file may become rather large, could you send a message to me with this file? In the mean time, I will build a new fresh slack machine and try this as well; then I will compare the output and see where the differences occur, which hopefully will shed light where things are going wrong.

thanks for the strace tip...
it helped me get the "adding of clips" working...
(it was rejecting everything I tried to add).

looking through the strace...
I noticed that it was trying to load the producers
from /usr/local/share/mlt and mine are in /usr/share/mlt.

so I created another symlink like so:
ln -sf /usr/share/mlt/ /usr/local/share/mlt

and I can now add clips.
(but the ones kdenlive captured are playing
faster then usual-mplayer plays them fine).

slowly but surely, I'm getting somewhere...

Figured out the problem with strace as well, now that I'm back on my pc. This led me to check out the melt binary, and it appears the --prefix path is hardcoded into melt, making it search in my build directories, which -obviously- do not exist on your systems, making me believe it actually worked;

I'm currently rebuilding MLT to fix this issue; should've thought of it myself, soon to come mlt-0.4.4-3-i686_MDG.tgz and hope this fixes it; also building an even cleaner slackware-current system to test out the packages before release, not a bad idea ;-)

Rebuilt MLT and tested it succesfully, up to starting kdenlive; Crashes afterwards have not been tested yet, but I think those are more likely to be related to the project. Please feel free to test this new package out and comment on it.

I'm getting access forbidden on the new MLT package.

The new MLT package appears to have worked for me.
Thanks.

Drumar,

Hallalujah!! Your new MLT package fixed it. I can now get into Kdenlive. I have tested a couple of clips and it seems to be working OK. Odd, though, in the Jaunty version of 0.7.5 I have about two dozen transitions available. In this one for Slack, there are only four. Can I get the others somewhere separately, or is this version for Slack available with only these.

Many thanks for your hard work on this. It was driving me crazy...I would be interested to know what you changed to get it solved. I would be a good learning experience.

Bob

Great to hear from both of you the last remaining problem to get things running was in MLT, which I fixed by setting --prefix to /usr; I had that set to my package installdir. Strace helped me analyze it, and this ultimately fixed it. I had expected the profile path set to something in a config file, not the binary itself.

Also, your report towards the transitions; I will look into this, but I think the point here is with ffmpeg. It can be built with several codecs etc... I will see which transitions I have available when I get back from work.

I'm showing 44 items in my "effect list".

And something I had not noticed yesterday:
I do appear to have lost some entries in the list.
For example, I have frei0r installed and an effect
named "B" used to be listed and no longer is.

But I noticed this after I removed frei0r
and reinstalled it using:
./configure --prefix=/usr --libdir=/usr/lib

I did this just to make sure all the programs
were using the same prefix and libdir.

So I'm not sure if the missing effects are due
to my rebuilding of frei0r or the installation
of the new MLT package.

Just in case, I again removed frei0r and
reinstalled it again as I originally did
without the prefix and libdir option
where /usr/local/lib/frei0r-1/B.so exists
instead or /usr/lib/frei0r-1/B.so.

Still no "B" effect listed.

Note: going back to installing MLT from source...
kdenlive detects the additional effects (now up to 75)
including the "B" effect.

I believe it is the frerOr package that I am missing. Where can you download that from?

Thanks

Bob

You can get frei0r from here: http://www.piksel.org/frei0r
but I was not able to get kdenlive to list the plugins
using the MLT package (I had to build MLT from source).

Indeed, I used the frei0r that is "shipped" with MLT, which seems to be a bit buggy. Could try to include it as a separate package and see if that expands the list of plugins etc.

comment removed:
the message I commented on has disappeared.
you can ignore/remove this post.
thanks

there's no frei0r shipped with mlt, it's just a module. you need to install frei0r-plugins if you want the effects

Been off this page for a while, massive layoff at work. I made it, but I haven't had much time for recreation in the last couple of weeks.

I went ahead and updated my Slackware system to current. I'm up to about 2 or 3 weeks ago now. I will likely try slackpkg when I have time as I did this upgrade manually the way I always do when I do a regular upgrade. I have never tried slackpkg so that should be new and fun!

Tried the 2 packages, mlt and kdenlive. Didn't work. I do not have time to try adding packages from http://connie.slackware.com/~alien/ right now, but I will give it another try when I have time. I'll do one at a time to see what's really needed.

I have to say, I am so happy to see everyone working so hard to get this working. I was afraid that my neglect might mean there wouldn't be any interest in this. Others have really stepped up. Thanks to all of you.

scott

I can't even run kdenlive. I did reintalls of packages and I installed the packages recommended from AlienBob's site. I'm on Slackware64-current. Here's the error and I can't make any sense of it:

bash: /usr/bin/kdenlive: No such file or directory

The file is there. I can open the binary with vi, it's garbage of course, but it's there. I have also run ./kdenlive from /usr/bin and run it as /usr/bin/kdenlive. Same result.

I've never seen this. I have proper permissions, it's executable, everything. I don't see it. It is either something with the file system, which appears to be fine or some other unknown issue. I'm using the system to type this, among many other things. I'm totally baffled at this one. Anyone have any thoughts? Am I a dunderhead, missing something obvious?

Edit:
Those package installs hosed parts of KDE. I had to reinstall KDE from the Slackware packages. I did not investigate what was damaged or what else could be affected but my KDE install is okay now. I will work on this more later because I don't know which packages did the damage at this point.

xzhayon,

I'm a little confused by your statement.

I take it to mean:
If I want the effects, the frei0r plugins
have to be installed.

It should not matter which MLT package I install
(the one available here or the one I built from source).

But in my case, kdenlive was only listing the
frei0r plugins when I install MLT from source.

The frei0r plugins are not available in kdenline
when I install the MLT package available here.

I'm not sure why.
Any ideas?

Well, I cheated my way through it. I created mlt, ffmpeg, kdenlive slackware64-current packages with slacktrack. I did the package generation with all default compiler settings on "make install." I didn't have the guts to use AlienBob's packages because I don't have the time to fix the system right now.

I did the install with my own packages. Things seem fine except for the problem Bob had. It was the exact same problem as the screen shots he posted.

Then I tried Drumar's mlt package, didn't work at all. Then I also tried Drumar's kdenlive package. Didn't work. I guess I could try using Drumar's mlt package and then create a fresh build and package for kdenlive. See if that goes since everyone seems to be having better luck with mlt now.

I guess I'm up to about where everyone else was few days ago. Is anyone else running 64 bit? I wish mlt would behave. I miss not having a system with kdenlive running on it.

Edit:
My own build of kdenlive failed with Drumar's mlt package. I'm going to go back to what I was doing. I'll report back any progress.

Quote:
"Those package installs hosed parts of KDE. I had to reinstall KDE from the Slackware packages. I did not investigate what was damaged or what else could be affected but my KDE
install is okay now. I will work on this more later because I don't know which packages did the damage at this point."

This is strange; no part of KDE should even remotely have been able to get removed or otherwise damaged; I will look into this as I think this is a serious problem.

- you can also try to extract the archive in a separate directory (eg mkdir -p /tmp/kdenlive-test ; cd /tmp/kdenlive-test ; tar zxvf
) and see what could have been damaged; or you can check the script I used for creation of the package; at least when compiling you should see what may be missing / wrong.

@aomega, @drumar

apart from the frei0r plugins, which are obviously needed, mlt must be compiled with --enable-frei0r. but, even if you enable that switch (which is the default, by the way), `configure` will check for the availability of /usr/(local/)include/frei0r.h, which comes with frei0r plugins (at least on my system): if it's not there, the mlt frei0r module can't be built, and then frei0r plugins won't be used by mlt (and kdenlive)

now, the package has probably been built when frei0r header was not installed, OR --disable-frei0r was used (i don't think so). instead, when you build from source (and you have frei0r plugins installed, you said it), it works

so: DRUMAR, please, rebuild your package with frei0r plugins installed. note that it is only a build dependency: you can build mlt with the frei0r module and then uninstall the plugins (and the header) in complete safety, so that you can ship mlt with the frei0r module without adding a runtime dependency on frei0r plugins

and... i think i've repeted the word "frei0r" 50-65 times!

I'll do so and add a package for it so that ppl can use the same fre0r; Good thing that rain is incoming tonight, so I won't be enjoying the sun again ;-)

Pages