Slackware package

A few days ago I created a 0.7.4 package for slackware, my first kdenlive package I made so far.
I also posted it for linuxpackages.net, but it still did not get reviewed and as such not available yet.

The question is two-fold:
1) Is there anyone around here that is able to host it with enough bandwidth, or knows a good place to host a package like this? (8.9M) Linuxpackages seems to only accept packages up to 5MB. In a few days I'll be on vacation for a week or two, and I'll turn off the computer at home, making the package not available.
2) Anyone around who is willing to test the package out and able to provide some (constructive) feedback. I'm willing to maintain this package, but I lack time to see if there are errors made in the build process or that the bugs I encounter are known bugs and as such should not be solved in the package itself ;-)

Quote:
This is strange; no part of KDE should even remotely have been able to get removed or otherwise damaged; I will look into this as I think this is a serious problem.

I have done more testing with your packages, installing and uninstalling. Your packages are okay. The issue is with the other packages from AlienBob. It may not be his fault though. Let me explain. In Slamd64, it had libraries to run most 32 bit binaries. Perhaps his libraries were for a 32 bit system. I'm running 64 bit. I assumed Slackware64 would be he same and perhaps it is, but I don't know. Even so, installing those packages may have hosed some 64 bit binaries.

Drumar, do not worry about your packages. I think they are fine. I guess that wasn't clear in my previous post and I'm sorry if I ended up wasting some of your time!

I also tried doing builds and creating packages with slacktrack that used the configuration settings from here:
http://www.kdenlive.org/user-manual/downloading-and-installing-kdenlive/...
and here:
http://www.kdenlive.org/user-manual/downloading-and-installing-kdenlive/...

Which means I compiled mlt with:
./configure --prefix=/usr --enable-gpl --qimage-libdir=/usr/lib/ --qimage-includedir=/usr/include/qt4 --avformat-swscale --disable-mmx
and kdenlive with:
cmake .. -DCMAKE_INSTALL_PREFIX=/usr

I still have the missing SDL module problem from Bob Nutfield's screen shot's posted earlier in this forum. I'm looking forward to trying xzhayon's other suggestion about building mlt with the frei0r plugins installed. I will try this too.

I did not run ldconfig as suggested here on any of this:
http://www.kdenlive.org/forum/always-famous-problem-sdl-module-not-found...

I haven't gotten as far as the rest of you, but it seems those other packages from Alien Bob's site are not necessary? I'm simply following the "install from source" instructions from this site:
http://www.kdenlive.org/user-manual/downloading-and-installing-kdenlive/...

I'll let you know how the mlt package goes with the frei0r plugins installed.

Good to hear the problem is not from my packages ;-)
Right now kdenlive is being built with a fresh build of MLT with a fresh new build of frei0r. Those 3 packages will be available soon, but be warned: I have not had the time to test them out even remotely... I'll share them anyway, hoping this may give some boost somewhere somehow.

The flags you use for MLT are the same as I use; there may be something with slack64, and I can only say that I will try to build packages for those as soon as I have my system upgraded to 64-bit slack, right now it's not really an option for me due to lack of time to troubleshoot when things go wrong, holding other things back.

If you have VirtualBox or another Virtual Machine, you could try to see if the problem persists in 32-bit slack, if so it's clear the issue is not especially in 64-bit, and if not we can pinpoint it to 64-bit slack ;-)

Edit - Update: uploaded the packages; will test them out myself tomorrow!

excuse me... when did slackware become so popular? :)

Quote:
excuse me... when did slackware become so popular? :)

No one told me it wasn't. I thought I was still cool like when I first installed it in 1995 :-)

Seriously, I've tried many other distros and I always end up cursing myself for wasting my time with them. Then I swear off everything else... again. There is nothing as fast or as stable as Slackware. Hands down, nothing comes close. And I use it for everything. I even wiped my work computer after the Windows issued Dell ate itself. Been almost a year with *no* problems.

Video editing is the last frontier. Then I can honestly say there is nothing wanting in Slackware.

if (aComputer instanceof Slackware) {
continue;
} else {
Computer aComputer = new Slackware(kill.everything.else());
}

And, yeah, I still use fdisk.

Scott

Drumar, just wanted to let you know that the three new packages are working here. Great job. Thanks & Cheers

64 bit Slackware is a no go with the new packages. I am attempting to rebuild mlt and kdenlive packages for 64 bit with Drumar's frei0r package installed. I Don't know if I need to have a 64 bit version installed for that to work. I'll let you know how it goes.

scott

Edit:
Okay. Didn't work. Same result with missing SDL again when I try and start kdenlive. I'll have to try compiling the frei0r package myself and see where I end up.

Another update:
Compiling the frei0r and making a 64 bit Slackware package didn't help. Same issue. SDL module missing from mlt. I will try to trouble shoot why mlt is misbehaving.

Question: I got the tar.gz of mlt do I need to get the latest version from git to move past the missing SDL module error?

scott

I built MLT from git, but I think you can use the stable version (just) as well. Most important fix for me -I think- was using "configure --prefix=/usr" and do the install with "make DESTDIR=/mypackagedir install", prior to that I tried to install with --prefix=/mypackagedir.

I made your change, meaning I downloaded mlt from git and rebuilt the package as opposed to using the stable release.

Good news! I am now past the SDL issue. Kdenlive crashed later. I will look more into what is happening here. Making progress ;-)

Maybe we'll have 64 bit versions available soon.

scott

Great news, great job!
Just to make sure: if things seem to be broken, check out if it's a known bug, so that it may get fixed on the right spot.

If you have the packages ready, you can mail them to me and I can add them to the repository ;-) Also I'm working on another server at the moment based on Drupal; lack of time makes this slow progress, but I could host the packages there on a 2gb connection, fast enough if you ask me :-) Once that is somewhat ready, I could setup something to host stuff.

I'm pretty time constrained too. It is the last week for many people at my job. We are scrambling to try and get things done.

I also have a Drupal server that I simply haven't had time to finish setting up. Only mine has been sitting there for a couple of years! It runs Slackware and is colocated at a high speed data center. Actually everything is working great, I just haven't had time to set up all the content. I need to study Drupal more or just go back to writing my html by hand. I like Drupal, but certain things are easier in html.

I have a gmail account and my username is pilbender. Ping me when you have time. I think we need to be consistent. I can build the 64 bit version while you build the 32 bit version, but I still think the packages should be consistent between the architectures. I have a feeling there will be a lot of interest in this. I know I've been wishing for it for years.

scott smith

poked you on gmail ;-)

Also the breaking news: Slackware 13 is out, I downloaded it and burned the 64bit dvd; The coming days I'll probably be busy reinstalling and getting all those nice things working again. After that I have to build a new 64bit virtual machine and I can also go about and compile your packages when there are updates to be made.

Expect new packages really soon! -current support will be removed as soon as the new packages are available. Stay tuned!

I bet post #63 is spam ;-)

Don't feel bad, I just got spam blocked too.

Blocked again. I went ahead and emailed you the latest Drumar.

It's been quiet for a while, but finally I am proud to announce to you the 13.0 32-bit packages. Since I wanted to solve issues compiling these packages 1st, I am now going to make a 64-bit virtual machine and repeat the steps to create the packages.

Changes:
- MLT is now built from GIT due to a library incompatibility issue that prevented it from building.

- The packages have not been tested yet, since I want to keep the 32-bit environment as clean as possible. Testing results are really appreciated.

Same stuff:
- You still will have to install ffmpeg; I don't provide packages for that, there are others who did a tremendous job on it, most notably Alien Bob, check his repository I linked earlier.

Excellent! I have a 32 bit machine I will be upgrading from Slackware 12.2 shortly. I will test the new packages on that machine at that time.

Scott

Today I created and uploaded new packages for Kdenlive 0.7.6 and MLT 0.4.6
Please try them out and report issues you may have with them.

Created both 32-bit and 64-bit packages, yay :-)

Hi

I cannot download the mlt and kdenlive packages for Slackware. I get "403 Forbidden".

My apologies, it should be fixed now.

hi all,

Drumar, I have created an slackware64 package too here http://cfdev.org/slackbuilds/
but at first KdenLive display an red cross "avFormat FFmpeg" ? ffmpeg is already install...maybe my ffmpeg configuration isn't correct ?

and if I continue In the second windows FFmpeg to webcam is correctly recognizes, but in Kdenlive when I add an new clip "*.mpg" tell me "*.mpg video is missing or not supported"...

thanks

---Edit
It's ok, my slackware configuration is bad, now with slackware64 13.0, my SB run perfectly in this order ffmpeg,mlt,Kdenlive

sorry Bye

To keep you folks updated; I will create a kdenlive-0.7.7 package after this weekend; unfortunately my agenda is quite full around this time of the year, hence the -hopefully- short wait. I will make an update post over here to keep you informed.

First of all my apologies for the long wait. But, I guess it was worth it... go grab your kdenlive 0.7.7 and leave your comments and suggestions here...

Unfortunately I have not been able to do work out a good solution for issues that arise when you install against later releases of the dependencies yet (as mentioned earlier in this thread) However, if you stick to the stuff provided, all should be nice.

Better await a build 2, it seems the file /usr/share/applications/kde4/kdenlive.desktop (and maybe others as well) is corrupt, causing much functionality loss in kde4. You have been warned!

After a reboot this issue seemed to have resolved itself; what exactly has gone wrong in the 1st place I have no clue... but a reboot fixed it all... the package is safe to install; rendered some projects for testing and this seems to go fine. So far no issues encountered here... except the kde issue that was solved with a reboot.

My suggestion is that this had to do with some files that were replaced by root, while having been logged in as a normal user; requiring a full kde restart... but so far it's only speculating...

... and a short wait later we have: kdenlive-0.7.7.1; check the download -> packages -> slackware section

Hi all !

Also, you can compile directly the source code with my SlackBuilds :

http://www.kdenlive.org/forum/kdenlive-0771-slackware-130-slackbuild

bye.

Installing the 13.0 x86_64 package in an xfce environment (kde libs only), all of the xfce desktop and menu icons disappeared as soon as kdenlive was launched. On reboot, all xfce icons are back as usual.

kdenlive works as expected.

kdelibs-4.3.4-x86_64-1
xfce-4.6.1-x86_64-5
kdenlive-0.7.7.1-1-x86_64_MDG
frei0r-20100316-1-x86_64_MDG
mlt-0.5.2-1-x86_64_MDG

Cheers,

update: control button icons in the clip, project and record monitors are invisible, I assume because of missing kde components. Anyone know which icon group these might be?

Usually the default Oxygen theme I believe

Pages