Slackware64 13.1 Avformat module

I have the same issue of this Thread: http://www.kdenlive.org/forum/slackware-13-64-bit-install-problem .
My kdenlive open but I can not import any video file because kdenlive can not decode it.
I installed all packages from the official site.

There are a few possible reasons for this:
- One would be that you do not have installed ffmpeg, as avformat is part of the ffmpeg package.
- Another reason can be that you installed a different version of ffmpeg than the one I used. Normally such things are not an issue, but due to static linking it does become an issue. There are two ways around this, I won't dare to say which will take less time:

1) recompile ffmpeg with the right versions. On the site where you can download the package, there is an ffmpeg build script. It should build all the right versions, which is why I stored it there, to prevent issues with upgrades... *cough* :-)
2) recompile kdenlive. It does sound scary, but it's not that bad. In /usr/doc/kdenlive-0.7.8 is the build script. These are the steps you'll have to take:
a) copy it over to a logical location (e.g. $HOME/slackbuilds/kdenlive )
b) chmod 755 kdenlive.SlackBuild
c) sudo ./kdenlive.SlackBuild

It should run fine, and provide you with a fresh package.

As a side note: I think I have not put the slack-desc file as a separate file in the package. You can extract it from your txz package. The file is not very important, rather practical as it gives a description of the package's contents. If things fail to run or you encounter other issues, let me know!

I have used the right version of ffmpeg.slackbuild. Mr. Drumar I think the script have instructions for download automatically the newer version of x264 and maybe other libraries. I will try to recompile kdenlive but I do not believe it is the problem.
Mr. Drumar may you post the right versions of each needed library?

Thanks

No results, the same problem after recompiling.

Another thing, when I run it as root it crashes:
bash-4.1# kdenlive
Qt: Session management error: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
kdenlive(7012): Session bus not found

KCrash: Application 'kdenlive' crashing...
sock_file=/root/.kde/socket-SIUG/kdeinit4__0
Warning: connect() failed: : No such file or directory
KCrash cannot reach kdeinit, launching directly.
Qt: Session management error: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
drkonqi(7014): Session bus not found

But with normal user it works.

About the root-thing I don't really know what is causing it; probably udev rules and root confuses the system somewhat...

As for the avformat thing, I'm not sure what is really going wrong, apart from you reporting kdenlive won't import any video.

Can you give me the output of these commands:
ldd `which ffmpeg`
ffmpeg --version

Both commands should give quite some output, and might give an insight on what's missing...

bash-4.1# ldd `which ffmpeg`
which: no ffmpeg in (/usr/local/sbin:/usr/local/bin:/sbin:/usr/sbin:/bin:/usr/bin)
ldd: missing file arguments
Try `ldd --help' for more information.
(using aliens bob script hosted by Drumar)
bash-4.1# ffmpeg --version
bash: ffmpeg: command not found

It is installed.
And I tried to download and install ffmpeg from other sources and have the same problem on kdenlive but the --version shows info
about.

Likely reason: the build for ffmpeg failed, but still created package file, but not with the executables in it, as they failed to build. There's likely something missing, however, we need to figure out now what it is that is missing.

The creation of the ffmpeg package should've left a log behind; either post it here, or find the errormessages that give a clue why the build failed.

After various tries I decided to compile ffmpeg myself. I have no error on compilation and now all is working, and I tested avformat direct on ffmpeg and it works but kdenlive do not recognizes the presençe of liavformat I tried to make a simbolic link:
ln -s libavutil.so libavutil.so.49
but no sucess.
In the slackbuild I have no error log only some isntalation logs and 1 error about missing reference to x264.
I run the slackbuild script again and made a logfile of the process using | tee (I can't find a error log).

PS: the attachment is a bz2 file remove the .txt extension.

Now that you recompiled ffmpeg (which is what had to be compiled anyway) you might have to recompile kdenlive to link to the right libraries. The steps to compile kdenlive are described above. Kdenlive will then run and use the libraries that were compiled into ffmpeg. It's not only libavutil but more libraries... I have good hopes for you that a recompile of kdenlive will work for you and make it do the things it is supposed to do.

Three's a little it of explanation required here, in case you wonder why ffmpeg was not delivered as a package itself. The reason is that you will want a few codecs that are are not allowed to be distributed in binary form due to patents or other reasons of licensing. But they're free and can be downloaded (which is what the buildscript for ffmpeg does). The script does make it a nice package so thta you can upgrade it nicely, replacing all the newer files. That is why I could not distribute the package I made for ffmpeg. I'm sorry for that. But Kdenlive heavily depends on ffmpeg, so that a different build of ffmpeg from the build I used will not work (entirely). Now that ffmpeg is actually many packages in one due to interlinked stuff, I hope you understand that a slightly newer version of a part of ffmpeg will break the build. An upgrade of ffmpeg requires a rebuild of Kdenlive, which is why I keep ffmpeg stuff as is when I distributed Kdenlive.

First compile ffmpeg (I used 6.0.1 version with no problem):
cd to directory then:
./configure --enable-libopenjpeg --enable-librtmp --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxvid --enable-zlib --enable-libdc1394 --enable-libdirac --enable-libfaac --enable-libfaad --enable-libfaadbin --enable-libgsm --enable-libmp3lame --enable-gpl --enable-nonfree --enable-shared

If you need any lib look at configure.err and install the needed libs according with this file.

now make and install ffmpeg:
make
make install

ffmpeg isntalled now install mlt (I used the last version )

cd to the mlt dir and:
./configure --enable-gpl --libdir=/usr/lib64/ --mandir=/usr/share/man/ --datadir=/usr/share/ --prefix=/usr/ --avformat-ldextra="-lmp3lame -lfaad -lfaac -lxvidcore -lx264 -lvorbis -ltheora -lvorbisenc -logg -lbz2"

after make and isntall:
make
make install

And compile kdenlive and restart your computer.
This process takes about 30min on a old PC.

Thankyou so much Mr. Drumar.

seems like you have the libraries for ffmpeg installed as shared libraries (which is great), which probably caused the ffmpeg SlackBuild script to fail compiling, as it builds all static. At a later stage I will provide the packages like that as well, so things should work (much) better. Just haven't had the time to split up the parts of ffmpeg into different packages yet.