SOLVED: kdenlive rendering crashed

for some reason my post is triggering a spam filter and i cant submit it but here is the original thread and my fix is below.
http://www.kdenlive.org/forum/any-rendering-crashes

fixed this by downgrading as well. changed from the kdenlive-svn to kdenlive-release ppa and did an apt-get update
only downgraded mlt from 0.7.7 to 0.7.6 and rendering started working again

Forums:

netpet's picture

So you are running kdenlive 8.3 with 0.7.6 or is just the melt 0.7.7 you downgraded ?

I am not really sure how to just downgrade just the melt ;-)

Case: I render with this characteristics and DO NOT RENDER (this is the script):

#! /bin/sh
SOURCE="/home/navruc/kdenlive/scripts/cezar.sh.mlt"
TARGET="file:///home/navruc/kdenlive/cezar.mp4"
RENDERER="/usr/bin/kdenlive_render"
MELT="/usr/bin/melt"
PARAMETERS="-pid:4792 in=0 out=4515 $MELT dv_pal avformat - $SOURCE $TARGET f=mp4 hq=1 acodec=aac ab=384k ar=48000 pix_fmt=yuv420p vcodec=libx264 minrate=0 vb=6000k g=250 bf=3 b_strategy=1 subcmp=2 cmp=2 coder=1 flags=+loop flags2=dct8x8 qmax=51 subq=7 qmin=10 qcomp=0.6 qdiff=4 trellis=1 aspect=@4/3 pass=2 progressive=1 threads=4 real_time=-1"
$RENDERER $PARAMETERS

IT CRASH ........................
If I change "acodec=aac" to "acodec=libfaac", change manualy script, it works very good.
In this case I use "ab=128k" works. If you use "ab=384k" do not work!

WHY??!!!!!!!!!!

lx / # ffmpeg -codecs|grep aac
libavutil 51. 7. 0 / 51. 7. 0
libavcodec 53. 6. 0 / 53. 6. 0
libavformat 53. 3. 0 / 53. 3. 0
libavdevice 53. 0. 0 / 53. 0. 0
libavfilter 2. 4. 0 / 2. 4. 0
libswscale 2. 0. 0 / 2. 0. 0
libpostproc 52. 0. 0 / 52. 0. 0
DEA aac Advanced Audio Coding
D A aac_latm AAC LATM (Advanced Audio Codec LATM syntax)
EA libfaac libfaac AAC (Advanced Audio Codec)
EA libvo_aacenc Android VisualOn AAC
lx / #

Can you fix that?
Best regards,
Cezar Navruc

I have to change manualy every time the script "acodec=aac" to "acodec=libfaac".
This work good every case "ab=128k" & "ab=384k".

Best regards,
Cezar

I use Mint 12, 32 bit on laptop.
Mint 12 KDE 64 bit on desktop.

Here's how it worked for me.

first I removed my existing ppa:sunab entries from the sources.

next, using synaptic, I removed kdenlive and kdenlive-data, then melt, AND the associated mlt librarys. Three of them. If you just remove melt and not the libs it won't get fixed.

from the command line I used this command:

sudo add-apt-repository ppa:sunab/kdenlive-release && sudo apt-get update && sudo apt-get install kdenlive.

when it comes back, melt and the librarys are downgraded to 0.7.6 and everything works, for me.

Hope this helps.

RSV869

netpet's picture

When I tried the kdenlive 8.3 I was so happy with the stabilize features but the problem doing rendering foced me to downgrade to the 0.8.2.1 from the
http://ppa.launchpad.net/sunab/kdenlive-release/ubuntu so I was able to do both the editing and the final rendering out again.

Sorry if I am confused about the solution, because I now have a fine working 0.8.2.1 just missing the stabilize funktion for some clips and
it looked like it all was working fine here except for my important problem rendering out with the http://ppa.launchpad.net/sunab/kdenlive-svn/ubuntu

I just need the stabilize features but I am not sure if the rendering problem with the 8.3 related to the mlt and if this is now solved ?

Has this been fixed? I am using mlt 0.7.8 from Debian-multimedia.org and I can't render. It stops halfway through the two pass rendering. The resulting video is viewable, but the render stops before the second pass begins. If I choose 1 pass rendering, it stops at the end of the file.

I don't seem to have any downgrade options at the moment.