[SOLVED] Kdenlive svn crashing after startup-wizard

Recently I compiled x264, mlt, mlt++, ffmpeg and kdenlive from SVN. The SVN versions were all from 09/25/2008 and compilation went successfully. I'm using QT 4.4.2.

When I start kdenlive, it opens a wizard for configuring my default project. After the second or third screen, kdenlive segfaults. I dug around a bit and wasn't able to find any complaints of a similar crash on google (I did notice other startup-crash complaints, but they were different). I'm not at my machine now, but I can provide either an strace or a backtrace for kdenlive if this isn't a known issue and that would be helpful.

I did try to compile various older revs from svn for kdenlive and I got the same result. I also tried recompiling mlt and ensuring that it was finding the appropriate versions of the libraries that I had compiled. I'm compiling mlt without the frei0r module.

Here are the last terminal messages I get:

------------
Object::connect: No such signal KActionCollection::actionHovered(QAction*)
Object::connect: (sender name: 'KXMLGUIClient-KActionCollection')
Object::connect: (receiver name: 'MainWindow#1')
kdenlive(16692) MainWindow::MainWindow: KXMLGUIFactory(0x854c930) QObject(0x0)
KCrash: Application 'kdenlive' crashing...
------------

It seems to segfault when attempting to write to MainWindow. Would this likely be related to a bad KDE4 installation?

Here's the backtrace

-------------
[?1034hUsing host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 0xb567c8e0 (LWP 6122)]
[New Thread 0xb3633b90 (LWP 6125)]
0xb7f39410 in __kernel_vsyscall ()
[Current thread is 0 (LWP 6122)]

Thread 2 (Thread 0xb3633b90 (LWP 6125)):
#0 0xb7f39410 in __kernel_vsyscall ()
#1 0xb659b7d1 in select () from /lib/libc.so.6
#2 0xb7cb41a3 in ?? () from /usr/lib/qt4/libQtCore.so.4
#3 0xb7be930e in ?? () from /usr/lib/qt4/libQtCore.so.4
#4 0xb7b6618b in start_thread () from /lib/libpthread.so.0
#5 0xb65a209e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb567c8e0 (LWP 6122)):
#0 0xb7f39410 in __kernel_vsyscall ()
#1 0xb7b6dfab in waitpid () from /lib/libpthread.so.0
#2 0xb6dfc8cb in ?? () from /usr/kde/4.0/lib/libkdeui.so.5
#3 0x000017f0 in ?? ()
#4 0x00000000 in ?? ()
#0 0xb7f39410 in __kernel_vsyscall ()

I managed to fix this. I made two significant changes -- the MLT recompilation was certainly a fix, but I believe the first to also be a fix.

The first thing I did was remove old versions of mlt and kdenlive from /usr/local -- I was more recently compiling into /usr.

The second thing I did was recompile mlt passing it --avformat-swscale instead of --avformat-shared. However, I recompiled MLT several times before with --avformat-swscale and I'm convinced that wasn't working so I think that the old installs of mlt/kdenlive were conflicting and I noticed it getting profiles and such when examining an strace.

At any rate, it works now.

edit: updating with more information in case others run into this issue.

Running 'inigo -query producers' should return at least:
-----
producers:
- slowmotion
- vorbis
- avformat
-----

And inigo -query filters should return at least:
-----
filters:
- telecide
- motion_est
- vismv
- crop_detect
- autotrack_rectangle
- avcolour_space
- avcolor_space
- avdeinterlace
- avresample
-----