Sound clips are not cut where I visually cut them.

This is related to http://kdenlive.org/forum/problems-cutting-audio-multiple-audio-tracks but I decided to create a new topic where I can clearly explain my problem.

Let's say I record myself saying 'A-B-C-D-E-F-G' and save the result into an audio file (I tried ac3, mp3, flaac for this experiment).
Than I bring up a new project and I add my audio file into it. Finally I add the audio file into an audio track. So far so good. The audio is indexed and the visual preview is correctly created. I see and hear what was recorded.

Next step I will cut the audio file into 7 pieces. One for each letter. Finally I will remove B and D. The remaining pieces can be sticked together, or left with spaces between them, it doesn't matter.

What I expect to hear is 'A-C-E-F-G'.

However, 4 out of 5 attempts to do a cut like this, I will hear: 'A-B-C-D-E'. F and G are cut out.

It's like the original sound track continues playing over the cut in half pieces. Sometimes it happens that it realizes this and tries to correct it, so I end up with even a bigger mess. Something like 'A-B-C-F-G'. Not only wrong, but also unpredictable.

A month or so ago I had no problems like this, but since than there were a lot of updates to my Linux... Here are the versions of the applications related to this problem:

localhost ~ # ffmpeg --version
ffmpeg version 0.8.4, Copyright (c) 2000-2012 the Libav developers
built on Oct 28 2012 14:08:59 with gcc 4.6.3

localhost ~ # melt --version
melt 0.8.6

KDEnlive is v0.9.2, installed from Sabayon binary. KDE is v4.9.3. Pulse Audio is used. Audio hardware is on-board Intel Corporation NM10/ICH7 Family High Definition Audio Controller.

Could this problem be related to some settings? Is there any way to reset all the kdenlive settings for my current user? Would that help? Any other ideas?