specific images crashing kdenlive

i converted some a pdf to a series of images (png) and tried to add them to kdenlive but they show distorted and sometimes crash kdenlive.

I converted them to jpegs but they do the same thing.

I then tried other pngs and jpegs and they work perfectly.

I'm using kdenlive svn and know it is development , but since it only happens with certain images it might be in 7.8 too.

My system is archlinux and I uploaded one of the pngs so that anyone who wants test it can try http://www.mediafire.com/?dwt8ia5jkpthfh9

Forums:

this is my ffmpeg information incase it matters.

FFmpeg version git-2611e52
libavutil 50. 36. 0 / 50. 36. 0
libavcore 0. 16. 1 / 0. 16. 1
libavcodec 52.108. 0 / 52.108. 0
libavformat 52. 94. 0 / 52. 94. 0
libavdevice 52. 2. 3 / 52. 2. 3
libavfilter 1. 74. 0 / 1. 74. 0
libswscale 0. 12. 0 / 0. 12. 0
libpostproc 51. 2. 0 / 51. 2. 0

I can confirm the png image is distorted. It seems to be an issue in the QImage producer, because when doing the following:

melt pixbuf:foo.png
or
melt avformat:foo.png

it works correctly, but with

melt qimage:foo.png

The image is distorted. I will investigate, but can you tell me which distro / version you are using and which Qt version too?

I'm using archlinux and Qt 4.7.1

The pdf export has 34 images in the folder and when adding them to the time lime sometimes kdenlive crashes
and once when trying to delete them from the clip manager kdenlive crashed.

The crashing seems to happen when using multiple images of the type posted above.

Still investigating but the bug is in MLT's QImage producer. It currently does not support indexed or mono png images. Incredible nobody ever noticed it. I guess everybody's using the pixbuf producer for images.

So as a workaround, you can compile MLT with GTK's pixbuf module enabled and everything will work. I am currently fighting with the bug and will get back to you when it's fixed.

regards

Oh! I tried converting the images to tiff and jpeg with a Qt program and they still come in distorted and crash kdenlive.

edit: I converted to gif and the problem is gone for that format

The image is monochrome (1 bit per pixel) and likely stayed like that during your conversions. There was a bug in the MLT qimage plugin accepting monochrome and just committed a fix for the next release. Thanks for reporting.

Well, and i can confirm, using PNGs containing transparency, within kdenlive titles,
prevents EVERY effect from rendering.
I've struggled with this issue about two weeks. ;) - Glad i found this thread. :D

Looking forward to this bug gets fixed.

CU

Maik