Support for HF100 video files?

Hi!

 

Im just wondering how the support for HF100 (AVCHD .MTS) is in the latest Ubuntu and latest Kdenlive?

Can I start using the Kdenlive as editor without problems, or do I have to convert?

 

Appreciate all answers!

Best Regards Fredrik

Hello,

I have a HF100. You can edit .MTS files directly, but there are some problems. When rendering, sometimes you get black frames between clips, and sometimes you get clips that are completely gray.

What I do is convert my MTS files to MPEG4 at 36000 kbps (a very high bitrate), intra-frames only, as an intermediate format. Here's the ffmpeg line:

ffmpeg -y -threads 2 -i $1 -acodec libfaac -ab 256k -vcodec mpeg4 -vb 36M -s 1920x1080 -intra -flags +ildct+ilme $1.mov
 

Cheers!

Eduardo

Hello eduardo,

when I try your ffmpeg line everything works fine, besides it seems that the film runs at half speed (like slow motion).
I used ffmpeg unter windows and VLC-Player for playback.
Do you have a clue why its not running in the correct speed ? I google a lot, but didnt find an answer

You should try editing directly OR converting to DHxNX. Transcoding is a new feature of Kdenlive 0.7.4, so you should not need to use FFmpeg. Do not use Kdenlive 0.7.3, it has poor AVCHD support. Also use a very recent ffmpeg snapshot.

What is DHyNX ?

O.K. I guess I have to update to Kdenlive 0.7.4.
Hope the update is possible without problems on Kubuntu, but I guess it is :-)

I think the codec actually called DNxHD. It's available as a custom rendering profile in Kdenlive. Go to Settings - Download new render profiles. It checks online for available new settings. You should see it there. Then it will be available in the render window under Destination - Lossless/HQ - Custom.

It makes extremely large files but they edit quite perfectly to frame accuracy and there is really no quality loss. I've tried other lossless/hq settings and they didn't work too well for me.

Generally I can edit HF100 files in 0.7.4 directly IF I don't trim any from the front of the clip. With my shooting style this is most clips. If I really need a clip cut off from the front, sometimes it will fail to render correctly or the sound gets out of sync. Then I pre-render this clip to DNxHD, import that file, and I can do whatever to it.

hi

Converting to DNxHD codec seems a good thing, because on test file i can't edit avchd file, but DNxHD yes ...

But i need to convert all my rush and i don't know how to make that with kdenlive ... i find just how to convert one file after one ...with rendering windows ... i generate script but there is two file generated and i don't know how to modify the xml file ?

how can i do for make batch conversion ?

Thanks

nyme

Is there anyone with a HF200 camera, would the file format be the same?
Maybe a stupid question, but I am considering buying that camera, it
is actually cheaper than the HF100 ...

Tnx Thomas

I do have this camera. The format is basically the some (a higher bitrate is possible).

@nyme: can't you just select multi files and start rendering ? Or was'nt this your problem ?

hi

i need to convert 50 files ... i don't know how to make that with rendering in batch mode .. i don't understand how the two script generated work... and i don't want open each file, convert, open next file, convert ..

nyme

I don't understand your question/problem. You can open more than one file at once (pressing Strg or Alt) and start rendering.
No script is needed.

ok, ok in fact i don't need rendering at this time, just to convert the rush directly took from camera ...

imagine i have 50 files in avchd, my goal is to convert each file with codec DNxHD, before using each files in kdenlive, just because i can't use kdenlive with avchd files ...

So i need a script to convert 50 files or more ... some months after when all will be finish, i will not need script to export the full movie ...

hope my description is better ...

thanks

Having Canon HF200, i've experienced this problem as well. It was my fault: firstly I added some clips in MTS format, and then changed the project preferences (resolution from 1440x1080 to 1920x1080). After that, all the clips had extra time in the end.

The workaround was to change preferences _before_ import of any clips.

Of course I'm hoping that all this is unnecessary (now that I've figured it out) very soon as Kdenlive 0.7.5 is supposedly coming out in a day or so but . . .

This is an easy GUI method. I have a Canon HF100 but this ought to work with most 1080 AVCHD files. I installed WinFF through Synaptic. To speed things up go into Edit - Preferences and make sure Multi-threading is checked off.

You need to create a custom preset in WinFF - go to Edit - Presets. Click on Quicktime in the upper left box.
Preset Name: I used 'DNxHD'
Preset Label: 'DNxHD HQ transcode for MTS'
Preset Command Line: '-vcodec dnxhd -acodec pcm_s16le -s 1920x1080 -b 220000k'
Output File Extension: 'mov'
Category: 'Quicktime'
(obviously all without the quotes.)

THEN click Add/Update. You should then see in the upper right box your label 'MTS lossless transcode' in addition to default 'Quicktime MOV'. Now hit Save to exit.

In the main WinFF window, add all the files you want to batch convert, select Convert to 'Quicktime' and your Device Preset you just created, and the Output folder you want.

Hit the Convert button and it should go. A terminal window should appear where you can see the command process and progress of each file. I only got 8-9 fps so it will take a while, and the file sizes are enormous, but there it is.

Thanks. I will include winFF in the next live DVDs and USB keys for batch processing. It is always interesting.

thanks for the conversion with ffmpeg ....

nyme

Batching is also possible by creating a batch file/script:

1. Open a new file in your favorite text-editor and paste following code;

for f in *.MTS; do ffmpeg -y -threads 2 -i "$f" -acodec libfaac -ab 256k -vcodec mpeg4 -vb 36M -s 1920x1080 -intra -flags +ildct+ilme "${f%.MTS}.mov"; done

2. Save the file as batch.sh in the folder where your .MTS files are.

3. Go to this directory in your terminal.

4. Set permissions for the file;

chmod 755 batch.sh

5. Run the script;

./batch.sh

NOTES
- I have tested this but a backup before messing with your files never hurts.
- Thanks to eduardo from me too!

I needed to add some background music to a recent project. Unfortunately I have a ton of music in WMA format (don't ask.) Anyway, WinFF will batch re-encode these as well as MP3 or pretty much any other audio codec to WAV in the blink of an eye with existing audio presets, or of course you can make your own format preset.

Should also say that I've done a couple of half-hour-ish long video projects now with Kdenlive 0.7.5 in Ubuntu Jaunty 64 with excellent results. I batch convert all MTS files from the HF100 to DNxHD using WinFF. I've added jpegs from a still camera, composite some simple titles, do some cross-fades. I use three video and two audio tracks. Some color correction with the White Balance filter. A lot of volume manipulations with the volume keyframing. Some Brightness with keyframing.

The HF100 has pretty lousy white balance. A lot of mistakes in the too-magenta area, even outdoors in broad daylight. The White Balance filter can help on some of these, but on others I can't really get a good balance. You can do a white card manual white balance before each shot but this is a big PITA in casual filming.

Also the camera tends to overexpose badly outdoors. Again, the brightness effect can help, but I've learned to do a lot of exposure compensation while shooting anything outdoors - like minus 3 to 5 EV! Of course when you do this the exposure locks and any change in scene during a clip will often have wrong exposure.

The other thing is that I shoot in 30p mode exclusively, because I edit and playback on computers, media center, and web, and interlacing pretty much sucks on anything other than a TV set. Now, on the HF100 unfortunately 30p is still recorded to MTS in 60i format. For some reason, previously Kdenlive just handled this footage fine and played it back in a 30p or 29.97p project at the correct speed. But Kdenlive 0.7.5 does not handle the raw MTS files right. The audio and clip length is correct, but footage plays back and is rendered at 2x speed. This means that before I could possibly edit AVCHD directly in some cases, but now I can't, everything has to be converted to something that is purely progressive. (See my post on DNxHD conversions.) I think the MTS files are flagged as being 29.97p but Kdenlive is no longer handling this flag correctly. It would be nice to see this corrected.

The new problem with 2x playback speed must be due to some change in FFmpeg because Kdenlive and even MLT do not operate at that low of a level. You should test with a non-30p shot. Perhaps the attempts to improve AVCHD for the more common cases (50/60i) has degraded yours.