svn fails: testlensiface has undefined reference to lkdecore

Today's svn fails as below. AFAICS this is because Fedora no longer permits implicit linking. See:
https://fedoraproject.org/wiki/UnderstandingDSOLinkChange

How do I set up libkdecore as an explicit link?

sean

BTW, I tried posting this on the dev mailing list, but it disappeared into the ether. So if you're seeing it twice, I apologize.

/usr/lib64/ccache/c++ -O3 -march=native -mtune=native -fopenmp -msse4.1 -mfpmath=sse -ftree-vectorize -Wnon-virtual-dtor -Wno-long-long -ansi -Wundef -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -Wformat-security -fno-exceptions -DQT_NO_EXCEPTIONS -fno-check-new -fno-common -Woverloaded-virtual -fno-threadsafe-statics -fvisibility=hidden -fvisibility-inlines-hidden -O2 -DNDEBUG -DQT_NO_DEBUG -Wl,--enable-new-dtags CMakeFiles/testlensfuniface.dir/testlensfuniface_automoc.o CMakeFiles/testlensfuniface.dir/testlensfuniface.o -o testlensfuniface -rdynamic -L/usr/lib64/kde4/devel -L/home/photo/rpmbuild/BUILD/digikam/x86_64-redhat-linux-gnu/lib ../../../../lib/libdigikamcore.so.1.0.0 /usr/lib64/libQtCore.so -lpthread /usr/lib64/libQtGui.so -Wl,-rpath,/usr/lib64/kde4/devel:/home/photo/rpmbuild/BUILD/digikam/x86_64-redhat-linux-gnu/lib
/usr/bin/ld: CMakeFiles/testlensfuniface.dir/testlensfuniface.o: undefined reference to symbol 'KDebug::hasNullOutput(QtMsgType, bool, int, bool)'
/usr/bin/ld: note: 'KDebug::hasNullOutput(QtMsgType, bool, int, bool)' is defined in DSO /usr/lib64/libkdecore.so.5 so try adding it to the linker command line
/usr/lib64/libkdecore.so.5: could not read symbols: Invalid operation
collect2: ld returned 1 exit status
make[2]: *** [libs/dimg/filters/lens/testlensfuniface] Error 1

Hmmm.

I would say the problem is that you are trying to solve the compilation of Digikam in a Kdenlive forum...

regards
jb