Transitions window all greyed out.

I watched the video tutorial on adding transtions, and wanted to try it out myself. I tried and it doesn't seem to work.
The 'Transtitions' window is all greyed out - I cannot do anything there.
I can add a transition (right click on the clip in the timeline), but it doesn't seem to work right, and I cannot edit it.

In the video, the context menu has "Add Transition" and "Transition". My menu has "Add Transition" and "Delete Transition".

This is with Kdenlive 0.4 Using KDE 3.5.7 on Debian/sid. I tried compiling from SVN and got the same results.

Am I doing something wrong?
The video clips I am working with are 1440x1080, 25fps. I realise I won't be able to render at that resolution (yet) but I
understood that I should be able to work with those clips.

It's OK, I managed to figure it out. Once I create a transition, I need to double-click on the little red
box. Then the 'transitions' window comes alive and I can try things out.

Next problem: It seems to assume the transition is from the lower clip to the upper clip.
"cross fade", "push" and "wipe" all have an "invert direction" checkbox, but "PIP" doesn't.
So I cannot do a PIP transition from e.g. Track0 to Track1. Obviously I can slice up the clips
with the razor and put the "before" below the "after" but that isn't always convenient.

Now I just need to figure out why my the sound in my

RIFF (little-endian) data, AVI, 1440 x 1080, 25.00 fps, video: FFMpeg MPEG-4, audio: Dolby AC3 (6 channels, 48000 Hz)

files plays faster than the picture... If I use ffmpeg to convert them to

RIFF (little-endian) data, AVI, 720 x 576, 25.00 fps, video: FFMpeg MPEG-4, audio: MPEG-1 Layer 1 or 2 (stereo, 48000 Hz)

They work fine... Maybe it is the 6 channels??