Trouble with DVD structure

I have rendered my avi files into a single vob file. I have added two title tracks to separate the clips which is what I reference in the chapter. I click on the DVD wizard to create my menu and eventually the iso file, this is where things go wrong.

I set up a simple menu containing three items; play all, play chapter 1, play chapter 2. I set up my chapters to the start of the title screens. It gets to the end of 'Creating DVD Structure', and I get this error

STAT: fixed 7782 VOBUs
INFO: dvdauthor creating table of contents
INFO: Scanning /tmp/DVD/VIDEO_TS/VTS_01_0.IFO
ERR: no video format specified for VMGM

I've got no idea what this means or how to fix it. The IFO file is a binary file so I can't really look in it to figure things out.

Any help?

openSuse 11.3, kdenlive 0.78

Vas

Just tried a simple project with one title screen, one clip, no menu. I still get the same error at the same place.

Any help?

openSuse 11.3, kdenlive 0.78

Vas

73 views, five days and no replies, great stuff guys. Some idea of what the errors mean would of been nice.

Are there no developers of Kdenlive who frequent these forums?, is there any other place to ask questions?

I'm now having to use DVDStyler to generate my menu's and finalise the dvd.

Vas

hi vserghi,

I don't have this problem on my system (Fedora 14 x86-64) and latest SVN versions built from source.

Please follow the steps for reporting a bug documented here (Contribute -> Bug Reports):
http://kdenlive.org/bug-reports

Please make sure you provide all the information requested on that page. Additionally, it is often helpful to note where you got the program (as a package, repository name, built from source), full version number information (e.g. 0.7.8 - which you did note). And in your case maybe the dvdauthor version. Its also useful to note the ffmpeg and mlt versions. You should be able to find this in our package manager (not sure what it is called in Suse).

Hope this helps, Geoff

You are probably running into the dvdauthor 0.7 compatibility issue, please look at:
http://kdenlive.org/forum/dvdauthor-07-incompatibility

regards

The reason for your error is probably that no default video format is set in your shell environment.
Open a terminal window, export the variable VIDEO_FORMAT (I have used PAL, but you can also use NTSC, depending on your format) and then launch kdenlive from the terminal window:

$ export VIDEO_FORMAT=PAL
$ kdenlive

If it works, you may want to add the line "VIDEO_FORMAT=PAL" (or NTSC) to the file /etc/profile. Upon your next login, kdenlive will work also when launched directly from the menu.

Brgds
Axel

Thanks, axel.spoerl!

I had the same issue as the OP, and your tip solved it!

vkr
Martin

$ export VIDEO_FORMAT=PAL

did NOT work for me, but Dan Dennedy's tip from here worked:

http://kdenlive.org/forum/dvdauthor-07-incompatibility

$ echo PAL > ~/.config/video_format

The link from the above post worked for me also. Good luck bro.